Announcement

Collapse
No announcement yet.

Customer Service: Order Shipping, After-Sale Problem, Post Here!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Jole View Post
    Please check order 5158139, it has passed more than 120 days since i ordered, and package is nowhere to be found. I ask for refund, because all deadlines are passed. Geekbuying support do not want to help.. it is parcel GT King payed 91 euros..
    I do not recommend to buy through Asian sellers because of this...it is always same...better get at ****.com or Amazon...

    Comment


      As mentioned
      The CV19 thing has made a mess of all shipping, be patient
      Not much anyone can do about it.

      tЯeboЯ
      Please consider
      Donating to Freaktab

      Comment


        Originally posted by Jole View Post
        Please check order 5158139, it has passed more than 120 days since i ordered, and package is nowhere to be found. I ask for refund, because all deadlines are passed. Geekbuying support do not want to help.. it is parcel GT King payed 91 euros..
        Hi Jole,

        Sorry for the inconvenience.
        Our Customer Service Team has sent email to you.
        If you want to get refund or a new replacement,just feel free to tell us in the email.
        Coupons Updated Every Day: https://bit.ly/2RnbHUi

        Deals for TV Boxes & Mini PC: https://bit.ly/2s7ugxD

        Comment


          hello,
          who do contact about a box i ordered that failed?
          Order #5195128.
          Thanks

          Comment


            Originally posted by Twisted714 View Post
            hello,
            who do contact about a box i ordered that failed?
            Order #5195128.
            Thanks
            Hi ,

            Sorry for the late response.
            Could you please tell me more details about the problem of your order?
            Coupons Updated Every Day: https://bit.ly/2RnbHUi

            Deals for TV Boxes & Mini PC: https://bit.ly/2s7ugxD

            Comment


              Originally posted by GeekBuying_Rep View Post

              Hi ,

              Sorry for the late response.
              Could you please tell me more details about the problem of your order?
              the wifi on the box stopped working. and wouldn't reset. no connectivity. after running normally for over a month. tried to flash with GTKING_910P0_wol.img. the box did not boot again. subsequent flashes do not make the box work. i can connect to the computer, the eyes are green, the box accepts the flash. but has no output to the hdmi port. i used usb using burning tool 2.1.7.0.
              Thanks
              Last edited by Twisted714; 07-28-2020, 09:49.

              Comment


                For what it is worth, I finally found out what was wrong with my Android TV Box:

                https://www.geekbuying.com/item/R-TV...ox-384405.html

                Yes. I know this information is old and the device is no longer available, but still relevant to other devices.

                The Power Supply, which was supposed to supply 5V/2A DC power to the device, gave only half the power.

                Looks like the Amperage, I believe, was less than 1A.

                After opening up the Power Supply, it appears that one of the internal components (a capacitor, I believe) had leaked out.

                Replacing the Power Supply with another one of equal power (10 W) solved the problem.

                As a general rule of thumb, it would be a good idea to check the Power Supply Voltage/Amperage/Wattage

                if any problem arises with any kind of device.

                https://www.youtube.com/watch?v=R4YRZw8hsA4

                https://www.youtube.com/watch?v=cFdG7NSqzrk

                Thank you for reading my reply.

                Comment


                  Originally posted by Twisted714 View Post

                  the wifi on the box stopped working. and wouldn't reset. no connectivity. after running normally for over a month. tried to flash with GTKING_910P0_wol.img. the box did not boot again. subsequent flashes do not make the box work. i can connect to the computer, the eyes are green, the box accepts the flash. but has no output to the hdmi port. i used usb using burning tool 2.1.7.0.
                  Thanks
                  Hi,

                  Did you try to update the firmware?
                  https://forum.freaktab.com/forum/adv...pdate-20190920
                  If not,you can check our firmware update .
                  Coupons Updated Every Day: https://bit.ly/2RnbHUi

                  Deals for TV Boxes & Mini PC: https://bit.ly/2s7ugxD

                  Comment


                    Is there a year 2020 ROM available for the T95 MAX Allwinner H6 4GB/32GB 6K Android TV Box ???

                    WeChip is no longer sharing the most recent IMG file on their official site download page, currently bricked my T95 MAX, and would appreciate if you could share the firmware image file.

                    Comment

                    Working...
                    X