Announcement

Collapse

Geekbuying 7th Anniversary with great Promotion!

Around the world, you can find a lot of online stores. But in short, one of the most loved by users is Geekbuying.
Not only because it has an impressive number of products that are in all categories, but also because it presents us with
great promotions. Freaktab and Geekbuying have been grown together so let us celebrate it!

https://forum.freaktab.com/forum/adv...sary-is-coming
See more
See less

MX10 ANDROID 9.0 RK3328 TV BOX FIRMWARE UPDATE 20190108

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    hi all, i didn't realize there was a topic for this device, so i posted to an earlier version's one....

    did anybody else experience an issue with the dropdown menus from apps in this Android version?

    i have 2 mx10 boxes, one is Android 7 i think, and the new one came with Android 9.

    With this new one i can't get the HBO GO app to work (european version, mind you). WIth the previous device it was ok, and i think it's an android 9 thing: when you start the app, it asks if you have a direct subscription or through another company. I must choose another company as it is what it is, and then it gives me a dropdown of these companies. Now apparently this handling of dropdowns must be a pretty annoying bug or something, because when i click on it, the app closes immediately, without an error message. And there is no way to get through it. I tried everything, from a browser, etc, but even if i manage to log in from the browser, the login does not transfer to the app, and the video player does not work at all from a browser.

    it's quite mindblowing for me that such a thing can happen, and i suppose there is nothing i can do to get around it. But if any of you has an idea, please let me know

    Comment


      #17
      Originally posted by waryou303 View Post
      hi all, i didn't realize there was a topic for this device, so i posted to an earlier version's one....

      did anybody else experience an issue with the dropdown menus from apps in this Android version?

      i have 2 mx10 boxes, one is Android 7 i think, and the new one came with Android 9.

      With this new one i can't get the HBO GO app to work (european version, mind you). WIth the previous device it was ok, and i think it's an android 9 thing: when you start the app, it asks if you have a direct subscription or through another company. I must choose another company as it is what it is, and then it gives me a dropdown of these companies. Now apparently this handling of dropdowns must be a pretty annoying bug or something, because when i click on it, the app closes immediately, without an error message. And there is no way to get through it. I tried everything, from a browser, etc, but even if i manage to log in from the browser, the login does not transfer to the app, and the video player does not work at all from a browser.

      it's quite mindblowing for me that such a thing can happen, and i suppose there is nothing i can do to get around it. But if any of you has an idea, please let me know
      Hi ,

      Sorry for the issue.
      Please kindly send me product link to confirm the version.
      Coupons Updated Every Day: https://bit.ly/2RnbHUi

      Deals for TV Boxes & Mini PC: https://bit.ly/2s7ugxD

      Comment


        #18
        i want upgrade my mx10 tv box


        Click image for larger version

Name:	54432998_10213257425766333_656693631905693696_n.jpg
Views:	114
Size:	64.8 KB
ID:	767205

        work Android 9 on my box ?

        Comment


          #19
          Originally posted by GeekBuying_Rep View Post

          Hi ,

          Sorry for the issue.
          Please kindly send me product link to confirm the version.
          hi

          is this what you mean by product link?

          https://www.geekbuying.com/item/MX10...ox-388684.html

          Comment


            #20
            Originally posted by Bimbo80 View Post
            i want upgrade my mx10 tv box


            Click image for larger version

Name:	54432998_10213257425766333_656693631905693696_n.jpg
Views:	114
Size:	64.8 KB
ID:	767205

            work Android 9 on my box ?
            Yes,please check the firmware.
            Coupons Updated Every Day: https://bit.ly/2RnbHUi

            Deals for TV Boxes & Mini PC: https://bit.ly/2s7ugxD

            Comment


              #21
              Click image for larger version

Name:	IMG_20190325_192706.jpg
Views:	94
Size:	143.0 KB
ID:	767404
              Attached Files

              Comment


                #22
                Originally posted by Bimbo80 View Post
                Click image for larger version

Name:	IMG_20190325_192706.jpg
Views:	94
Size:	143.0 KB
ID:	767404
                Hi,

                You can update it to Android 9.0 if you want.

                Android 9.0 can work on your box.
                Coupons Updated Every Day: https://bit.ly/2RnbHUi

                Deals for TV Boxes & Mini PC: https://bit.ly/2s7ugxD

                Comment


                  #23
                  thanks upgrade done

                  Comment


                    #24
                    hi i upgraded my box it said successful when i plug it into my tv mx 10 logo shows straight after i get a green screen anyone know how to fix or what is wrong?

                    Comment


                      #25
                      Dont upgrade this box to android pie if you are lucky enough to have it with older android.
                      Nothing works. Tried to put another launcher to bypass it's awful launcher and at every restart it puts back the stock launcher although I set the new launcher as the default.
                      Location doesn't work, launcher has a weather widget that doesn't work.
                      Kodi 18.1 crashes all the time to desktop.
                      I am waiting for the day that someone will make an Android TV rom to use this box again (or a root will be found so to put another firmware or perform a downgrade).

                      Comment


                        #26
                        Originally posted by DaMeZ View Post
                        hi i upgraded my box it said successful when i plug it into my tv mx 10 logo shows straight after i get a green screen anyone know how to fix or what is wrong?
                        Hi ,

                        Could you please send me a picture to show the problem?
                        Coupons Updated Every Day: https://bit.ly/2RnbHUi

                        Deals for TV Boxes & Mini PC: https://bit.ly/2s7ugxD

                        Comment


                          #27
                          Originally posted by Pallaros View Post
                          Dont upgrade this box to android pie if you are lucky enough to have it with older android.
                          Nothing works. Tried to put another launcher to bypass it's awful launcher and at every restart it puts back the stock launcher although I set the new launcher as the default.
                          Location doesn't work, launcher has a weather widget that doesn't work.
                          Kodi 18.1 crashes all the time to desktop.
                          I am waiting for the day that someone will make an Android TV rom to use this box again (or a root will be found so to put another firmware or perform a downgrade).
                          Hi ,

                          Could you please send me a picture to show the problem?
                          Coupons Updated Every Day: https://bit.ly/2RnbHUi

                          Deals for TV Boxes & Mini PC: https://bit.ly/2s7ugxD

                          Comment


                            #28
                            I cannot seem to find this version anywhere. Where did you download 2.59 from?

                            Originally posted by jibmaster View Post
                            I finally got it working. Just encase anyone else is having similar issues as me what I did was:
                            I used Android Tool v2.59 - clicked UPGRADE FIRMWARE tab, and loaded the android 9 firmware. I made sure the program recognized my android box by pushing the toothpick in the reset button and plugging in the usb cable. Once android tools recognized my android box I clicked erase flash, which erased successfully for me. (When I tried to do this with factory tool v1.6 it kept failing for me) (see pic above). Next I clicked on the UPGRADE tab and it installed android 9 firmware successfully. Hooked it up to the tv, and checked in the about to confirm it was Android 9.

                            I have found 2 issues so far with this firmware, I am wondering if anyone else is having the same issues:
                            1. When launching the google playstore, it just crashes. if you click on it multiple times it was will say it is doing an update but never finishes. Is there a fix for this?
                            I tried force stopping google play store, and uninstalling it to the factory version that came with the app, it will load once, but once you close out and reopen it crashes again.

                            2. The weather app on the home screen won't recognize my city? I type it in and hit ok, and it does nothing. Does anyone know how to get this working?

                            Comment


                              #29
                              On latest firmware ,android pie, we have no root , default key pressed on physical keyboard is q instead of enter , no posibilities to choose launcher. Wifi is very slow , it would be nice if it support usb wifi adapter.
                              Last edited by mihaianti; 05-10-2019, 01:45.

                              Comment


                                #30
                                Hello, I have an RK3328 Wifi 2.4G/5G TV Box YSE 4GB 64GB with 7.1.2 firmware and I want to put android 9.0. Someone could help me? Thank you

                                Comment


                                • mo123
                                  mo123 commented
                                  Editing a comment
                                  I think support for your device died from the moment it shipped from the factory.
                                  You can try different firmwares but risk bricking your device, also make sure you have a backup of the 7.1.2 firmware before trying anything.
                              Working...
                              X