Announcement

Collapse
No announcement yet.

H96 Max plus, 4gb, 64g froze after just 1 week, how can i load new firmware

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    H96 Max plus, 4gb, 64g froze after just 1 week, how can i load new firmware

    hi, i bought a new h96 max plus 4g, 64g, 8.1 , running kodi 18, loaded nolimits build worked great, then loaded 1 extra addon, seemed to work ok, next day started the box and it is stuck on the boot up screen the logo icons just keep turning, i tried the reset button no luck

    tried loading new firmware using the batch tool and then tried the factory tool but seems the firmwares i tried are not correct, but it is a bit complicated so might be me messing up,

    can anyone advise what firmware does work ? and instructions that cover the complete procedures ?

    i spent a day trying so many ways no luck , i got the firmware loaded into the batch tool v1.7, loaded driver assit onto my pc, held the reset button , plugged in the box to pc, clicked run, and i get failed message, i tried this with 2 different firmwares i got from what seem good sources but i just cant fix this box , so am now thinking buy another box....an ideas ? thanks

    #2
    hw defect
    send back to shop

    Comment


      #3
      This box does not work properly with Kodi from google play due to libraries. Give it this version:

      http://mirrors.kodi.tv/nightlies/and...64-v8a/master/

      Comment


        #4
        i cant load any new version of kodi as the box is locked on the startup logo, i cant do anything, thats why i thought rest it with new firmware, i will contact the **** seller maybe i can get replacement

        i also have a mx10 box, its working with apps that are already on it , but i cannot load any new builds or addons onto it, i might uninstall kodi and load the version Gante suggested....

        Comment


          #5
          https://mega.nz/#F!B8gBhAKD!bZHKBR5FhfIAc93zd0aE6Q

          For 4/64 is last:
          RK3328_DC_H96_MAX+_HS2734_8.1.0_20181227.0527
          but the box gets very hot.

          I also have 4/64 and I have it there:
          RK3328_DC_H96_MAX+_noaddon_SSV6051_RTL8189_8.1.0_2 0181215.1524
          it's not wifi but it does not matter. The box is not that hot.

          Comment


            #6
            i tried the firmware ending in 0527 it was loaded into the tool, i held reset button, then plugged in usb to pc, then pressed run, then i get failed message, tried a few times, i got firmware from that mega site, i did have issues opening files but eventually got it loaded into the tool, and ticked the restore option

            i have not tried the other firmware you suggest, but i have called seller and they want me to send back so i will see how that goes,

            also on the mx10 i uninstalled kodi, went to playstore and downloaded kodi liea , then loaded nolimits build and yes all good the mx10 is working really good, so i can use it till this h96 gets sorted....thanks

            i just went back to check on the 0527 firmware i tried, i clicked on it and got a message firmware is corrupted, so that explains it, maybe i stuffed it up with my attempts to open file.......

            Comment

            Working...
            X