No announcement yet.

Chuwi VX3 phablet (my new toy)

  • Filter
  • Time
  • Show
Clear All
new posts

    Chuwi VX3 phablet (my new toy)

    Main Features
    Operating System Android 4.4
    Model CHUWI VX3
    Announced 201404
    Color Silver
    Shell Material: Plastic
    Size 7 inch
    Resolution 1920*1200
    Display Technology IPS Capacitive touch screen
    Visible Angle 180°
    CPU Manufacturer MTK
    CPU Model MTK6592
    CPU Core Octa Core
    CPU Speed 1.7GHz
    GPU Model Mali-450MP4
    GPU Speed 700MHz
    RAM Type DDR3
    RAM 2GB
    Hard Drive Type NAND FAST FLASH
    Hard Drive Capacity 16GB
    Extend Card 32GB
    Other Functions
    Camera 2.0MP+8.0MP
    3G YES
    Bluetooth YES
    G-Sensor YES
    Software Youtube/Facebook/Twitter/MSN/Android market/Skype/Calculator/Google Mail/Google maps/iReader/Quick Office/Google store
    Media Formats
    Audio FLAC/APE/WAV
    Speaker/MIC Built in stereo speakers/Built in Microphone
    Picture JPG/BMP/PNG/GIF
    Battery Type Li-ion battery
    Battery / Run Time(up to) About 4-7 hours
    Power Device Type AC Adapter, AC 100-240V
    Charging Voltage DC 5V 2A
    Wireless Connection WIFI
    Wireless Protocol 802.11 b/g/n
    Language Multi-language support
    Dimensions ---
    Net Weight ---
    Ports 1 x Micro USB/MHL port
    1 x Micro SD Card slot
    1 x Earphone jack
    1 x SIM card slot
    What’s in the box 1 x Tablet PC
    1 x Micro USB cable
    1 x Charger
    1 x User manual
    Well.. the fridaynight me to buy this unit..
    -note: with price diffences of 60euro..per site, its worth digging a little
    -I used DHL.. So,it could cost me upto 34euro to import this baby.. but thats the risk

    other members can give me advice, share thoughts opinions,
    share links to any updates or custom fw out-there..

    I will test it in the next few weeks. Will keep you informed.

    Well.the unit came yesterday(with tax)
    First look and feel... Looks are great, its fast and gps works realy good
    The unit Gui is horrible, the 'home' button does not go home.. Sometimes (multitasking)
    Browsing is abit..laging while going up/down in landscape mode
    Pretty.. But user-unfriendly

    I enabled "developer" option "show cpu usage"
    -it shows 12.47 in idle (looks high to me.. Most of my tvbox's use 1.00 and my phone 7.00)

    Antutu video tester, score 382 with lots of red.. flv,avi/ac3,real4,wmvv2,mpeg and all 2k/4k media

    -camera only works after reboot (or else : gallerie stopped unexpected)

    I think, i need to root this unit.. And disable some stuff
    Last edited by mitchell4you; 12-16-2014, 14:41.


      Geekbuying found a new firmware:

      I just installed it...

      First impression,
      It starts with a wizard in lng ch..
      After changing lng..
      I found imei code still there
      I dont see the 3d launcher (better)
      I changed brighness.. it can be set allot lower.. then before (better)
      Develop/cpu usage shows 8.18 (alot better idle)
      I dont see supersu app (there is no root)(tried the from ifive and s89 its no go)
      Gps works (abit slower..then pre-fw)

      Missing a little bit,
      The previous radio app was more fance looking
      The previous explorer app was more adv with ftp-server support

      It looks like this fw.. is better at powersavings

      The screen.. is just beautifull using spmc 14 beta2
      I also like the gps.. (after first using wifi to get its gps location in life) it works without wifi/sim
      Sadly there is navigation apps (only google-maps.. )

      Futher testing needed

      intresstingly found som firmwares..
      And a freaktab custom (thanks rriley )
      Last edited by mitchell4you; 01-02-2015, 11:55.


        to continue.. installed rriley rom,
        its the same rom posted by gkb (#3) but tweaked/pre-rooted
        main difference: (i can see)
        its english from get go
        multi user support (did not see that option on gkb fw.. )
        root (tweak/backup/freeze.. stuff now works....note:cpu tweaking will not work)
        disabling power save, will now ask for a reboot (so, it seems to
        It has a red bootscreen..

        Nice work rriley.. (donation send)

        the last..nags i still have..
        browsing still not smooth scrolling.. tried a few browsers
        -no h/w acc it seems..even after tweaking some browsers.. and forcing hw acc..its still not as good as prev.tabled
        The home-back-menu buttons..the are not responding sometimes..and not to be seen in the dark (no glow)

        Some questions.. came to mind it possible.. to enable s/w home-back-menu ? (like editing build.prop)



          Try an app called Button Savior from Play Store. It has a tab you can press that brings up navigation buttons.
          Freaktab Developer, Product Reviewer, Moderator and "Flashaholic".
          Read my BIO Here
          Be sure to donate to support If any of my development work makes a positive difference for you, please make a donation to support future RileyROM's.
          Donate here


            Thanks rriley.. Button savior works really well..
            -great tool to have..



              I have one and it's really a great toy !

              I use many Android devices and this one is the most impressive I ever seen!

              This phone (okay, big for a phone but not to much for me) is really thin and back is real metal, not painted plastic as often !
              Weight is really low, you forget you have it on hands.
              Screen is amazing : 1920x1200 is pure imersive experience... hard to go back now!
              Good photo capture (sure, better exist), good enough to use it everyday.
              Sound is impressively powerfull with the internal speaker. Maybe not as good on earphone output.
              OS 4.4.2 with absolutly no lag (swipe between apps is better than I could see on last apple tablets).

              Many website are out of stock with this device - I found it at and I use DHL : ordered on monday morning, at home 2 working days later! that's what I called a express service

              Better to put it in a small shoulder bag because in pant, it's not easy (even in baggy worker pant).
              Never try a device like this... you will buy one !


                So, i decided to upgrade from rrily's rom to cm13 2.2 from 4pda (android 6 based)

                To install TRWP : I used the new TRWP app from market \ selecting recovery.img
                To boot into TRWP : I used Petrus reboot, boot to recovery
                Wiped the devices (except:recovery/sdcard) (sdcard holds the new firmware)
                then Home/reboot/reboot to recovery
                then Install/select storage sdcard/zip file
                few minutes later...done / Reboot

                _______ CM13 v2.2
                First boot some Russian : select your country and GUI language changes accordingly

                nice looking GUI/fast

                The bad
                No WiFi/BT/camera/FM radio/shutdown timer
                titanbackup says no root (developer/root access for apps is enabled)
                this ROM looks like a failer...
                logedin as owner...yet no permission sometimes to developer options or users? setting made as owner..are not saved on reboot
                totalcmd created a map in / is working

                will try another rom..tomorrow
                PS..under developer can enable : boot to recovery

                Zip file corrupt...

                _______ Cm12.1 based on 5.1
                First boot some Russian : select your country and GUI language changes accordingly

                nice looking GUI/fast
                wifi works! sims online, sdcard working,camera working, radio working

                looks like..I will keep using this one...for awhile...
                installed : exposed , soundmod ainur, viper4android, some black cm theme...all is looking\souning great
                Last edited by mitchell4you; 02-19-2017, 23:04.