Announcement

Collapse
No announcement yet.

Rooting a RockChip Tablet

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Rooting a RockChip Tablet

    Hi all,
    I put my hands on a Philips 10BDL4151T, an Android 7.1.2 tablet powered by a RockChip rk3368.
    My goal is to root it, and these are my findings/what I tried so far:

    -AIO root tools (KingRoot et al.) don't work
    -Bootloader unlock works fine
    -RockChip AndroidTools for flash dump works fine
    -fastboot can boot images only up to 16MB
    -Dumped recovery.img doesn't boot (it's 32MB)
    -No official sources/updates/OTA images are available.
    -None of the available TWRPs for rk3368 devices found in the wild boot: the ones in AOSP format are too large and the others in KRNL format seems not compatible (nothing on screen and usb stops working)

    The last thing that came to my mind was dumping boot.img and patching it with Magisk Manager, but i haven't flashed it back yet because I'm too afraid of bricking it (and I don't know if AndroidTool can be used to restore a bricked device)

    What should i do? Is writing back patched boot.img safe? Can I eventually recover from it?
    Or are there other ways?

    Thank you

    #2
    I managed to root a tablet with a rk3188 chip with the PC version of Kingroot so it might be worth a shot

    Comment


      #3
      Already tried, doesn't work.
      I also rooted a rk3188 with KR, but it was an Android 4.

      Comment

      Working...
      X