Unconfigured Ad Widget

Collapse

Announcement

Collapse
No announcement yet.

Pipo M9 Pro RileyROM 3.4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Pipo M9 Pro RileyROM 3.4

    Here is yet another port from M7 Pro firmware...which is an update with bug fixes dated 7/8/14.

    This ROM includes the firmware from that M7 Pro ROM, customized for the M9 Pro with kernel407 included.

    As usual, this ROM is:

    Rooted
    Debloated
    Init.d/Busybox support
    User app space options from 1 to 12gb (4gb default)
    Auto Install available (as with my other ROM's)
    TWRP Recovery by Abdul_pt...installed after first boot
    Google Play Store fixes
    All of the typical RileyROM features

    Reboot app by Petrus
    Flash Tool by Finless
    Boot animation by me

    Download

    Enjoy!!!!!!!!!

    Don't forget to donate to support future RileyROM's here on Freaktab...that really helps me stay up to date on the latest devices.
    Randy
    Freaktab Developer, Product Reviewer, Moderator and "Flashaholic".
    Read my BIO Here
    Be sure to donate to support Freaktab.com. If any of my development work makes a positive difference for you, please make a donation to support future RileyROM's.
    Donate here

    #2
    Happy, to finally upgraded from RR 2.6b to RR3.4

    I've tried to upgrade to newer RR with no success, unit reboots within a minute. I believe to have the 1st version of pipo m9 pro (Spring 2013).

    What i've done is loaded RR 3.4 and then loaded RR 2.6b with everything unchecked except for the kernel. And the unit, once it bootup for the first time, it has not crashed, rebooted and i loaded go back and restore app and restored my previous app.

    It started a little slow at first, but after i rebooted myself, started running smooth again..I like to continue to upgrade 'till i find a working miracast function. My only solution for that has been ezcast app with measy a2w wireless display adaptor.

    Comment


      #3
      I just installed the 3.4, and so far so good. It's running nice and smooth. it also looks stable up until now. Let's see what is does after running for a day or 2. Randy, a great solution as always.

      Aargh, first reboot just now.
      Last edited by Starcopy; 07-13-2014, 06:47.

      Comment


        #4
        Random reboots when opening programs. I downloaded a different camera ap (A Better Camera- one i usually use) and it just reboots everytime.

        Comment


          #5
          One thing you might try...if you are having multiple reboots it to erase IDB a few times before you flash. Sometimes there's still leftover data that causes conflicts.

          Otherwise, it must be a compatibility issue with a certain app.
          Randy
          Freaktab Developer, Product Reviewer, Moderator and "Flashaholic".
          Read my BIO Here
          Be sure to donate to support Freaktab.com. If any of my development work makes a positive difference for you, please make a donation to support future RileyROM's.
          Donate here

          Comment


            #6
            Originally posted by rrileypm View Post
            One thing you might try...if you are having multiple reboots it to erase IDB a few times before you flash. Sometimes there's still leftover data that causes conflicts.

            Otherwise, it must be a compatibility issue with a certain app.
            I've tried erase DB several times, but it didn't work. Now I have switched from Dalvik to ART, but the same warm reboots keep coming up. The app doesn't matter so much.

            Another problem after switching to ART: After each warm reboot, it starts optimising all apps again. So that's not a good solution eather, because it consumes al large amount of time.

            If I go back to 3.0 or 3.1, it al runs without any problems. So there must be a difference in theM7pro part. But what? I don't know. I keep trying for another day or so, but otherwise its back to the old one.

            I hope that it's not a hardware thing like with the M8pro.

            Edit:

            There is no need to run an app. I just started it, and that was enough for a reboot. I already switched back to dalvik and rebooted the tablet twice. Then let it go to sleep. A push of the button did the rest.
            Last edited by Starcopy; 07-13-2014, 10:09.

            Comment


              #7
              Originally posted by Starcopy View Post
              I've tried erase DB several times, but it didn't work. Now I have switched from Dalvik to ART, but the same warm reboots keep coming up. The app doesn't matter so much.


              There is no need to run an app. I just started it, and that was enough for a reboot. I already switched back to dalvik and rebooted the tablet twice. Then let it go to sleep. A push of the button did the rest.
              Also getting multiple reboots. Think I'll switch back for the moment. Hoping Randy comes up with something from the Omni rom 4.4.4. It appeared to be stable - no reboots.
              Regards

              Comment


                #8
                It seems that the problem lies with starting and stopping from eather an app, or the tablet itself. As long 'm using the app, there is no problem.
                Last edited by Starcopy; 07-14-2014, 10:37.

                Comment


                  #9
                  CPU Control / ROM

                  Hey Guys,
                  Does our Pipo ROM / Kernel support OndemandX for the Governor?

                  Oh by the way Randy, Did your P1 come in yet?
                  Last edited by PipoM9Pro; 07-14-2014, 17:19.
                  People who think they know everything are a great annoyance to those of us who do.

                  Comment


                    #10
                    Originally posted by Starcopy View Post
                    Another problem after switching to ART: After each warm reboot, it starts optimising all apps again. So that's not a good solution eather, because it consumes al large amount of time.
                    I think mine is still on 3.0 and it does that as well, but I don't think I've ever seen a reboot, despite running on a low voltage overclocked to 1704 / 768 kernel.

                    I rarely do a warm reboot, so it isn't a huge deal, but it may make me go back to Dalvik, even though that takes Antutu down to under 20,000

                    Comment


                      #11
                      Re: Pipo M9 Pro RileyROM 3.4

                      Originally posted by PipoM9Pro View Post

                      Oh by the way Randy, Did your P1 come in yet?
                      Not yet. Still waiting on inventory to arrive from Pipo.
                      Randy
                      Freaktab Developer, Product Reviewer, Moderator and "Flashaholic".
                      Read my BIO Here
                      Be sure to donate to support Freaktab.com. If any of my development work makes a positive difference for you, please make a donation to support future RileyROM's.
                      Donate here

                      Comment


                        #12
                        Good luck

                        Originally posted by rrileypm View Post
                        Not yet. Still waiting on inventory to arrive from Pipo.
                        Are you dealing with Ben and or Sharon @ pipo? I got my 2 M9Pros from them directly. We evaluated them for a corporate environment. But the weak GPS was really the factor that hurt the M9 Pro. So now I have them for personal use...next is either the P1 or Talk 9X.
                        Just waiting for the hardware/pcb dust to settle....

                        Good luck and hope it comes in soon.
                        People who think they know everything are a great annoyance to those of us who do.

                        Comment


                          #13
                          Freezes/Reboots

                          Getting a lot of random reboots and freezes every 10-15 minutes of use on my m9 pro. Is the 3.3 more stable anyone?

                          I also have trouble with MX Player freezing the video (audio keeps playing) every so often (mostly on SW, sometimes on HW) and having to switch from SW to HW to get it working again. HW+ works but messes up when you scroll forward or back.

                          IDB was cleared and all that, followed the instructions to a T.

                          Comment


                            #14
                            Windows 8 drivers

                            Guys, a bit OT but maybe someone can help. When I first got my M9Pro there were no windows 8 drivers for the RK3188. I'm thinking of upgrading my computer but I'm worried about not being able to upgrade my M9PRO if I get a copy of windows 8. I see that there are new drivers on the rockchip page for the RK3188 that say they support WIN8. Do these new drivers work? Can I connect my M9PRO to windows 8 now? Thanks

                            Comment


                              #15
                              I have not had a problem with Windows 8.0...it works as well as my Windows 7 PC, but so far Windows 8.1 is still a problem with Rockchip drivers...unless I've missed something.

                              For now, I'm refusing to upgrade to 8.1.
                              Randy
                              Freaktab Developer, Product Reviewer, Moderator and "Flashaholic".
                              Read my BIO Here
                              Be sure to donate to support Freaktab.com. If any of my development work makes a positive difference for you, please make a donation to support future RileyROM's.
                              Donate here

                              Comment

                              Working...
                              X