Unconfigured Ad Widget

Collapse

Announcement

Collapse
No announcement yet.

[ROM] MMK TRONFY X2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [ROM] MMK TRONFY X2

    Hi guys, welcome to my rom for the Tronfy X2

    This is a rework of the Rom posted by Trigtop with a twist. Feel free to state any opinions or requests. There is a lot more i want to do/fix.

    Let's get down to business, what's in it:
    • TWRP 2.8.7.0, fully functional including ADB sideload
    • Updated root
    • Updated Busybox
    • Updated all Google apps and added some missing ones
    • Clean all that Dragon resource eater spyware crap
    • Added a Calculator, Gallery replaced LatinIME for LatinIMEGoogle, replaced Calendar for GoogleCalendar, replaced DeskClock for GoogleDeskClock
    • Added some preinstall apps. Terminal, Reboot, ES File Explorer, AdAway...
    • Added Nano text editor. Open Terminal and type nano
    • Added Bash enviroment. Open Terminal and type bash
    • Added init.d support. I put 3 scripts in there, one for buffer, one for userinit script and another for usb
    • I added a script to force PC connection. Open Terminal and type "usb.sh" as root. Sometimes it requires you to run the script twice.
    • Increased TCP buffers
    • Added a Nexus10 build.prop in system root in case you want to spoof your device.
    • Probably some more ....


    Download
    --> TRONFY X2 MMK



    Instalation
    • Unzip the file
    • Open Phoenix Suit, and select the image file
    • Power off the X2. With it connected to the PC, insert a paper clip in the reset hole and press and hold it. Now press power button.
    • Updating process should start automatically



    Some Tools

    I have uploaded some tools if anyone needs them

    if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
    then mv $user.contact.up.post /.trash; set response($response.type = ignore);
    $user.up.post.ignore_in_future = true; fi;


    #2
    Will give it a go for sure, and all In, looks very good
    Update went smooth
    Kodi looking OK.
    Netflix looking OK.


    Logitech k400r appears to loose the abilty to type at random times
    Enabled hardware keyboard not helping, it works then drops our.
    Solved: used extension cable for dongle OK



    Thanks
    Last edited by trebor; 09-02-2015, 03:36. Reason: update
    treboR
    Please consider
    Donating to Freaktab

    Comment


      #3
      Thanks for the feedback.
      I just got that behavior on my k400 keyboard also. I suspect it's related to the usb.sh i left on init.d folder.
      If I remove the ir receiver from the box and connect it again the keyboard works again.
      Might need to remove it.

      Tapatalked

      if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
      then mv $user.contact.up.post /.trash; set response($response.type = ignore);
      $user.up.post.ignore_in_future = true; fi;

      Comment


        #4
        Most likely what fixed it just the Unplug and replug..All good
        Good looking Rom, can move around easily
        Mine is the X2 same inner's different Lid
        Cheers
        treboR
        Please consider
        Donating to Freaktab

        Comment


          #5
          Thanks for this great rom. Installed it a few days ago. Been testing it since. Works great except for poor video quality on the live sports tv app from google play store. This app plays perfectly on my ogoos and minix. But not on my x2. Any suggestions on how this can be fixed?

          https://play.google.com/store/apps/d...umbi.dilberjim

          Comment


            #6
            I have to install the app to check it. But there are problems with some codecs, my ISP provides an app to watch Live TV witch doesn't work on the X2.
            if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
            then mv $user.contact.up.post /.trash; set response($response.type = ignore);
            $user.up.post.ignore_in_future = true; fi;

            Comment


              #7
              Great. A new rom for X2. I will test it as soon as I get the new box.

              I have also noticed some strange playback when watching live tv. I was getting stuttering on full hd hls streams on mx player in HW mode and the stock player. It plays really good for 5-7 minutes and after that you start noticing some small stutter in picture. It gets worse and eventually picture freezes for couple seconds and after that it starts playing fine again for 5 - 7 minutes. Its like the buffer gets full or something. Really strange. But some full hd hls streams work fine. So they must be using different codec. Might be the audio one.

              But when using the hw+ mode in mx player or using bsplayer the streams played fine without any stutter ol lag. So I thought I will be using mx player in hw+ mode. But it turned out that in hw+ it will not play some sreams at all. And yes in hw mode they play fine. So I had to switch the decoding all the time when changing channels.

              Comment


                #8
                Originally posted by DiZet View Post
                Great. A new rom for X2. I will test it as soon as I get the new box.

                I have also noticed some strange playback when watching live tv. I was getting stuttering on full hd hls streams on mx player in HW mode and the stock player. It plays really good for 5-7 minutes and after that you start noticing some small stutter in picture. It gets worse and eventually picture freezes for couple seconds and after that it starts playing fine again for 5 - 7 minutes. Its like the buffer gets full or something. Really strange. But some full hd hls streams work fine. So they must be using different codec. Might be the audio one.

                But when using the hw+ mode in mx player or using bsplayer the streams played fine without any stutter ol lag. So I thought I will be using mx player in hw+ mode. But it turned out that in hw+ it will not play some sreams at all. And yes in hw mode they play fine. So I had to switch the decoding all the time when changing channels.
                valuable message!

                Comment


                  #9
                  Abdul_pt 's rom boot speed maybe a bit faster than 104k4, about 2 seconds.

                  Comment


                    #10
                    abdul_pt Ok. Got a chance to test it out. All looks good but I can not get in to recovery. If i reboot to recovery it will freeze on boot logo. Even if I restart the box it stays on boot logo and will not even go to boot animation. Only reflashing helps. Where can I get the latest twrp image?

                    abdul_pt and TRIGTOP I will pm you couple of example links for the hls streams that I have the "stutter" issue with. Maybe you can work out the reason for it and come up with the fix in the next relase.

                    Comment


                      #11
                      What box is it ?
                      Latest image is included in the ROM.
                      How do you reboot to recovery ?
                      if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
                      then mv $user.contact.up.post /.trash; set response($response.type = ignore);
                      $user.up.post.ignore_in_future = true; fi;

                      Comment


                        #12
                        Originally posted by abdul_pt View Post
                        What box is it ?
                        Latest image is included in the ROM.
                        How do you reboot to recovery ?
                        I have X2 (without 4k logo on the box), it should be the same as Tronfy X2. I use the reboot app. I flashed the rom from sdcard. I will try to do it with USB method.

                        Comment


                          #13
                          abdul_pt It works fine when I flashed with Phoenix Suit. So something must have gone wrong when I flashed with sd card method.

                          Comment


                            #14
                            Originally posted by abdul_pt View Post
                            I have to install the app to check it. But there are problems with some codecs, my ISP provides an app to watch Live TV witch doesn't work on the X2.
                            Hi abdul_pt

                            Can You say me what app you talking about? Im waiting to receive the Beelink X2 and i'd like to know if IrisOnline App works with this TVbox.

                            Thanks
                            Beelink X2 and Nexsmart D32 for now!!!

                            Comment


                              #15
                              I'm talking about Vodafone. It just crashes
                              if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
                              then mv $user.contact.up.post /.trash; set response($response.type = ignore);
                              $user.up.post.ignore_in_future = true; fi;

                              Comment

                              Working...
                              X