No announcement yet.

bricked my m8 square - need help

  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by grant2258 View Post
    hi mate pretty new to embed linux stuff but been using linux for years. Now the uboot for this aml tools looks like its originally from a round box.

    The boot.img in the zips isint the boot loader i unpacked it. Its just a kernel and a ramdisk. Long story short I dumped my bootloader from my box for you .Try this with bootmaker might help.

    Use the recovery you used the first time that did boot with your box but wasnt great. Now this is the right boot loader if nothing happens with the usb or recovery at all youll need to short the nand to get it to boot. let me know how you get on. Also i seen someone say about another box when the nand was corrupt recovery button can take up to a minute to kick in to give that a try too. I did compare the boot binarys and there are a lot of differences in it.
    Thank you. i will try this tonight.
    I see the my M8 reacts differently to different versions of uboot.bin so hopefully i do not need to short NAND pins as I am abit scared of doing that


      Well don't short the nands until all options are covered. I'm off to bed for work but if u don't get any joy ill send u the recovery image from my box to add to the finless 1.8 you can try that no guarantees but us worth a try. Remember to look for usb and screen response


        I still have a black screen with your file. just to make sure I am doing this right here is what i do:

        rename your bootloader.img to uboot.bin
        use bootcardmaker to put it on SD card
        copy all files from "M8 CM8 M8S Amlogic S802 169450 175646 177412-20140929.rar" the one that was half working and supposedly has a good recovery.
        now i have
        I also have usb刷机工具说明.wps and uboot.bin from the root folder of amlogic_tools.rar just in case

        is this right? am I missing anything?
        I have ethernet cable plugged in and I can look at LEDs. Whne i have no SD or SD card with some versions of uboot.bin applied via bootcardmaker, i see that link goes up and down every few seconds like it is going through reset loops. If I put "good" uboot.bin with bootcardmaker including the one you gave me the link goes up and stays up. This what leads me to believe that it is detecting SD and trying to boot from it. However I still have nothing on HDMI.


          I have to go to work it is good news your box is booting. It sounds like adb might be accesable if the box is staying on. I have to get to work ill send you something to try with instructions when I get in


            Originally posted by grant2258 View Post
            I have to go to work it is good news your box is booting. It sounds like adb might be accesable if the box is staying on. I have to get to work ill send you something to try with instructions when I get in
   for the recovery.img again grabbed from my box.

            i suggest you do the bootmanager with my uboot forget the wps file for now. get this then add the recovery.img i uploaded and let us know how you get on.

            You can also just try the recovery.img with the first firmware you tried if you dont want to use finless that the image i use myself


              Thank you, i will try, just not sure I understand this part:
              "i suggest you do the bootmanager with my uboot forget the wps file for now."
              do you mean use
              bootcardmaker to put your uboot.bin on sd card?
              If so this is exactly what I am doing.


                Yea I meant boot card maker must have been thinking of something else lol. Just do what you've been doing. No need to put the u boot on the card just add it with bootmaker then copy the files u want and my recovery.img

                so youll have
                bootcardmaker <uboot my one>

                recovery.img < my one >
                Last edited by grant2258; 12-17-2014, 13:41.


                  tried, still black screen with no signal. I am ready to give up. Perhaps something happened to the box other then bad NAND image


                    I Bricked my M8 in a similar way, probably flashing with an incorrect image.
                    but now its alive.
                    I followed this link
                    maybe worth a try


                      I suggest Contacting the person you got this box from an ask them for the firmware from your supplier. your supplier. You could try adb and the otg. There should also be a serial on the board to check what's going on. You could try the probox2 image it's mentioned on that thread I showed you earlier as well


                        Thank you for your help, guys! I will try probox firmware. Should I try using their uboot as well ?
                        For the OTG part. I made a straight cable USB Male to Male - all 4 pins connected to corresponding pins on other side. The box gets power from my PC now, so even when i unplug the power cable it is still on. But PC does not detect anything on the USB bus. I do have jumper installed on the PCB. Is this a good cable or do I need to make it OTG by shorting some pins?


                          Ok fist of all in working box just plugging in a usb will power it up and nothing else.

                          Im guessing thats all your doing even when you do this with a working box nothing happens either.

                          Only one port works for ota havent tried adb yet cause its not been opened to move the jumper.

                          The usb port varies from box to box so try both.

                          what to do is keep the recovery button in when you power up from the usb and listen for windows finding the usb if it doesnt work try it on the other port.

                          if neither works add the bootimage and recvery we made earlier with bootmaker put that in and keep the recovery button down let us know how you get on.

                          if that doesnt work last attemt will be

                          make bootmaker with the the uboot image from the root folder of amtools and use my recovery.img keep the recovery button down try both usb ports.

                          almost forgot try with the jumper off first for ota. If you can get adb with my uboot i got from my box i can get you the files you need from my box to try if you dont want to go probox


                            One more thing it just dawned on me the box might not boot properly with the jumper on ie abd mode. Try booting with the boot card maker you made with the recovery image and the uboot i gave you on with the jumper off and the recovery button held in. Please use the ac adaptor for this boot
                            Last edited by grant2258; 12-18-2014, 13:20.


                              tried all of the above with no luck. nothing on the screen, nothing on USB. I got the scope and check all the connectors on the board, while rebooting the box - nothing that looked like a UART (serial) signal. Even tried to short pins 17 and 18 of the NAND FLASH part. Also I suspect different FLASH parts have different pins to short. I have Micorn 29f64G08CBABA and according to it's datasheet pin 17 is ALE (Address latch enable) and pin 18 is WE# (Write enable). not sure if shorting those really disables NAND.
                              I'd ground RE# and/or CE#. No signal from USB on the scope either.


                                did you try the probox method