No announcement yet.

bricked my m8 square - need help

  • Filter
  • Time
  • Show
Clear All
new posts

    My M8 was bad flashed. I tried to install Finless 1.8 and I did it wrong, used a usb stick. Anyway, my unit powered on and all that happened on the screen was the tv detected something, switched to auto mode, then switched to no signal. This repeated over and over.
    To fix it I did the following.

    1. Downloaded the Amlogic Tools rar file.
    2. Unpacked it to my hard drive
    3. Using the SD card creator tool inside the rar I selected the uboot.bin from the root folder of the rar, not the one inside the sd card creator folder.
    4. I selected to format the card too and hit start, after it was all done I got a successfull message.
    5. Downloaded the image from Post #2 in this topic.
    6. Placed the zip file and created my own factory_update_param.aml file with notepad, pasting this into it
    7. Safely ejected the SD card from the pc.
    8. Put sd into M8, hold button inside AV socket and apply power, as also said in this topic within 12 seconds it will begin to update with the android logo on the screen.


      I flashed PROBOX to my bricked M8, and it worked. BUT, now every ROM I flash is missing wireless/wifi. Anybody know why?? How to fix??


        I have a m8 box square brand new and tried installing mediamans GEv2 rom which I have done many times with no problems but this time it's bricked my box no light or picture iv tried amalogic tools.rar as posted in this forum but no sign of life iv also tried usb burning tool with probox2 file my box connects to pc no problem but keeps stopping at 2% every time even when shortening the pins it still stops at 2% is there anything else I could try before I throw it in bin ??


          Not sure if anyone is still following this thread, but I have the same issues here with a M8S box. I tried to root using the em8_finless_rom18 which I believe should have worked, except for the fact I believe my box is a clone... I have uploaded a pic of the board. It's bricked. Light stays on, but no output to the tv. I would like to try shorting pins, but I believe my chips are different.

          Any suggestions based on my pic?

          Couldn't upload pic.... Had to host it....