Unconfigured Ad Widget

Collapse

Announcement

Collapse
No announcement yet.

Official Stock Firmware - Beelink S805 SoC(MXQ/MK808 Plus/MK809 Plus) -User feedback

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Official Stock Firmware - Beelink S805 SoC(MXQ/MK808 Plus/MK809 Plus) -User feedback



    The latest Firmware:

    Download here ---->107k4_SDcard<----
    Last edited by oman; 10-23-2014, 08:45.
    Easy way to catch LOG -> Search 'Syslog' in Google Play,then install it and catch log

    #2
    Bee-link s805 MQX s85..
    E: footer wrong
    Signature verification failed

    Unpacked 3 files to sd-card using winrar ( no error) used app update&backup.. boots to recovery
    Mount read-only /dev/block/mmcblk0p1
    -failed

    Attemt 2,
    Moved 3 files to /cache
    -failed signature/footer

    I will redownload.. after diner

    Comment


      #3
      Originally posted by mitchell4you View Post
      Bee-link s805 MQX s85..
      E: footer wrong
      Signature verification failed

      Unpacked 3 files to sd-card using winrar ( no error) used app update&backup.. boots to recovery
      Mount read-only /dev/block/mmcblk0p1
      -failed

      Attemt 2,
      Moved 3 files to /cache
      -failed signature/footer

      I will redownload.. after diner
      try unzip instead of winrar.

      Comment


        #4
        Well..
        redownload..extracted to
        /cache
        sdcard
        nand sdcard
        - same errors

        im done for the night.. goodnight
        -lets see what tomorrow brings...

        Comment


          #5
          don't use update and recovery app.
          hold the recovery button on the back of the box while plugging in power and turning on until you see recovery screen.
          have firmware or files you want to flash on sdcard or usb and use a usb keyboard or remote to navigate.
          wipe cache and data partitions first.
          then select flash from ext-usb or sdcard and select your rom.
          if there is still a problem flashing make sure your USB or SDCARD are formatted in FAT32.

          Comment


            #6
            Originally posted by infamouskid View Post
            don't use update and recovery app.
            hold the recovery button on the back of the box while plugging in power and turning on until you see recovery screen.
            have firmware or files you want to flash on sdcard or usb and use a usb keyboard or remote to navigate.
            wipe cache and data partitions first.
            then select flash from ext-usb or sdcard and select your rom.
            if there is still a problem flashing make sure your USB or SDCARD are formatted in FAT32.

            wil not work for me same with usb stick it says no files on sd card and same usb stick i tried app method same i cant find the img file for 109k4 i want to try burning tool

            Comment


              #7
              Hmm.. i forgot to mention.. i have the bee-link s85 with-out bluetooth,
              Perhaps.. thats the reason why it failed?

              About the sd-card.. it was previous used to upgrade my s89-h,
              So.. it should work

              Men could probably also use 'petrus reboot' app to boot into recovery

              Anyway, i appreciate the comments and advice

              Bugs found, (105k4/xbmc 13.1 oman) (So far)
              Keyboard uses more then 50% of the screen
              xbmc: Hevc not present/working
              (alucard bigbunny 720p hevc using pre-installed videoplayer=perfect)(but "sintel" sample not)
              xbmc: 720p online stream plays fine.. but 720p dolby 5.1 lots of " cache filled before reaching required amount " nags, same goes for 1080p online media/trailers (xbmc probably needs a adv.xml)
              4:3 movies have a warped black border
              Location locked to shanghai
              Sometimes the screen goes back to 100% (saved settings get lost)
              Wifi scan: fails to detect ch13 routers ( because of this.. i can only use lan for testing)
              Update..
              After tweaking: : deepfreeze app releasing more ram (xbmc says 450 mb free / adding adv.xml buffer 100mb
              -i can now play 1080p online trailers without nag ( not multi-ch.. )
              update2 i did the bionic tcp buffer tweak using 'tuner'
              -720p 5.1 dolby trailers fury and evengers played with-out any hitch
              update3.. tried build.prop edits to enable wifi ch13.. no dice sadly
              So, made my s89 as hotspot<<s805 wifi>><<openvpn>>
              tested..iplayer and demand5 (by bob)
              - demand5 played fine / video quality good
              -iplayer : blackscreen with sound :: was fixed by running omans 13.1 prior to iplayer / quality good
              -rtlxl : app runs in phone-view : ads play : stream runs for 1min then vid-screen hangs.. sound continues
              -veetle sd+hd.. lots of framedrops, cpu load high - veetle and mediaserver, stream fails after some time
              -npo : live tv and video / good ( 1time :: s85 crash/reboot, i clicked live-tv without running xbmc first)
              -petrus reboot 0.9.3 : just makes app hang, unable to run any app.. manual reboot was needed to fix this
              Update 4
              after 8 days of use.. the dc adaptor gave-out
              Before going to work.. i checked weather (bike or not) when the unit rebooted,
              It became a 'android tv logo' bootloop.. after changing dc.. all worked fine (quite a scare)
              Update 9
              Tried a 'script manager' to fix the permission problem (run script after boot) sadly it did not work
              Update 10 Howto enable small keyboard
              Desktop/mboxsettings/andvanced sett/input:
              Enable : aosp, remote controller input and remote keyb
              Set: remote controller as default (go sett of.. remote controller to disable sound feedback)

              To oman or any dev.. please make a:
              Update.zip to fix/solve the wifi ch problem
              And a update.zip or app that can set the permisision correctly on boot ( to enable other video apps h/w acc)
              Last edited by mitchell4you; 11-02-2014, 15:40. Reason: bug list

              Comment


                #8
                I have question regarding this firmware and prior versions.

                Why is not possible for other XBMC installations (SPMC) or even XBMC official to access the amlogic libraries in the firmware?

                I always get error ERROR: DVDVideoCodecAmlogic: Failed to open Amlogic Codec

                and blank screen with only audio when i try to playback on other XBMC installations.

                Comment


                  #9
                  Hi V_ghelani
                  See:
                  http://www.freaktab.com/showthread.p...MC-Gotham-13-3

                  In short..
                  If you run Oman 13.1 first.. exit..and run SPMC, it should run fine..

                  Goodluck

                  Update...,
                  my apologies.. i tried spmc 13.3.. first running omans version
                  -blackscreen with sound
                  Also tried omans 13.2.. if you leave it running for many hours, then use it, video starts to stutter
                  -exiting, rerun and reboot did not fix it.. i reinstalled 13.1 again
                  Last edited by mitchell4you; 10-30-2014, 07:48. Reason: update

                  Comment


                    #10
                    Just flashed this on my bluetooth version of s85 and it's working great, however, sometimes while using xbmc box totally locks up (freezes), I have to use the power button to turn it off and than on. Does this have the Oman's latest 13.2 xbmc on it?

                    Comment


                      #11
                      Originally posted by mitchell4you View Post
                      Hi V_ghelani
                      See:
                      http://www.freaktab.com/showthread.p...MC-Gotham-13-3

                      In short..
                      If you run Oman 13.1 first.. exit..and run SPMC, it should run fine..

                      Goodluck

                      Update...,
                      my apologies.. i tried spmc 13.3.. first running omans version
                      -blackscreen with sound
                      Also tried omans 13.2.. if you leave it running for many hours, then use it, video starts to stutter
                      -exiting, rerun and reboot did not fix it.. i reinstalled 13.1 again
                      I can see that Oman fixed this explicitly in another Beelink rom:

                      "Update xbmc to Gotham 13.2,and open some nodes' authority,so you can install any version of xbmc"

                      I assume this same fix would need to be applied to our MXQ firmware for other xbmc installations to work. For me I would like to try SPMC because it has some initial h265 stuff in it and given the MXQ has h265 hardware decoding, I would like to try it out.

                      Comment


                        #12
                        mirror here

                        http://chinagadgetsreviews.blogspot....ware-on_2.html

                        Comment


                          #13
                          Internal storage RW permissions.

                          Got a couple of these boxes.

                          .. came with 105k4 flashed 106k4 and now using 107k4.

                          In XBMC folder cannot set `guisettings.xml` permissions to `read only`.
                          however I can change permissions of pretty much any file in the root directory,
                          anything past storage folder is blocked.

                          always used RK devices before, never been an issue.

                          Tried all sorts of fixes, non worked.

                          Click image for larger version

Name:	RW1.jpg
Views:	1
Size:	113.4 KB
ID:	435175Click image for larger version

Name:	RW2.jpg
Views:	1
Size:	119.4 KB
ID:	435176

                          Comment


                            #14
                            Originally posted by Johnoo View Post
                            Got a couple of these boxes.

                            .. came with 105k4 flashed 106k4 and now using 107k4.

                            In XBMC folder cannot set `guisettings.xml` permissions to `read only`.
                            however I can change permissions of pretty much any file in the root directory,
                            anything past storage folder is blocked.

                            always used RK devices before, never been an issue.

                            Tried all sorts of fixes, non worked.

                            [ATTACH=CONFIG]8645[/ATTACH][ATTACH=CONFIG]8646[/ATTACH]
                            guisettings is a funny one. From what I've seen, XBMC keeps the file "open" and when it shuts down it writes the last know "good" settings to the file. Could be why you can't change setting on it.

                            Comment


                              #15
                              Originally posted by syztemlord View Post
                              guisettings is a funny one. From what I've seen, XBMC keeps the file "open" and when it shuts down it writes the last know "good" settings to the file. Could be why you can't change setting on it.
                              guisettings shown as an example.

                              Major issue is this firmware not allowing RW file permissions change in internal storage,
                              but allowing permissions change of pretty much any file in the root/system directory.

                              BIG BUMP for internal storage
                              permissions fix.

                              cheers.


                              Comment

                              Working...
                              X