Unconfigured Ad Widget

Collapse

Announcement

Collapse
No announcement yet.

Problem booting S812 OTT M8S TV box without SD card

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem booting S812 OTT M8S TV box without SD card

    Hi!

    I have a problem which can't solve so far. I have a box based on S812, 8GB, 2GB with AP6330 WiFi. It had loaded the stock ROM which was based on Android 4.4.2. I rooted it and installed TWRP which I used to make a backup of the system before I try to install a different ROM.

    The problem started when I tried to restore the original ROM. I loaded TWRP from the SDCARD and I restored the original ROM from a USB stick but when I tried to reboot I noticed that the blue light gone off and the box was bricked. I put the SD card back to the box and suddenly the box booted to the original ROM.

    Now the only way to have back my original ROM is to have a bootable SD card always in the BOX.

    How can I solve this problem ? Is there something wrong with the boot loader (u-boot). How can I repair the bootloader ?

    I would really appreciate your help.

    Kind Regards

    #2
    Update!

    I managed to solve the problem by flashing the (correct) boot loader back to the NAND of the box. The procedure is straight forward using the toothpick method and a SD card. The only pain is the ass is to find the right one u-boot.img for your box and a AML update script that flashes the boot loader to the correct memory addresses in the FLASH chip.

    Comment


      #3
      hi nikal, I have similar issues. I have good firmware that works remote works etc but when I restart my box it wouldn't load and stuck on m8s (s812) logo then I usually boot into recovery using toothpick and restart system from twrp and that works but its get annoying. I am not sure if its uboot file or not, can you share your firmware and uboot files etc ?

      Comment

      Working...
      X