Announcement

Collapse
No announcement yet.

Linux for Amlogic S802 \ S812

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by balbes150 View Post


    To run the system you need to manually copy it to the root of the media the correct dtb file with the name "dtb.img" .
    I've tried renaming and compying files from dts folder, but no luck. Maybe I have different HW - S802, it's k200

    Comment


      #17
      Originally posted by Kentril View Post

      I've tried renaming and compying files from dts folder, but no luck. Maybe I have different HW - S802, it's k200

      Send me the dtb file from Your firmware (with which TV box is powered, LE or Android)

      Comment


        #18
        Originally posted by balbes150 View Post


        Send me the dtb file from Your firmware (with which TV box is powered, LE or Android)
        https://drive.google.com/open?id=0B8...UlkWkktRUttejg
        https://drive.google.com/open?id=0B8...k1MZzFnaHptRXc

        Thank you

        Jiri

        Comment


          #19
          Originally posted by Kentril View Post

          I've tried renaming and compying files from dts folder, but no luck. Maybe I have different HW - S802, it's k200
          try this rom https://drive.google.com/open?id=0By...WU0R0U5RG85Q3M with sd card method

          Comment


            #20
            1-Download boot card maker from this link https://drive.google.com/open?id=0By...jdJbmR4UDctNUE
            2-Unzip rom that you have downloaded from the link https://drive.google.com/open?id=0By...WU0R0U5RG85Q3M
            3-Run boot card maker and in choose disk choose sd card (put sd card to usb sd card reader and connect to pc) ,check yes to partition and format and in options choose your bin file click open options and select u-boot from unzipped rom and than click make .
            4-Put all files that are on unzipped folder to sd card ,put u-boot.bin,recovery.img,k200-ota-20141208.zip,aml_autoscript,factory_update_param.a ml to sd card that you have runed boocard maker.
            5-Power off the android box and insert the sd card with 5 files and after inserting the sd card use toothpick and you have to put the toothpick on the hole from the back of android box (reset button) and push the power button without removing toothpick and you must wait about 10 second and than remove toothpick and leave the power button and you will see the android icon working.Normally if is the right rom the box shut power on.

            Comment


              #21
              Kentril the rom that i have posted in the beginning was from n200.you have k200 so the last post will work for your box

              Comment


                #22
                Originally posted by tani666 View Post
                1-Download boot card maker from this link https://drive.google.com/open?id=0By...jdJbmR4UDctNUE
                2-Unzip rom that you have downloaded from the link https://drive.google.com/open?id=0By...WU0R0U5RG85Q3M
                3-Run boot card maker and in choose disk choose sd card (put sd card to usb sd card reader and connect to pc) ,check yes to partition and format and in options choose your bin file click open options and select u-boot from unzipped rom and than click make .
                4-Put all files that are on unzipped folder to sd card ,put u-boot.bin,recovery.img,k200-ota-20141208.zip,aml_autoscript,factory_update_param.a ml to sd card that you have runed boocard maker.
                5-Power off the android box and insert the sd card with 5 files and after inserting the sd card use toothpick and you have to put the toothpick on the hole from the back of android box (reset button) and push the power button without removing toothpick and you must wait about 10 second and than remove toothpick and leave the power button and you will see the android icon working.Normally if is the right rom the box shut power on.
                Thank you, I followed you instructions and it was working. I think by NAND memory is corrupted, because all is working until I power it off. I need Android to be run directly from SD card. As balbes150 describes. I think this thread is about it.
                Last edited by Kentril; 01-31-2017, 00:13.

                Comment


                  #23
                  Originally posted by balbes150 View Post


                  Send me the dtb file from Your firmware (with which TV box is powered, LE or Android)
                  How to determine dtb file?
                  I followed this instructions:
                  http://freaktab.com/forum/tv-player-...thod-and-files

                  Burn SD card, rename one file from dts dir and copy into root of SD Card.
                  run Android and update it from aml_autoscript
                  restart

                  is this good procedure? If I want to try another dts file just rename it and boot again? or make aml_update?

                  I have k200

                  Thank you

                  Jiri

                  Comment


                    #24
                    You may try all files. To repeat the activation is not necessary (it is saved until the flashing device new firmware when replacing the boot loader u-boot).

                    Comment


                      #25
                      Originally posted by balbes150 View Post
                      You may try all files. To repeat the activation is not necessary (it is saved until the flashing device new firmware when replacing the boot loader u-boot).
                      I've tried all files with the same result. I could see this screen for 5 seconds and then no video signal.

                      Comment


                        #26
                        The startup process is long, need to wait for system start up 5 minutes or more (at this time, the monitor will read "no signal").

                        Comment


                          #27
                          Originally posted by balbes150 View Post
                          The startup process is long, need to wait for system start up 5 minutes or more (at this time, the monitor will read "no signal").
                          Good news. After few mins with first dts file system booted up! Seems network card has trouble, but when I get home I look at it closely. I think no sound is playd during test video. Does it support CEC protocol?

                          Comment


                            #28
                            CEC is not working.

                            Comment


                              #29
                              Hi everyone
                              Kentril - do you have M8 Box (k200) with 2 GB RAM? I have the same device and problem with activating multiboot and with boot.

                              Burn SD card, rename one file from dts dir and copy into root of SD Card.
                              1. Which application you use to burn your SD card?
                              2. What size of SD card you used?

                              run Android and update it from aml_autoscript
                              3. Did you get any warnings after this step? For me it's going to recovery and displays "Footer is wrong" etc.
                              4. Could you boot Armbian from both SD and USB flash?

                              Really appreciate to answer this questions. Thanks.
                              Last edited by 4timepi; 02-13-2017, 00:07.

                              Comment


                                #30
                                Hello, I have Android TV box MXIII 4K Quad Core Android 4.4.2
                                I followed this instructions:
                                https://it-tuto.com/dualboot-android-libreelec-mx3-g/

                                aml_autoscript.zip makes it bootable from SD card.

                                1) Win32 Disk Imager
                                2) 32 GB SD Card
                                3) No warrning... Box automaticaly restarted (3 seconds applying the aml_autoscript.zip)
                                4) I've tried only SD Card

                                Comment

                                Working...
                                X