Unconfigured Ad Widget



No announcement yet.

Lubuntu possible on S905?

  • Filter
  • Time
  • Show
Clear All
new posts

    hdmi in 1080p !
    recompiled the s905_autoscript

    usb bluetotth dongle (csr8510) working

    Last edited by Koxx; 04-15-2016, 19:23.



      There is a good manual here


        Originally posted by balbes150 View Post
        yes, it was my starting point.

        now, kodi is running with accelerated hardware... but still no sound.


          You need to rebuild your kernel with the sound devices used in these TV-tuners. Odroid in another system. And perform settings.


            that's the problem ... I am not sure about the sound device I should pick for my Minix 1G/8G. For me, it's the "aml_m8" (for hdmi audio)... like on my odroid c1.
            But the compilation fails with this driver. I'll try cross-compile.

            same for wifi.
            It seems to be a AP6212 (broadcom).


              here is the error when I compile the kernel

              CC [M] sound/soc/aml/m8/odroid_hdmi.o
              In file included from sound/soc/aml/m8/odroid_hdmi.c:18:0:
              include/linux/module.h:87:32: error: '__mod_of_device_table' aliased to undefined symbol 'odroid_hdmi_dt_match'
              extern const struct gtype##_id __mod_##gtype##_table \
              include/linux/module.h:145:3: note: in expansion of macro 'MODULE_GENERIC_TABLE'
              MODULE_GENERIC_TABLE(type##_device, name)
              sound/soc/aml/m8/odroid_hdmi.c:246:1: note: in expansion of macro 'MODULE_DEVICE_TABLE'
              MODULE_DEVICE_TABLE(of, odroid_hdmi_dt_match);
              scripts/Makefile.build:308: recipe for target 'sound/soc/aml/m8/odroid_hdmi.o' failed
              make[4]: *** [sound/soc/aml/m8/odroid_hdmi.o] Error 1
              scripts/Makefile.build:455: recipe for target 'sound/soc/aml/m8' failed
              make[3]: *** [sound/soc/aml/m8] Error 2
              scripts/Makefile.build:455: recipe for target 'sound/soc/aml' failed
              make[2]: *** [sound/soc/aml] Error 2
              scripts/Makefile.build:455: recipe for target 'sound/soc' failed
              make[1]: *** [sound/soc] Error 2
              Makefile:843: recipe for target 'sound' failed
              make: *** [sound] Error 2
              make: *** Waiting for unfinished jobs....


                alsa now has soundcards
                I had to compile those drivers, not as modules, but in the kernel.

                [email protected]:~$ cat /proc/asound/cards
                0 [AMLM8AUDIO ]: AML-M8AUDIO - AML-M8AUDIO


                  it seems almost good :

                  [email protected]:~$ aplay -l
                  **** List of PLAYBACK Hardware Devices ****
                  xcb_connection_has_error() returned true
                  card 0: AMLM8AUDIO [AML-M8AUDIO], device 0: I2S.35 dummy-0 []
                  Subdevices: 1/1
                  Subdevice #0: subdevice #0
                  card 0: AMLM8AUDIO [AML-M8AUDIO], device 1: SPDIF.36 dit-hifi-1 []
                  Subdevices: 1/1
                  Subdevice #0: subdevice #0
                  card 0: AMLM8AUDIO [AML-M8AUDIO], device 2: PCM.37 pcm2bt-pcm-2 []
                  Subdevices: 1/1
                  Subdevice #0: subdevice #0

                  [email protected]:~$ aplay /mnt/pchome-mydatas/series/Media-Convert_test6_PCM_Stereo_VBR_16SS_8000Hz.wav
                  xcb_connection_has_error() returned true
                  xcb_connection_has_error() returned true
                  Playing WAVE '/mnt/pchome-mydatas/series/Media-Convert_test6_PCM_Stereo_VBR_16SS_8000Hz.wav' : Signed 16 bit Little Endian, Rate 8000 Hz, Stereo

                  [ 888.517546] [aml-i2s-dai]i2s dma ffffff80007c2000,phy addr 914751488,mode 0,ch 2
                  [ 888.517558] ----aml_hw_iec958_init,runtime->rate=48000,sample_rate=4--
                  [ 888.517562] aml_set_spdif_clk rate
                  [ 888.517574] divider=20,frac=33920000,SDMval=5654
                  [ 888.517585] set normal 512 fs /4 fs
                  [ 888.517592] iec958 mode PCM16
                  [ 888.517599] IEC958 16bit
                  [ 888.517604] hdmitx: audio: aout notify rate 48000
                  [ 888.517608] hdmitx: audio: aout notify size 16
                  [ 888.517611] 958 with i2s
                  [ 888.517716] speaker_events--mute =1
                  [ 888.523636] [aml-i2s-dai]i2s dma ffffff80007c2000,phy addr 914751488,mode 0,ch 2
                  [ 888.523641] ----aml_hw_iec958_init,runtime->rate=48000,sample_rate=4--
                  [ 888.523645] aml_set_spdif_clk rate
                  [ 888.523652] divider=20,frac=33920000,SDMval=5654
                  [ 888.523661] set normal 512 fs /4 fs
                  [ 888.523667] iec958 mode PCM16
                  [ 888.523673] IEC958 16bit
                  [ 888.523677] hdmitx: audio: aout notify rate 48000
                  [ 888.523680] hdmitx: audio: aout notify size 16
                  [ 888.523684] 958 with i2s
                  [ 888.524068] aiu i2s playback enable

                  here is my /etc/asound.conf

                  pcm.!default {
                  type plug
                  slave {
                  pcm "hw:0,2"
                  format S32_LE

                  still no sound :/
                  any idea ?


                    my god ... after 5 hours of digging, I found a hack :
                    su -c 'echo "audio_on" > /sys/class/amhdmitx/amhdmitx0/config'

                    it enable the sound on HDMI !

                    kodi is now fully working.
                    tomorrow : network routing, transmission and openvpn.
                    Last edited by Koxx; 04-21-2016, 10:07.


                      Excellent, never give up good to see
                      Please consider
                      Donating to Freaktab


                        Kodi is running great.
                        Now, I am trying to add the 'bcmdhd' drivers & firmware to the kernel ... but I have no clue how to do that.
                        I just managed to get the firmware from OpenElec distrib.
                        How can I add this to the kernel build ?



                          Try it this way.

                          copy the directory /lib/firmware/brcm from the latest version Openelec and all its contents in /lib/firmware.
                          copy the contents of the files /etc/modprobe.d and /etc/modules-load.d into files with the same names.
                          I'm not sure it will help. We need to see how the 80211 module included in the kernel.


                            thanks !
                            is the bcmdhd module needed ? because it's not in the current odordoic2 kernel :/
                            I'll try that tomorrow


                              Yes, it is about the dhd module


                                ok, firmware copied.

                                for modules, I found this /etc/ after unsquashfs
                                lrwxrwxrwx 1 root root 31 avril 18 19:37 modules-load.d -> /storage/.config/modules-load.d
                                lrwxrwxrwx 1 root root 27 avril 18 19:37 modprobe.d -> /storage/.config/modprobe.d

                                both are nearly empty. nothing to use in this.

                                I recompiled the kernel to be sure I'll have :

                                I also copied :

                                I think something is missing since there is nothing to load the module...

                                here is my dmesg :