Announcement

Collapse
No announcement yet.

X96 MAX TV Box BLACK 4/64GB Amlogic S905X2, Android 8.1, Dual WiFi, Gig Lan,USB3.0, BT4.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Fugitive View Post
    That's also a bit of a problem for me now... you need a M$windows PC to do this.... via USB cable.... would be easier when this would be an image/iso to flash by means of (micro)SD card or USB memory stick, then i could do this with Etcher, Etcher is available for M$, Linux, and Mac OS ( i have a MacBook Pro).
    ...
    i have the 4GB RAM 64GB storage version i now see only an upgrade for 4/32,
    would that be a problem ? do i loose 32GB with that upgrade ?
    It would be nice if there was a LibreELEC fork for the X96 Max.....
    - Yea I guess you need win pc for flashing as there is no other way to update firmware. Go to some friend with a pc and flash it...
    - And no, I don't think you will lose half a storage if you update 4/32gb version. The architecture difference is between RAM (2 or 4 gb), not ROM. So just make sure you get 4gb version.
    - There is development in progress for porting CoreELEC on this box, check the progress here - https://discourse.coreelec.org/t/amlogic-s905x2/1818/39

    Cheers,
    Nik

    Comment


      I guess all sorts of virus protection/shield should be switched off for this procedure ? sounds a bit too risky for me at the moment, because i have to do this on a computer that is not of mine...
      I will remove some of the apps and will install the ones i really need again, i was a bit too eagerly in installing some of these, since my idea was also to install some video streaming add-ons into Kodi, I will do without that, and setup some "gateways" between my laptop and X96 Max device, or maybe a NAS again, this time with a SSD.

      Comment


        Originally posted by Fugitive View Post
        i have the 4GB RAM 64GB storage version i now see only an upgrade for 4/32,
        would that be a problem ? do i loose 32GB with that upgrade ?
        Sorry about posting that 2GB firmware, didn't read the fine print before posting. But I was sure the 4GB/32GB said it was for both versions 32 and 64 storage.

        It would be nice if there was a LibreELEC fork for the X96 Max.....
        balbes150 here on FreakTab is moderator/developer from LibreELEC forum, he makes Generic images for the Amlogic S905x2 devices and other S9xx series devices, and the X96_Max board was added to mainline Linux kernel several months back so his images should work for your board, possible the wifi drivers are still not added to upstream support yet so will have to use Ethernet.
        Link to last update:
        https://yadi.sk/d/DHePyyRcterLf/KODI-18/20190911/AMLG12

        Search the LibreELEC forum and balbes150 comments for specifics on the Images and user feedback.
        Last edited by RiCkLaR_atvX; 09-15-2019, 13:56. Reason: Typo.

        Comment


          Is there/which button for the english language ? lots of Russian (Greek to me) language i don't understand, still new to this all, is there a good FAQ for the X96 max (4/64) ?
          i also want to try my luck with a NUC (NUC6CAYH) since i first wanted to have a WinM$ PC around again, maybe i'll LibreELEC it first... have a 860 EVO 1TB SSD fitted, and total of 16GB ram in it.
          sofar only boot problems.... need to upgrade bios i guess... i'll come to that...

          Comment


            Originally posted by Fugitive View Post
            Hi, My name is Eric-Jan, just got this X96 Max 4/64,
            But Youtube is buffering, (with feeze frame on tv screen) while i think it should not, because i have no problems with Youtube on my Sony PS4,
            Can i adjust something so Youtube isnt freeze frame/buffering so much ?
            Try installing the app "Cpufloat" and check the cpu temperature while playing the videos. Maybe something wrong with the cpu cooler, then it overheats and throttles down.
            It's just a thought

            Enviado do meu POCOPHONE F1 atrav?s do Tapatalk

            Comment


              Originally posted by TheBlackening View Post
              Try installing the app "Cpufloat" and check the cpu temperature while playing the videos. Maybe something wrong with the cpu cooler, then it overheats and throttles down.
              It's just a thought

              Enviado do meu POCOPHONE F1 atrav?s do Tapatalk
              Thank you !

              Comment


                Hello. i am thinking to buy this box.But i have some inquiries.Have anyone tryied if coreelec/libreelec (bootable from microSD) streams Netflix on 1080p without any issues? Also does the missing statusbar/navbar added with some update? thanks in advance.

                Comment


                  Originally posted by kos25k View Post
                  Hello. i am thinking to buy this box.But i have some inquiries.Have anyone tryied if coreelec/libreelec (bootable from microSD) streams Netflix on 1080p without any issues? Also does the missing statusbar/navbar added with some update? thanks in advance.
                  Both Coreelec and libreelec work , Coreelec have perfect amlogic support so much better performance . Under coreelec netflix can be used only with 720p . about Android i use him with latest Sasvlad ATV 2.0 and work very good . Bad thing is that mine and many users report broken spdif out

                  Comment


                    Originally posted by Maki_SM View Post

                    Both Coreelec and libreelec work , Coreelec have perfect amlogic support so much better performance . Under coreelec netflix can be used only with 720p . about Android i use him with latest Sasvlad ATV 2.0 and work very good . Bad thing is that mine and many users report broken spdif out
                    thanks bro.So I thought it can stream to 1080p.I think I read it on Kodi forums.If it doesn't,I will keep my Vorke Z6.It lags a little,but to a point that it almost isn't noticeable.Any settings I could do to make it run bit smoother?

                    Comment


                      For people new to the X96 Max, or type Arm Logic S905X2, expect a lot of tweaking before you have normal use of this device, i have the X96 Max, it's a cheap device, true,
                      But like i said, you must do some/ a lot tweaking, and if that's no dealbreaker for you, it's okay, for me it's just too much to start with, i switched to a NUC...
                      Last edited by Fugitive; 10-03-2019, 14:30.

                      Comment


                        Originally posted by Fugitive View Post
                        For people new to the X96 Max, or type Arm Logic S905X2, expect a lot of tweaking before you have normal use of this device, i have the X96 Max, it's a cheap device, true,
                        But like i said, you must do some/ a lot tweaking, and if that's no dealbreaker for you, it's okay, for me it's just too much to start with, i switched to a NUC, that's mini very small bare bone pc,
                        you can mount on the VESA mount of your monitor, or tuck it in a small space, you can flash an image on a USB stick or SD card, put that into the NUC, this process is done in a wizard setup way,
                        so the first time you need a usb mouse or keyboard connected first time to boot up from the external device.
                        My NUC has a Celeron cpu, which is enough. barebone pc means that there is no RAM or SSD/HDD present, so this will be more expensive, but you have a stable working solution, my NUC wakes up from a infra red remote control, so i don't need to push a button on this TV-BOX NUC, via hdmi cec the tv can be switched on, so very easy to use.

                        btw. the software i use on the NUC is LibreELEC, goto https://libreelec.tv and you find all the information you need, also the devices LibreELEC runs on, and these are a lot !
                        You will also come accross CoreELEC, first, ... this will take up a port, because it does not run internally in the X96 Max, running it internally, brings the chance
                        that it will brick your X96 Max, for me CoreELEC didn't work.

                        A Raspberry Pi 4B (4GBversion) can also be a good option.....

                        sorry for being off topic tis way,

                        my two cents of experience with this.
                        Your way off base with this thread

                        Comment


                          Originally posted by raruba View Post

                          Your way off base with this thread
                          You are correct, i have edited my original post.

                          Comment


                            Hi.
                            How i can unbrick this x96max?

                            Comment


                              Originally posted by satstarter View Post
                              Hi, guys first of all sorry for my english (i'm from belgium)
                              i have purchased this box a few weeks ago x96 max 4gb 32mb now my only problem is
                              the optical out to my receiver dont work i have tried a few roms without succes over hdmi the sound works
                              i also tried manny settings but none of them works is there some one that have a solution for this
                              the strange thing is there is a red light in the optical connector from the device when i put the cable in then on the other side of the cable
                              that goes in the receiver is also red light so that means the signal is ok but no sound if i put the same cable in my sat device then i have sound on my receiver
                              so its something about the x96 max that doesnt work ??

                              thanx in advance
                              So I just bought one of the X96 max 4gb/32gb

                              i don’t have any sound trough hdmi, optical nothing. I tried different cables, TVs. When I connect trough my Bluetooth soundbar I get sound. I try all kind of setting and options but it looks like my box is broken on arrival?

                              Anyone has a suggestion?

                              Comment


                                Sound is working fine over hdmi here the seller of my box has given me a hdmi sound extractor for free so now i have
                                also sound via spdif did you look at your settings is hdmi on? and surround sound auto?

                                Comment

                                Working...
                                X