Announcement

Collapse
No announcement yet.

X96 Air Amlogic S905X3 Android 9.0 Media Player

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ant_thomas
    replied
    Seems it was an SD card issue. Didn't realise it was formatted to exfat rather than FAT32. It has now taken the firmware image file and is upgrading.

    Hoping this fixes the USB issue.

    Leave a comment:


  • Satbeginner
    replied
    Originally posted by ant_thomas View Post
    The device boots fine to Android - I've now tried the Burn Card Maker to make an update SD card and it doesn't update off that either.

    It boots to recovery using the "toothpick" AV button, and in there trying Apply update from EXT doesn't work
    To boot from SD instead of recovery I had to hold the toothpick longer, about 25-30 seconds I guess

    Leave a comment:


  • ant_thomas
    replied
    The device boots fine to Android - I've now tried the Burn Card Maker to make an update SD card and it doesn't update off that either.

    It boots to recovery using the "toothpick" AV button, and in there trying Apply update from EXT doesn't work

    Leave a comment:


  • Satbeginner
    replied
    Originally posted by ant_thomas View Post

    That doesn't seem to work either. How very annoying!
    If it still boots, you could try an SD card and go back to stock first.

    Mine was bricked before, because I tried a different, non x95air rom... (Stupid of me, I know)

    I was able to bring it (sort of) back to life by shorting some points somewhere with the PC waiting for a connection.

    I was then able to flash a rom from the PC, but only partially...
    But, just enough to make a boot from SD possible again ..

    Pfffffff, I consider myself lucky.

    Leave a comment:


  • ant_thomas
    replied
    Originally posted by Satbeginner View Post

    I was able to use an A-A cable, but only on the USB-3 port.
    That doesn't seem to work either. How very annoying!

    Leave a comment:


  • Satbeginner
    replied
    Originally posted by ant_thomas View Post
    I have an X96 Air P2 and I've having a few issues.
    I wanted to boot CoreElec but that fails to boot.

    I thought it might be a firmware issue so I'm trying to reflash the original firmware (or ATV firmware) using the USB burning tool.

    The problem is that the box is not recognised on any computer over USB. None of the ports allow the box to show up as a device of any sort. Other S905X boxes work fine with the same A-A cable.

    Any suggestions?
    I was able to use an A-A cable, but only on the USB-3 port.

    Leave a comment:


  • ant_thomas
    replied
    I have an X96 Air P2 and I've having a few issues.
    I wanted to boot CoreElec but that fails to boot.

    I thought it might be a firmware issue so I'm trying to reflash the original firmware (or ATV firmware) using the USB burning tool.

    The problem is that the box is not recognised on any computer over USB. None of the ports allow the box to show up as a device of any sort. Other S905X boxes work fine with the same A-A cable.

    Any suggestions?

    Leave a comment:


  • mirecko
    replied
    Originally posted by Letrix View Post
    Tanix TX3 4/32 or this X96 Air 4/32? Which of these two TV Boxes performs better with CoreElec, Kodi, H265 (and 10-bit)?
    Thanks.
    i did try x96 air 4g / 64gb with recent nightly of CoreElec,
    it was running on old and slow 2GB SD card, it was not good. i will try it again, when there is a stable version for a905x3 device tree.

    Leave a comment:


  • Letrix
    replied
    Tanix TX3 4/32 or this X96 Air 4/32? Which of these two TV Boxes performs better with CoreElec, Kodi, H265 (and 10-bit)?
    Thanks.

    Leave a comment:


  • Boxybox
    replied
    X96 Air is fast! the installed firmware P2 is rubbish in my opinion,

    is there an ATV that has status bar drop down, and supports ethernet apparently mine is 1000 lan ? is 4gb/64gb
    I am trying to look, id prefer using the usb burning..

    Thank you

    Leave a comment:


  • sogoku_vn
    replied
    Originally posted by dracosc22679 View Post
    I have a TX3 s905x3 2/16 tv box. Preinstalled firmware is useless so i tried installing other firmwares to test. All other firmwares found in another forum, work but without LAN....(looks like i have a fake TX3??).
    I have tried also some firmwares from X96 Air box, and i can confirm that P2 version firmware are REALLY SMOOTH on my box! But front lcd and remote control don't work.
    I don't really care about front LCD, but i would appreciate if there is anyone here that can help me fix the remote contol!
    Have tried transfering remote.tab(1,2,3) from preinstalled firmware, didn't work.
    Tried General.kl from preinstalled firmware, didn't help.
    Please anyone?
    HAPPY NEW YEAR TO ALL OF YOU GUYS!
    Try this. My box TX3 S905x3 2/16
    https://drive.google.com/drive/folde...frJY6dzc_ivcl6

    Leave a comment:


  • sogoku_vn
    replied
    Originally posted by jebaga View Post

    Tanix TX3 have lan 10/100mb,you buy on Bangood or Ali?

    https://www.banggood.com/Tanix-TX3-S...r_warehouse=CN
    Try this. My box TX3 S905x3 2/16
    https://drive.google.com/drive/folde...frJY6dzc_ivcl6

    Leave a comment:


  • jebaga
    replied
    Originally posted by dracosc22679 View Post
    I have a TX3 s905x3 2/16 tv box. Preinstalled firmware is useless so i tried installing other firmwares to test. All other firmwares found in another forum, work but without LAN....(looks like i have a fake TX3??).
    I have tried also some firmwares from X96 Air box, and i can confirm that P2 version firmware are REALLY SMOOTH on my box! But front lcd and remote control don't work.
    I don't really care about front LCD, but i would appreciate if there is anyone here that can help me fix the remote contol!
    Have tried transfering remote.tab(1,2,3) from preinstalled firmware, didn't work.
    Tried General.kl from preinstalled firmware, didn't help.
    Please anyone?
    HAPPY NEW YEAR TO ALL OF YOU GUYS!
    Tanix TX3 have lan 10/100mb,you buy on Bangood or Ali?

    https://www.banggood.com/Tanix-TX3-S...r_warehouse=CN

    Leave a comment:


  • l3g0r
    replied
    hi any solution for 2gb ram version and clock led?

    I flashed latest lekha7777 v2 but same problem with led. latest atv rom have bluetooth error.Tvbox not bluetooth.
    https://4pda.ru/forum/index.php?show...ost&p=92367633

    If someday works can display tvbox temp in led clock?

    Leave a comment:


  • Hexagon
    replied
    Originally posted by dracosc22679 View Post
    I have a TX3 s905x3 2/16 tv box. Preinstalled firmware is useless so i tried installing other firmwares to test. All other firmwares found in another forum, work but without LAN....(looks like i have a fake TX3??).
    Take a photo of your board, maybe your box is really different inside.

    Leave a comment:

Working...
X