Announcement

Collapse
No announcement yet.

HK1 X3 S905X3 Android 9.0 4GB/64GB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HK1 X3 S905X3 Android 9.0 4GB/64GB

    HK1 X3 S905X3 Android 9.0
    No ROOT
    4GB ram, 64GB ROM
    Some fresh out of the box observations.
    So far, Seems smooth, stable and fast.
    Initial setup was a breeze.
    Runs Top TV Launcher 2 with widgets.
    Idle temp is about 48 degrees C, 48-58 while doing general tasks and streaming.
    No Top.Bottom menu bars (Using Snowball and Button menu apps to simulate)
    Antutu score, ~65,000 (Temp peaked at 73 degrees C for a few seconds)
    Put a small cooling fan under the box
    Idles at ~32 degrees C
    Antutu score, ~74,000 (Temp peaked at 50 degrees C for a few seconds)
    Appears, without the fan, the CPU is being throttled to control temperature.
    My Internet is 100Mbs but generally peaks at 120Mbs
    2.4 Ghz WiFi link speed 65Mbs, ~25Mbs speed test (Other boxes, same location, including HK1 Plus show 65Mbs link speed, ~45Mbs speed test)
    5.8 Ghz WiFi link speed 65Mbs, ~45Mbs speed test (Other boxes, same location, including HK1 Plus show 433Mbs link speed, ~120Mbs speed test)
    1000Mbs Ethernet, 120Mbs speed test. (The Ethernet connector in the box does not click so could slip out easily.)
    Micro SD card can be formatted as Internal or portable.
    OTA Update check failed.
    I will add to thread as I find new things to report.


    HK1 Pro Plus
    FlowFon F1
    H96 Pro+ (Wisdom-Green Board-2017-02-10 H96-S912-TVBOX(DDR4)-V0.2)
    MXQ Pro+
    R-TVBOX Mini+
    MK809III

    #2
    Text file of AIDA64 results.
    Attached Files
    HK1 Pro Plus
    FlowFon F1
    H96 Pro+ (Wisdom-Green Board-2017-02-10 H96-S912-TVBOX(DDR4)-V0.2)
    MXQ Pro+
    R-TVBOX Mini+
    MK809III

    Comment


      #3
      Hi!
      I'm testing and reviewing this unit. I've noticed a few issues with it:
      1. When restarting the unit from the shutdown/restart menu, when it comes back up, no picture is showing on the TV until you disconnect and reconnect the HDMI cable
      2. Connection speed on LAN over Power-line is inconsistent, and I've encountered quite a bit of buffering, even in 1080p content
      3. It is unclear whether root in present or not. Superuser is installed, but shows nothing inside.
      4. HDMI CEC seems to malfunction. Even when it's turned off, the box will auto turn on from shutdown when the TV is running.
      5. 8K videos play, but with a lot of buffering, and some stutter
      6. Keyboard/airmouse remote does not work when transceiver is connected to the USB on the side of the box, but does work when connected to the corner USB

      Comment

      Working...
      X