Unconfigured Ad Widget

Collapse

Announcement

Collapse
No announcement yet.

H96 PRO TV Box Amlogic S912 Android 6, 2/16gb or 3/16GB, Dual WiFi, Gig Lan, BT4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Hi.
    Anyone able to find a changelog for the firmware? What is the benefits of going 20170308 instead of my firmware from 2016? I Googled but can't find anything
    cheers

    Comment


      #47
      20170602 out stock http://chinagadgetsreviews.com/downl...-tv-box-3.html

      Comment


        #48


        Have tried to install this – it’s really Android 7.1 64bit – as many times before by use of the sd card burning method, but this fails with “can not load volume /misc”. I have an H96 Pro Plus 3/16, so I think, this is for 3/32 only.

        The description is wrong, there is also no “Flash Instructions and Tool (H96pro Flash Tutorial + video tutorial + USB_Burning_Tool_v2.0.8_x86 + license” inside of the package.

        So I think I have to wait for a 3/16 version…

        Comment


          #49
          The update works well, using SD card, there is the requirement to enable "Update bootloader". All four checkbox should be enabled because of the 64bit system.

          Comment


            #50
            Originally posted by Terence_G View Post
            I purchased 10 of these boxes from DH Gate and they have the 20161101 firmware on them. I have had issues with the wifi not working properly and have been trying to update the firmware since I received them. They sent me a link to download aml_s912_q6330-H96-PRO(3+16-kodi16.1)-mac-20161105.rar (This unzips to a .img image file) which is apparently the newest firmware and also a link to a card burner to create a bootable sd card. I've tried repeatedly to update but am not getting anywhere. Here are the steps I've taken to install this firmware, can someone please tell me if I'm doing something wrong?

            1) Unzip the rar file
            2) Insert the SD Card into the PC
            3) Run the card burner which formats the SD Card and installs the image file onto it.
            4) Install SD Card into the tv box.
            5A) Tried using the update app and choosing the local install option but no file is available to choose for the update.
            5B) Tried installing SD Card with no power to the TV box then powering it up with the reset button pressed but all I see is an Android Guy with a red X on his chest. I did this because I read somewhere that you have to go into recovery mode to initialize the firmware update.

            Obviously I'm doing something wrong and hope someone can help.

            One other note, if I double click the image file on my PC it tells me it's corrupted.

            Thanks,
            Terry
            Mine has the same WiFi problems. Adding to that the Bluetooth also has problems. In order to update via the sd card, do the same procedure, but before creating the card, rename the iso image name to "update" and then create the bootable card using the sd card burning tool.

            Comment


              #51
              Originally posted by Endur View Post

              Have tried to install this – it’s really Android 7.1 64bit – as many times before by use of the sd card burning method, but this fails with “can not load volume /misc”. I have an H96 Pro Plus 3/16, so I think, this is for 3/32 only.

              The description is wrong, there is also no “Flash Instructions and Tool (H96pro Flash Tutorial + video tutorial + USB_Burning_Tool_v2.0.8_x86 + license” inside of the package.

              So I think I have to wait for a 3/16 version…
              I installed this rom in my 3/16 box and works very well. No issues.

              Comment


                #52
                Originally posted by OctavioS View Post

                Mine has the same WiFi problems. Adding to that the Bluetooth also has problems. In order to update via the sd card, do the same procedure, but before creating the card, rename the iso image name to "update" and then create the bootable card using the sd card burning tool.
                You may have a different wifi/Bluetooth chip. q6330 doesn't work with this stock firmware...

                Comment


                  #53
                  These model very confusing. If i correct device have both ddr3 and ddr4 and wifi in some changed. Id check supercelerons builds for this device in beelink section i check and post the one i used on alfwise h96
                  Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

                  Comment


                    #54
                    In alfwise section is ddr3 ones by superceleron and wifi fix if not same mine debloated rom there too.

                    Main forum beelink have ddr4 super celeron rom too

                    http://freaktab.com/forum/tv-player-...oated-firmware

                    Is best to open device check make sure ddr4 or ddr3 and check wifi chip for correct one. Much better then stock roms anyways
                    Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

                    Comment


                      #55
                      Originally posted by OctavioS View Post

                      I installed this rom in my 3/16 box and works very well. No issues.
                      Yes, can confirm that also now. The cpu temp seems a little bit higher as usual 72 °C on latest Kodi Krypton nightly == 17.4rc1. Had to use now the armv8 64bit version. The box is stable. Also the button to switch the power LED off is gone, good, this functionality was useless from my point of view.
                      ​​​​​​I'm very satisfied with the update.

                      Comment


                        #56
                        Originally posted by Endur View Post
                        You may have a different wifi/Bluetooth chip. q6330 doesn't work with this stock firmware...
                        I intalled the latest firmware from china gadget reviews for the q9377 chip, which my box has. It has the same wifi and bluetooth problems since i first purchased it.
                        Last edited by OctavioS; 06-16-2017, 02:18.

                        Comment


                          #57
                          Just updated my H96 Pro 3/16 with Q9377 chip using the sd card method with the image file in the above link and it worked perfectly first time.
                          Now have Android 7.1.1 and it shows up as H96 Pro+ in the system info.
                          Last edited by scobo; 07-20-2017, 21:08.

                          Comment


                            #58
                            H96 pro+ 7.1
                             

                            Comment


                              #59
                              I think my box is bricked. When I plug it in, I see the blue light but nothing on the screen. I've tried to plug in every single usb port to the computer with the reset button pressed but nothing happen. Do you guys have any ideas?

                              Sent from my SM-G955U using Tapatalk

                              Comment


                                #60
                                Originally posted by tengtengvn View Post
                                I think my box is bricked. When I plug it in, I see the blue light but nothing on the screen. I've tried to plug in every single usb port to the computer with the reset button pressed but nothing happen. Do you guys have any ideas?

                                Sent from my SM-G955U using Tapatalk
                                Try a different HDMI cable, try a different TV. perhaps a 720 tv (HD) or 1080 Full HD

                                Not sure why you expect to see something when plugging a usb lead to a computer.

                                Comment

                                Working...
                                X