No announcement yet.

T95Z Plus - with AP6255 WiFi Troubles

  • Filter
  • Time
  • Show
Clear All
new posts

    T95Z Plus - with AP6255 WiFi Troubles

    Hi again,

    I have a friends T95Z and trying to fix it up. It won't connect on WiFi. When you go to network settings - WiFi is switched off. If you switch it on - it "pretends" to search for about 40 seconds - finds no AP nearby and switches "Off".

    I have wrenched on a number of these T95Z. boxes and always seem to get them working.
    Hats off to Superceleron and his ROM - His ROM really cleaned up the first couple of these I worked on. They had the LTM8830 chipset I think.

    Then I worked on a couple newer T95Z's and that ROM didn't work. If I recall - same thing where you can try and turn the WiFi on but it just turns off. I think they turned out to have the 9377 chipset. Found a workable ROM for them and all is well.

    Okay so here are some pics of the insides of this one:

    I flashed a bunch of ROMs - Here is like a list of some of the file names etc:

    Poison ROM -
    T95U PRO_S912_02012017_

    Sorry that I didn't keep great notes on what I flashed but hey - once you start flashing - it is just so easy to try another one.

    Anyway - Several of the ROM's said they were for the AP6255 chipset and ALL of the ROM's do the same thing where the WiFi just won't turn on.

    Now I am not an expert on this - so I don't know:
    Can you confirm - Is this a Sunvell?
    Is the wifi chipset an AP6255?
    What else should I try? I wandered into a T95U ROM... should I wander further and look for Beelink or other manuf ROM's that show the AP6255?
    Is there any other tool or APK that can be flashed after ROM install to query the hardware config or add chipset support?

    Open to ideas.


    Hi ,

    maybe a Rom from the Wechipwebsite fits , u can find it in Freaktab Downloads Section ,

    sticky Thread "STOCKROMS DOWNLOAD PAGE" , good luck / gefattern


      Thanks for the reply.
      I am downloading now. But - there seems to only be one version for the T95Z Plus which sounds scary - It seems there are at least three different hardware configurations of the T95...

      But worth a shot and flashing is easy. Plus this is downloading way faster than Mega.

      Thanks again,


        Well - downloaded that one and got the same results. Wifi switches on for a few seconds - finds no APs and then just shuts off.

        Any other ideas?



          Originally posted by VoidnWarranties View Post
          Well - downloaded that one and got the same results. Wifi switches on for a few seconds - finds no APs and then just shuts off.

          Any other ideas?

          can you reflash using burn tool in firmware update mode?


            I have done most of these flashes with USB cable flash tool. I have also done a couple with the SD card burn tool and I have done a couple in TWRP. So I have all the tools and understand all the methods.

            But it is really sounding like I have a bad wifi chipset. Not sure there is anyway to get that fixed without some micro soldering which is beyond my skill set and the price point of this box.

            Anyway - thanks for the help or at least just listening.