Announcement

Collapse
No announcement yet.

[Help]M8S Pro L 3GB/32GB: Cannot pair Xbox One Controller or TurtleBeach headset by Bluetooth

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [Help]M8S Pro L 3GB/32GB: Cannot pair Xbox One Controller or TurtleBeach headset by Bluetooth

    Hi,

    On my new M8S Pro L device, I'm trying to pair a Xbox One Controller via Bluetooth but the pairing always ultimately fails. The Box sees the controller but when I try to pair it, it always fails.

    I also try to pair a Turtlebeach headset via Bluetooth but this one isn't even picked up by the box.

    Both the devices mentioned above can successfully pair on my PC. I don't have any other Android devices on hand but looking up on the web, both devices should work on Android. The Turtlebeach headset works on my iPad.

    Bluetooth radio seems to be working on the M8S Pro L as I was able to pair my iPad and my TV. But what could be wrong with the controller and the headset?

    I tried all 3 variants of Magendanz ROMs and the 2 stock versions of course all with the same results. Is there anything else I would need to install on my M8S Pro L to make these devices work?

    Thanks.

    #2
    Hi PC!

    I think this might be an issue/bug with all variants of M8S PROs ... check out my post here

    Mecool M8S PRO 3/32 - Bluetooth is not working on its own or with ethernet only working when wifi is connected ???

    Out of curiosity have you tried connecting bluetooth with your wifi on/connected?

    I am currently downloading latest stock rom for my M8S PRO to confirm whether this bug in only in custom roms or also in stock roms.
    From what your saying it looks like it may well be in stock roms too or maybe its a hardware issue either way we are screwed!
    As soon as I confirm the bug in stock rom I will be contacting the supplier to arrange a return of the box!
    Unless by some miracle this is fixed in the next couple of days

    Comment


      #3
      That is really interesting! I do in fact use Ethernet instead of Wifi. I even have the wifi radio turned off.

      I will try to connect via Wifi when I get home although I still would prefer to use a wired connection.
      What I find weird is that with my current setup, some Bluetooth peripherals are properly discovered by the M8S Pro L!

      You can try stock ROMs if you want but as I wrote in my previous message, I had the same behavior on both versions of the Stock ROM. iPad and TV would pair but the rest was either not discovered or would just throw an error during the pairing process.

      Comment


        #4
        I noticed the same thing. If wifi is off / not connected bluetooth seems to see some devices and not others. In my case it was seeing my phone but not my gamepad controller. But even though it was seeing my phone when I tried connection to it it would say device not found and failed to connect to it. I found after testing the only time bluetooth devices were able to connect was when wifi was on/connected.

        Without ethernet the unit is useless to me one of the main reasons I got it was to be able to stream PC games over ethernet ggggrrrr

        I finally downloaded stock rom to flash and try and will post results but im not very hopeful from what you have said.

        I have contact my supplier with this issue so will see if they come back with a solution or except a return.

        I should add that I think when I was testing for bluetooth to work wifi not only had to be switched on but have and active connection. At least I think so but I will double check that and post.

        Comment


          #5
          I'll do my tests as well and report here.

          Thanks.

          Comment


            #6
            Ok I can confirm

            1. The stock rom gui sucks bad! I hadn't even used it before now I flashed to custom rom as soon as I got box haha

            2. I'm seeing exactly the same problem/bug with stock rom

            3. Also to confirm, to work bluetooth needs an active live wifi connection, doesn't work with just having wifi turned on.

            Comment


              #7
              Nice thanks.

              Would it be possible to have both Wifi and Ethernet connected on the same network and somehow hope Android prefers wired connection over the Wifi one, leaving it connected but never actually used?

              Comment


                #8
                If you read my original post here Mecool M8S PRO 3/32 - Bluetooth is not working on its own or with ethernet only working when wifi is connected ???

                That was one of the options I tried but I found bluetooth would stay connected for a little while and then both wifi and bluetooth would drop out so it doesn't give you stable bluetooth

                You could try it with your box and see if you get the same result

                Comment


                  #9
                  Yeah, same here. Even worst, with custom TVStock ROM, I cannot connect to Wi-Fi when the Ethernet cable is connected. It just says the Wireless network is unreachable.
                  For the record, I have not tried connecting to a Wireless network while Ethernet is connected on Stock ROM but I bet it's going to be the same.

                  Comment


                    #10
                    This Bluetooth issue maintain also with the new firmware from 27.11? http://freaktab.com/forum/tv-player-...855#post689855

                    Comment


                      #11
                      I've tested with 2017.10.30 stock and 2017.11.16 Nano Custom and Bluetooth bug is still there

                      Comment


                        #12
                        Originally posted by r3dcat View Post
                        I've tested with 2017.10.30 stock and 2017.11.16 Nano Custom and Bluetooth bug is still there
                        but there is a new stock from 27.11 see my link upon, why dont try with this new update?

                        Comment


                          #13
                          Have you guys tried turning on Wifi manually in terminal?

                          in terminal type
                          Code:
                          su
                          ifconfig wlan0 up

                          dont know it the above will work but its worth a try

                          I turn off my Ethernet with it still plugged in automatically when i boot into android using kernel Adiutor built in init.d script function.

                          Code:
                          ifconfig eth0 down
                          su is not needed as kernel adiutor is already root


                          The reason why i do this is because when setting a Static IP on Ethernet the speed is very slow

                          Comment


                            #14
                            Hey Dope101,

                            I am a bit unsure of what you mean here exactly. Are you saying you can force wifi to stay connected while using Ethernet as the active connection?

                            Comment


                              #15
                              Hey Everyone! I have found an easy work around if your seeing this problem/bug finally
                              If BlueTooth is dropping out when your connected through Ethernet just turn on "Portable WiFi Hotspot" and presto problem fixed

                              Comment

                              Working...
                              X