No announcement yet.

Requesting Z69 Max firmware - bricked device

  • Filter
  • Time
  • Show
Clear All
new posts

    Requesting Z69 Max firmware - bricked device


    I accidently bricked my Z69 Max TV Box Amlogic S912 CPU 3/64GB device. Would somebody be willing to help me by providing an extract of the boot partition at least? It would be very much appreciated. I can assist with information on how to perform the copy if needed.


    I hate this box, whit the original firmware (I'm not been able to upgrade the firmware) how can I extract the boot partition?


      Originally posted by hereje View Post
      I hate this box, whit the original firmware (I'm not been able to upgrade the firmware) how can I extract the boot partition?

      Why do you hate it? The original firmware seemed ok to me, although I only got to use it for an hour or so before mistakenly installing supersu and bricking the device...

      For backing up the boot partition, the simplest way would be to use an app, but not sure if it works on this device. You could try:

      If that does not work, an image can be made using adb. You will need to enable USB debugging on the device and install adb on your computer (, You will need to connect your device with your computer using a USB male-to-male cable (the USB will provide power, so do not use the power adapter when doing so).

      This link describes the steps required in detail:

      I already looked up the block device name using a serial console, and it can be referenced simply as /dev/block/boot from what I can see.

      So in short, you need to do the following:
      1) insert SD card into device
      2) connect your device with your computer using a male-2-male USB cable (do not use power cable)
      3) run the following command from your computer: adb shell
      4) then type: dd if=/dev/block/boot of=/sdcard/boot.img
      5) wait for the command to complete. The image should now be on the sd card

      I hope you can help me with this. Once I have the image I intend to try and port TWRP for this device and maybe test other firmwares.



        FYI, I managed to install the H96 Pro Plus firmware from here:

        Everything seems to work except WiFi so far.

        I used the bootable SD card method since I don't have access to a Windows machine at the moment. (

        I also tried X96 firmware but that did not boot. (
        Last edited by floppymaster; 11-15-2017, 22:28.


          Why I hate it?:
          If I run any app almost inmeadiately after turning on this thing it hangs, I have to wait like 20 secs if I don't want hangs
          The device is somewhat slow in the emulation aspect, I was hoping to use like a SNES Classic alternative, but I feel some lag in Retroarch (mostly in Super Mario World)
          The remote control suuuuucks!

          I couldn't use the Partitions Backup & Restore app 'cause my box is not rooted
          and for some strange reason I can't detect the devide with ADB (windows and linux)... I have a USB male to male, maybe because is a USB 3.0???

          Geekbuying has the IMG update for this box:, could it be useful?
          if not, any ideas? maybe trying to root my box


            Ok, fair enough, sounds like you have plenty of reasons to hate it

            Are you sure you are talking about the Z69 Max? The link you provide is for the Z69 Plus which is a different model... Also, my box was rooted when I received it as far as I can remember.

            For ADB: did you enable usb debugging under Developer Options?

            Thanks again for your effort.


              You're right, I mistook the Z69 model, mine is the "Plus" (3 and 64gb) and for the looks of it is made by another company.
              if I were able to get the boot image maybe it will be useless
              and yeah, I activated the Development options before the ADB comands.



                No worries. I'm good for now with the H96 Pro Plus firmware although would still like to have the original firmware eventually. Thanks anyway.


                  You can find that firmware here:


                    Originally posted by androidbill View Post
                    That's for the "z69 plus" and not the "z69 max" model. I did try it on the z69 max though, but it did not seem to run smooth and was missing the Android navigation bar. WiFi did work with this one.