Announcement

Collapse
No announcement yet.

[ROM] New H96 Pro+ LP firmware 15-11-2019

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [ROM] New H96 Pro+ LP firmware 15-11-2019

    So apparently there is a new firmware for H96 Pro+ LP signed as aml_s912_7.1_H96PROPLUS_mac_LP_20191115 listed on h96tvbox site.
    So far I have downloaded and flashed it last night - but that would be it.

    Please note I did not use USB Tool, nor Card method - I unpacked it in AMLogic Tools (ver.4), threw out garbage apps, added my own set and repacked it as .zip upgrade package and clean flashed it in TWRP.

    It has normal canzone launcher (but somewhat... nicer? I left it in .img file while repacking just to check it out), but I had no trouble with changing it to Google Laucher (although you have to use "Search" for main screen options in settings if you set any launcher to be used not "just once" but "always").
    What I did notice is that the whole interface appears to be... brighter and shinier

    For those who'd like to check it out - links below:

    site:
    https://www.h96tvbox.com/content/6-Firmware-upgrade

    rom:
    https://drive.google.com/drive/folde...OahCbRP1nmNxWB

    #2
    Any chance you could upload your TWRP version? I have a v2 box that needs a fix anyways.

    Comment


      #3
      Sure thing - there you go - onedrive host:

      https://jxjjxy-my.sharepoint.com/:u:...ZSA?download=1


      Positive note is that I managed to flash it on a Wisdom unit (yep, and working fine) - negative is I am still struggling to revive the other, dd4 one and I think I've given up, time to let it go
      Anyway, hope the file will be useful somehow - packed with 7zip.

      here's flashable .zip as well - for clean flash (+some apps) after a backup in twrp:
      https://jxjjxy-my.sharepoint.com/:u:...3sA?download=1


      Cheers!
      m.

      Comment


        #4
        Thank-you very much!

        My current setup froze 10-15 times today...was about to reflash my back-up.

        Your TWRP Installed fine on my CZ-S32-v2.2
        • Turned on >Developer Option.
        • Turned off >Location
        • Turned off >Scan for harmful programs
        • Installed Microsoft Launcher (Will try Google Launcher later)
        • Installed Chrome 57.0.297.132 (Older and has security flaws..but it works on these China Boxes.)
        • Playstore cache/data needs to be cleared or won't start.
        • Playstore shows many more "Your device isn't compatible" (Build.prop tweak did not work/wrong.)
        • Side loaded Youtube for android (Can't remember why I did not like Smart-youtube 2018)
        • Modified Build.prop
        #4k YouTube + Others
        sys.display-size=3840x2160
        sys.display-size.check=false
        • ?

        Antutu v8.04-OB (side loaded)

        63227

        *** Oops*** Back to previous Firmware. Played with Build.prop too many times(didn't make a TWRP backup). Testing done-till China Box acts up again. 
        Last edited by ReaperMan; 12-02-2019, 02:13.

        Comment


          #5
          Originally posted by miziou View Post
          Sure thing - there you go - onedrive host:

          https://jxjjxy-my.sharepoint.com/:u:...ZSA?download=1


          Positive note is that I managed to flash it on a Wisdom unit (yep, and working fine) - negative is I am still struggling to revive the other, dd4 one and I think I've given up, time to let it go
          Anyway, hope the file will be useful somehow - packed with 7zip.

          here's flashable .zip as well - for clean flash (+some apps) after a backup in twrp:
          https://jxjjxy-my.sharepoint.com/:u:...3sA?download=1


          Cheers!
          m.
          Wow, are you sure it's working on a wisdom?
          I have a hard bricked h96 pro+ wisdom from bangood s912 3GB LPDDR3 32GB SAMSUNG eMMC that I am trying to bring back to life via the shortcut pin method. Would your image work? If not could you suggest a firmware that works? I don't want to make it even worse ( can it get worse? :P)

          Comment


            #6
            Originally posted by miziou View Post
            Sure thing - there you go - onedrive host:

            https://jxjjxy-my.sharepoint.com/:u:...ZSA?download=1


            Positive note is that I managed to flash it on a Wisdom unit (yep, and working fine) - negative is I am still struggling to revive the other, dd4 one and I think I've given up, time to let it go
            Anyway, hope the file will be useful somehow - packed with 7zip.

            here's flashable .zip as well - for clean flash (+some apps) after a backup in twrp:
            https://jxjjxy-my.sharepoint.com/:u:...3sA?download=1


            Cheers!
            m.
            Wow, are you sure it's working on a wisdom?
            I have a hard bricked h96 pro+ wisdom from bangood s912 3GB LPDDR3 32GB SAMSUNG eMMC that I am trying to bring back to life via the short circuit pin method. Would your image work? If not could you suggest a firmware that works? I don't want to make it even worse ( can it get worse? :P)

            Comment


              #7
              Originally posted by ReaperMan View Post
              Thank-you very much!

              My current setup froze 10-15 times today...was about to reflash my back-up.

              Your TWRP Installed fine on my CZ-S32-v2.2
              • Turned on >Developer Option.
              • Turned off >Location
              • Turned off >Scan for harmful programs
              • Installed Microsoft Launcher (Will try Google Launcher later)
              • Installed Chrome 57.0.297.132 (Older and has security flaws..but it works on these China Boxes.)
              • Playstore cache/data needs to be cleared or won't start.
              • Playstore shows many more "Your device isn't compatible" (Build.prop tweak did not work/wrong.)
              • Side loaded Youtube for android (Can't remember why I did not like Smart-youtube 2018)
              • Modified Build.prop
              #4k YouTube + Others
              sys.display-size=3840x2160
              sys.display-size.check=false
              • ?

              Antutu v8.04-OB (side loaded)

              63227

              *** Oops*** Back to previous Firmware. Played with Build.prop too many times(didn't make a TWRP backup). Testing done-till China Box acts up again.?? 
              To tell you the truth, I hadn't spent much time with it - got quite angry with Perfect Player refusing to work flawlessly with my iptv subscription, but that must be my 5G.
              I recall I once flashed some custom firmware that I had no problem with streaming services while using 5G WiFi but I can't remember which one - not NexusUltra, nor SCV and Frankenstein neither - I know because I already checked just for the sake of knowing
              Also I think there were no trouble with Play Store when I flashed my homemade OTA .zip file over - I think 20180826 - but when I flashed it with USB Burning Tool and all was as you described it.
              Not only one has to clear app's cache, it also doesn't upgrade itself and stays on this nasty old version look and features. Usable, but awful.
              Plus, this is damn irritating...
              I'll try to replace it with a newer and official version once I find time for playing with my box again.
              As for YouTube, I got used to wonderful Vanced version on my mobile but found it not so appealing while on tv box - background play is superb when you want it, but when you don't the obligation to close one app three times because of its smaller instances constantly playing is tiresome.
              That is why I stayed with Smart Youtube TV - nice quality options to choose from - the only drawback I can think of is Android TV search interface which, well, sucks.
              There also once was YouTube Red .apk (that shouldn't be confused with I believe once a subscription name) that I think was more official-like without annoying ads, but I haven't used it for quite a while.

              All in all, I also need to sit back and take a look at this supposedly new test-keys rom.
              Now I'm in search of a rom with best WiFi drivers and settings for my v.6

              Thanks for getting back to me with a review!
              Cheers!
              m.



              Originally posted by NTAHS View Post

              Wow, are you sure it's working on a wisdom?
              I have a hard bricked h96 pro+ wisdom from bangood s912 3GB LPDDR3 32GB SAMSUNG eMMC that I am trying to bring back to life via the short circuit pin method. Would your image work? If not could you suggest a firmware that works? I don't want to make it even worse ( can it get worse? :P)
              I am positive, but there is a big but - my wisdom unit was not LP version.
              And just as I explained it earlier - I flashed this rom in TWRP over the official stock rom.
              The only thing I think I did was replacing certain files with the ones from stock rom in Customization Tool - that is:
              aml_sdc_burn.UBOOT
              bootloader.PARTITION
              DDR.USB
              UBOOT.USB
              so that they would match my box - but I can't tell you for certain, I recovered three different softbricked devices since that time and done some trials on them too, so all is mixed in my memory now.
              Sorry.
              But, what I can do is I can check tomorrow the board version of my Wisdom unit and get back to you with that info.

              As far as I know, Wisdom units are pain in the back as it comes to firmware - they seem to reject any other than stock made for them.
              But don't entirely trust me on this, as I only had one Wisdom unit so far - I fought with it for a couple of nights trying god-knows how many roms before I decided that the only ones I hadn't tried were said Wisdom ones.
              I picked the newer available on mega H96 Pro+ folder and magic happened.
              Me flashing this newest rom from this thread was just curiosity if I could pull it off with dirty flash without much thinking about it, and it worked.
              Luck, I guess.

              What I can advise to you, stick to the firmware with 'LP' in name.
              Provided you won't phisically damage memory, you can try as many times as you like - USB Burning Tool will communicate the errors, and what I learned, most of the times it is right, kind of
              Check the famous mega folder - in Wisdom subforder you will find two versions of working firmware for Wisdom units.
              Sadly, neither of them is for LPDDR according to the description in name.
              You can try them out, but if no luck - start checking the others - Shonk modified ones perhaps - but with careful reading of text files included in folders.
              Remember, that your board signature points to exact firmware you should be trying to flash (or Shonk's Shmod vresions you should pick and try out).
              Check the board and pick your firmware accordingly - if it's CZ-S32-v2.2 do not pick a rom for v.6 and so on (at least at the beginning and without proper modifications if needed).
              here's the folder in case you missed it so far:
              http://mega.nz/#F!8qhRRaYJ!2ZA3VLjvL...TF27g!pjRnUKBK

              If still no luck, you can try out repacking a given rom designed for a different version than yours, and replacing those 4 mentioned before files and packing it to a new .img file to be tried in USB Burning Tool, or SD card method - so get yourself familiar with Amlogic Tools and its Customization Tool app.
              What would be helpful here is knowing which exact firmware should work on your device, and ideally which one you tried to flash that bricked your device.
              But then again, there are nuances to this like given method like settings selection, correct bootloader, recovery etc.
              Quite a task if you're doing it for the first time - and believe me - I know.

              And one more thing - if your PC has no problem with recognizing the devices - do not overdo short pin method.
              Try simple reset button procedure - you can minimize the threat of damaging the memory.
              Treat pins shorting as a kind of last resort when your PC does not recognize your device despite having your drivers installed and working fine a second ago (which may also be a fantastic indicator that you probably chose the wrong firmware to flash).

              Then there are different sequences for connecting your device when flashing, various programme versions to be checked one after another, Windows playing with drivers, and so on and so forth.
              I wish you good luck - try this one if you like - what you risk is an error code from USB Burning Tool, which will also give you some kind of feedback and new word sequence for searching through the web.

              btw - how do you know you hardbricked your device? It usually means there is no chance of bringing it back to life due to e.g. phisical damage.
              If your device is responsive, there is still a chance.
              So far I only had one device I gave up on - sold it two days ago to a guy, who said that even if the memory is damaged, he is able to replace it. Good for him, I'll keep my money

              Cheers!

              Comment


                #8
                Thank you for your reply. I called it hard brick since there was no response and no light when connecting to power. Anyway fortunately I managed to find the pins and recover my box with original firmware and then successfully flashed Atvxperience v2h LPDDR3 version:

                Comment


                  #9
                  Good news then, I'm glad to hear it.
                  Not a big fan of ATVs, but if it works for you, then it's all that matters.

                  Comment


                    #10
                    Installed aml_s912_7.1_H96PROPLUS_mac_LP_20191115 on a CZ-S32-v6.
                    • Play Store is borked (on purpose by original dev?) Apps must be side loaded! Paid apps work but are not seen by Play Store.
                    • Play Store manual update fails.
                    • Updating Play Services does install...leading to cascade paid-apps failure!
                    Installing GAPPS fails. Warning incompatible api22. This is Android 5.1.1 Lollipop SDK 22 system files.

                    Might be fine for anyone who has no use for the Google Play Store experience...
                    There are other mods that strip these services out.

                    On a positive note...this is why its called testing!
                    Thousands of Apks and countless Firmwares.

                    Keep the firmwares coming!

                    Comment


                      #11
                      Originally posted by ReaperMan View Post
                      Installed aml_s912_7.1_H96PROPLUS_mac_LP_20191115 on a CZ-S32-v6.
                      • Play Store is borked (on purpose by original dev?) Apps must be side loaded! Paid apps work but are not seen by Play Store.
                      • Play Store manual update fails.
                      • Updating Play Services does install...leading to cascade paid-apps failure!
                      Installing GAPPS fails. Warning incompatible api22. This is Android 5.1.1 Lollipop SDK 22 system files.

                      Might be fine for anyone who has no use for the Google Play Store experience...
                      There are other mods that strip these services out.

                      On a positive note...this is why its called testing!
                      Thousands of Apks and countless Firmwares.

                      Keep the firmwares coming!
                      This Play Store is bugging me - I tried to install updated one over it, but the system didn't let me.
                      I also played with GApps - same conclusion as yours.
                      And of course, one can use Aptoide, APKPure or even ACMarket - but I'm going lazy lately and Play Store became essential for my well-being

                      I'll try to tinker with it when I have some time - as for now I went back to 20180824.

                      But in the end when I come to think of it, I'm quite surprised by the fact that a new rom version came out - even if it's test-keys

                      Comment


                        #12
                        LOL, I restored TWRP 20180824 system files onto this firmware...some apps had to reinstall for proper setup...so a "Freakinstein" setup now.

                        Comment


                          #13
                          Originally posted by miziou View Post

                          This Play Store is bugging me - I tried to install updated one over it, but the system didn't let me.
                          I also played with GApps - same conclusion as yours.
                          And of course, one can use Aptoide, APKPure or even ACMarket - but I'm going lazy lately and Play Store became essential for my well-being

                          I'll try to tinker with it when I have some time - as for now I went back to 20180824.

                          But in the end when I come to think of it, I'm quite surprised by the fact that a new rom version came out - even if it's test-keys
                          Please link Aml_s912_7.1_H96PROPLUS_mac_LP_20180824?
                          Thanks

                          Comment


                            #14
                            I think this may be the original link..otherwise Google around.

                            https://drive.google.com/drive/mobil...OahCbRP1nmNxWB

                            PM, I will try to send to you.

                            Comment


                              #15
                              Originally posted by ReaperMan View Post
                              I think this may be the original link..otherwise Google around.

                              https://drive.google.com/drive/mobil...OahCbRP1nmNxWB

                              PM, I will try to send to you.
                              Thanks for ROM

                              Comment

                              Working...
                              X