Announcement

Collapse
No announcement yet.

[ROM] SC v1 USER/USERDEBUG - GTKing SN: B922 - "Normal" Build

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [ROM] SC v1 USER/USERDEBUG - GTKing SN: B922 - "Normal" Build

    (Sorry the delay, but as you guys know i from now on only do original roms from source directly and that takes time lots of it... if i use a already made rom i could do a rom in 1h...)

    DISCLAIMER: MY ROMs(WORK) CAN NOT BUT USED FOR ANY COMMERCIAL PROJECTS WITHOUT MY CONSENT.

    Anyway, one more rom/fw for you all!
    And many thks to trebor for be my beta tester
    Build from Latest source, all changes done in source itself...
    Btw from now on im going to be very "economical" about my changelogs...
    This rom might work on older SN: 922X.... but it will be slow and might not works correctly all the time so i do not recommend to use it on that SN number devices.

    THIS BUILD IS FOR SN: B922..... it should also work in PRO version just fine but you will lose DTS-HD support, i will be doing a specific build for PRO in a near future.


    Differences of USER and USERDEBUG builds:

    User Build: This build is done to be as close to a company rls as possible, it does not have root or twrp and is compiled with rls keys and SELINUX enforced, what this means for you?
    Well it means lot more apps show in Playstore that dint show before, (EX: my isp androidtv live tv app, only shows in Playstore non rooted and SELINUX enforced devices, also the streams in the app does not even play in rooted devices.). Like this there's lots of other ISP/NON ISP apps Out there....

    UserDebug Build: This build does have root, twrp, selinux is permissive and some other stuff you will see in changelog down there.., but of course you will lose the above...

    OF COURSE YOU WILL NOT LOSE WIDEVINE L1 IN ANY OF THE BUILDS...

    CHOOSE YOUR VENNON........

    Changelog:
    • Build from latest AML Pie SDK
    • Long press Home button to show navigation bar, double press shows recents.
    • Dolby Atmos HW decode support (NOT HD)
    • Reboot to TWRP or Switch OS ( Only on UserDebug build )
    • Bla bla bla
    • Bla bla bla bla
    • Bla bla bla bla bla...
    • etc.....

    Bugs:
    • Of course there is bugs!! there always be bugs!!


    Want to buy me a beer?

    Download:

    Install instructions:
    • Use usb burning tool 2.2.0 to burn the IMG.


    THIS ROM DELETES ALL YOUR DATA SO DO A BACKUP!

    USE AT YOUR OWN RISK!

    Enjoy it!
    Last edited by superceleron; 01-06-2020, 07:20.

    #2
    Tks, for your work in develop betther firmwares that the one beelink released...

    Comment


      #3
      Hello dear superceleron,

      first of all thank you very much for your great work again as i am a long time fan since your GT1 rom. As my still good working GT1 was forced into obsolescence as some apps didn't support Android 6-7 anymore i was glad to see that you were working on the GT king . I installed your rom yesterday and while setting up my box, i noticed few strange behavier which i didn't have on my GT1. First of all,i am on your
      UserDebug Build and i am not using the remote control but an USB mouse to control the box (could be one of the explanations)...

      1) with square home launcher......when i click on the home button (the bar on the bottom where you have shutdown button, sound, home button, recent apps...)....its reacts either with delay or not reacting at all. Using an app switcher (EAS) its reacts immediately.
      2) the shutdown button has only 1 option?.. no choice for either restart or shutdown? (sorry was spoilt from your earlier rom)
      3) as the square home launcher needs "some getting used to it"... i tried to install Nova launcher which i know quite well. Normaly if i wanted a shortcut on my frontpage i went to the app drawer and longpress a app-icon to place it on the front page. This seems not to be working. The longpress normaly gave you as well more option like app info or disinstall? I tried few other launchers... same problem....
      any thoughts or workaround will be very welcome
      have a nice day

      Comment


        #4
        Originally posted by ender41 View Post
        Hello dear superceleron,

        first of all thank you very much for your great work again as i am a long time fan since your GT1 rom. As my still good working GT1 was forced into obsolescence as some apps didn't support Android 6-7 anymore i was glad to see that you were working on the GT king . I installed your rom yesterday and while setting up my box, i noticed few strange behavier which i didn't have on my GT1. First of all,i am on your
        UserDebug Build and i am not using the remote control but an USB mouse to control the box (could be one of the explanations)...

        1) with square home launcher......when i click on the home button (the bar on the bottom where you have shutdown button, sound, home button, recent apps...)....its reacts either with delay or not reacting at all. Using an app switcher (EAS) its reacts immediately.
        2) the shutdown button has only 1 option?.. no choice for either restart or shutdown? (sorry was spoilt from your earlier rom)
        3) as the square home launcher needs "some getting used to it"... i tried to install Nova launcher which i know quite well. Normaly if i wanted a shortcut on my frontpage i went to the app drawer and longpress a app-icon to place it on the front page. This seems not to be working. The longpress normaly gave you as well more option like app info or disinstall? I tried few other launchers... same problem....
        any thoughts or workaround will be very welcome
        have a nice day
        1. well long press home is only to enable the nav bar, that is it because it comes disabled by default... once enabled you need to use the air mouse cursor get near the button and it auto shows the navbar.

        2. sorry didn't get this one, you mean long press the power button in navbar? if yes then is normal... long press the powerbutton in your remote and it will shows you the options

        3. Need to check when i have the time, i don't use other launchers only squarehome and i know the long press is working fine on it.

        Comment


          #5
          thank you for your reply ) .... sorry that i was't clear in my description,not easy for a layman (english is not my mothertongue)... maybe connect your box with a mouse it will be easier to understand

          1) + 2) seems that the problem occures while controling the box with a mouse.... will try the remote control tonight
          3) thank you....will try the long press on the remote control on Nova laucher tonight as well

          Comment


            #6

            superceleron

            Thank You for the hard GREAT work!

            I tried this USERDEBUG rom, but unfortunatelly the issues still exist

            "I use Your rom but i have an issue which is not only with your rom. I have a Samsung soundbar Hw-q90R and a Samsung TV QE55Q6FNA 4k UHD.
            When i connect the GT-king dirrect to TV HDMI is O.K. When i connect the box to Soundbar HDMI in and the HDMI(ARC) to TV (for the Dolby Atmos) the video signal is lost, have to connect disconnect randomly cables for getting back the signal. First i thought its a Soundbar issue. But if i try another 4K device example xbox one s the HDMI issues non exist. After that i accepted this is a incompatibility between soundbar and king. But i install Coreelec to the king and voila hdmi issue isn't exist. So it have to be firmware issue mainly in the stock firmware too. Sorry if it was to long, but it made me crazy from 2-3 days. Could ou imagine what the trouble is? Thank You again for the firmware"

            Comment


              #7
              Originally posted by rruzsi View Post
              superceleron

              Thank You for the hard GREAT work!

              I tried this USERDEBUG rom, but unfortunatelly the issues still exist

              "I use Your rom but i have an issue which is not only with your rom. I have a Samsung soundbar Hw-q90R and a Samsung TV QE55Q6FNA 4k UHD.
              When i connect the GT-king dirrect to TV HDMI is O.K. When i connect the box to Soundbar HDMI in and the HDMI(ARC) to TV (for the Dolby Atmos) the video signal is lost, have to connect disconnect randomly cables for getting back the signal. First i thought its a Soundbar issue. But if i try another 4K device example xbox one s the HDMI issues non exist. After that i accepted this is a incompatibility between soundbar and king. But i install Coreelec to the king and voila hdmi issue isn't exist. So it have to be firmware issue mainly in the stock firmware too. Sorry if it was to long, but it made me crazy from 2-3 days. Could ou imagine what the trouble is? Thank You again for the firmware"
              I think the linux-coreelec/libreelec HDMI-CEC driver is much good than android driver. I have 3 different android box and neither of them is issueless (less or more) . All of them works better, more stable and have more commands and settings on linux.
              If someone will can adapt linux HDMI-CEC driver to android ...

              Comment


                #8
                Thank You, this is the answer that i was afraid of

                Comment


                  #9
                  yes the linux driver is more complete and advanced than the one aml is using in android... theirs not much we can do, unless aml updates the driver

                  Comment


                    #10
                    Anyway Thank you! Go ahead AML
                    So is there a chance for Netflix UHD + Dolby TruHD on GT King either on Coreelec or Android?

                    Comment


                      #11
                      Originally posted by rruzsi View Post
                      Anyway Thank you! Go ahead AML
                      So is there a chance for Netflix UHD + Dolby TruHD on GT King either on Coreelec or Android?
                      in coreelec who knows... maybe if the netflix addon gets better, on android nop just forget it.

                      Comment

                      Working...
                      X