Unconfigured Ad Widget



No announcement yet.

Cannot install KODI 18 Alpha2 on Beelink GS1 since Android 7.1 update

  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot install KODI 18 Alpha2 on Beelink GS1 since Android 7.1 update

    Hi guys,

    I have an issue that is probably a firmware issue.

    Some noteworthy information:

    The Android Box is a Beelink GS1 running the latest release of firmware which is Android 7.1 dated Jan 2018 from Beelink. Previous to this update, I believe the GS1 box ran all Alphas of KODI without issue.

    Currently KODI 17.6 installs and runs aok on this box

    However, the latest KODI Alpha2 code will not run without crashing at startup. After it has crashed, everything (all apps) appear to give "corrupted" messages when I try to run them until I reboot the box. Once rebooted, everything works ok (except KODI).

    I have factory reset the box (many times). On a freshly wiped and rebooted box, I try to install KODI Alpha. It appears to install ok. When I run it, I get the fancy picture and the line at the bottom saying that KODI is starting for the first time. At the point where I would expect it to clear the screen and show the KODI menu, the KODI app crashes and puts me back to Android.

    Remember that I am Factory Restoring between each attempt. I have tried many Alpha builds and the same USB key installs cleanly on other Android boxes.

    There are no other Android apps installed other than what comes from the factory build.

    Since KODI never starts, it is implied that I have no add-ons other than what KODI installed.

    I have lots of various boxes here to play with. All of them work AOK with the nightly KODI builds. Only the GS1 is crashing and only since it took an Android 7.1 update. I would ignore the failure and toss the box aside except for the fact that KODI 17.6 works 100% ok. Something between this Android 7.1 update and KODI 18 nightly builds has changed causing grief. I would be happy to tweak something if could help in debugging.

    Is your issue solved?
    I have a similar issue with KODI 18 beta3
    GS1 is normally a 64 bit architecture but Kodi 18 Arm64 does not want to install; incompatibility msg.
    Arm32 is installing but at the end, after the first load, kodi crashes and back to Android screen
    I had to uninstall Kodi , install back 17.6 and loose all config.
    Here also the 32 and 64 bits versions found on Kodi website do not work.
    I had to download the one from Google Play to have Kodi 17.6 work.


      I am facing the same issue. I tried even nightlies but they too crassh on loading. No fix either from Beelink or Kodi. Also, no recent firmware updates for GS1. Feel cheated.


        working since final Kodi 18 release