No announcement yet.

Help me please erro [0x30405004] USB burning tool

  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Nebojsa View Post
    My SN is also AX12.

    [0x10105002]romcode/initialize ddr/read initialize status/USB control setup error
    this is the error on 2%

    [0x10303004]romcode/switch status/identify/error result
    this is the error on 4%

    Tried lot of roms with N0 but no luck, everytime those errors.
    Have very good cable, tick and short, 50cm.
    Also what android version did you have on it right before you tried to change it and or upgrade it?

    Also did you try this?
    Make sure you check erase bootloader when your flashing with Amlogics's USB Burning Tool. Also it seems to help me out when I first plug the box in through usb and while holding down the reset button with the paper clip on the bottom and once the box is recognized by the USB Burning tool then I plug in the power cable also, this seems to help with flashing boxes and I get less errors trying to flash it this way. I feel like sometimes just the USB cable is not enough power.


      I can't remember what version was before.
      I tried every possible combination, check erase bootloader, uncheck erase bootloader, normal erase, force erase all, with power supply, without power supply...
      I do not have the problem with recognizing devise, USB Burning tool always recognize it, problem is when flashing start.


        Do you know if it was Android 6.0 or Android 7.1?
        Also did you try the power plug once box was recognized through usb burning tool?
        Did you try SD Card method?


          Think that was 7.1.
          Yes, box is recognized and I plug the power adapter
          or, plug the power adapter then USB, box is recognized like it should.
          ​​​​​​Tried SD card method but nothing happened, no reaction at all. I tried with all roms I have found. Once I leave the box for half an hour to see if anything will happen, but nothing.


            Okay, So you would have to plug in USB first then power adapter afterwards you can't plug in power then USB then it won't work properly. I do see you said you tried both ways. So it looks like there is something else wrong with the box. Only other thing is trying to play with force erase and uncheck bootloader options and play with all these other options that usb burning tool has. Sorry but it looks like it's a bad flash, somewhere in the middle of flashing something didn't go as expected. Sorry I couldn't be of any more assistance.


              OK, thanks for trying.


                Apparently you have damaged the Bootloader, so that the eMMC Memory can not be initialized. You must perform a full erase of eMMC Storage and reinstall Bootloader. Do you have the possibility to connect your box via UART to the computer?


                  As a matter of fact, I do.
                  I already have disassembled the box and solder RX TX GND and 3.3v to adapter.
                  What to do next?


                    Now start the box and post the bootlog here


                      If you think that I use some terminal emulator program, like Putty, and see what it says when connect box to PC, I already tried that.
                      There is just bunch of crap, sequence of signs, numbers and letters without any meaning. Something like:
                      [email protected]$$$&%5(£[]][[§
                      You got the picture.
                      Can I somehow force it to install bootloader?


                        Just a wee bit of info from my unbricking from the dead. With various ways of bricking the same unit. To me these boxes are impossible to brick into total death.

                        i have seen every error posted here with my box, and never been stumped at recovery. The NAND mask flash seems to be the best method as long as power, cable and proper flash tool is used.

                        I use 2.0.8 flash tool, if using newer, uninstall and reboot. Then install 2.0.8 and reboot.

                        hardware brick...

                        When you power on with power cable only, does the SPDIF LED light up inside the connector?

                        If not, there is not enough power is at the RAM and CPU.

                        Jumpering USB 5v power to the power input connector pin should initialise the dead portion of the system.

                        Start the flash tool with your loaded image, and connect the USB cable from the computer to the box's USB port to flash.

                        Short the pins for NAND mask.

                        Bootloader brick...

                        Obtain 5 different firmwares... M8S, Beelink, Ugoos, and two custom firmwares. Try Superceleron, and Tillas97.

                        Each firmware will give a different error. But always try factory first with force erase, on each USB port. Take note on how far it goes. If they all go to to the same area and fail, untick erase boot loader.

                        Once you find a USB port that seems to go further than the others, stick with it for all flashes.

                        My bootloader is locked, and i have done full erase, with stock firmware, so that may be something you cannot do with your device, as you loose MAC, serial number, and other device specific data needed for firmware to properly function.


                          You have connected and configured it incorrectly.

                          Putty Settings:

                          baud = 115200

                          Data bits = 8

                          Stop bits = 1

                          Parity = none

                          Flowcontrol = none

                          Wiring Conf.:

                          PCB GND <———> GND Comp.

                          PCB RX <————> TX Comp.

                          PCB TX <————> RX Comp.

                          I need to know exactly what happened to the old bootloader to describe the correct installation process


                            You are wright, I configured it incorrectly.
                            Done like you wrote and I have something in Putty:

                            LOOP:4;EMMC:0;READ:800;SD:800;USB:8;LOOP:5;EMMC:0; READ:800;SD:800;USB:8;LOOP:6;EMMC:0;READ:800;SD:80 0;USB:8;LOOP:7;EMMC:0;READ:800;SD:800;USB:8;LOOP:8 ;EMMC:0;READ:800;SD:800;USB:8;LOOP:9;EMMC:0;READ:8 00;SD:800;USB:8;LOOP:A;EMMC:0;READ:800;SD:800;USB: 8;LOOP:B;EMMC:0;READ:800;SD:800;USB:8;LOOP:C;EMMC: 0;READ:800;SD:800;USB:8;

                            And on and on...

                            "When you power on with power cable only, does the SPDIF LED light up inside the connector?"
                            No, there is no light on SPDIF, but there is light when I insert the usb cable and the USB burning tool recognize the box. Is that ok, or I have to short some pins (don't know which)?
                            Last edited by Nebojsa; 06-07-2018, 05:11.


                              the eMMC Bootloader Partition is empty, you have deleted the Bootloader. I'll write a short tutorial later on how to install the Bootloader. I'm still on the go.


                                OK, thanks a lot!