Announcement

Collapse
No announcement yet.

Problem with Ethernet. Internet Works. Doesn't see PC.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with Ethernet. Internet Works. Doesn't see PC.

    Hello, I have Tanix TX92 (3/32, s912) TV box. It's running Vorke Z6 7.1.2 Firmware. It runs fine on wifi. I can connect to ftp, Splashtop Streamer, Steam Link can automatically detect my PC.

    However, when I connect through the Lan Ethernet of my wifi router I can't connect with my PC. I can't connect with FTP server. Splashtop Streamer, Steam Link doesn't detect my PC at all. Internet connection works absolutely flawlessly. Gets great speed with ethernet.

    pic below is for visual aid. I'm using this router with DD-WRT firmware.


    Click image for larger version

Name:	rnXVujv.jpg
Views:	290
Size:	64.6 KB
ID:	784501

    I'm sure I'm missing something.. any help is greatly appreciated.

    #2
    Well.. its proberly a dns issue
    -aka wifi using dhcp / lan using dns 8.8.8.8 as default?
    Try using a static ip/dns/gateway on your androidbox ( lan/advanced settings )

    cheers

    Comment


      #3
      UPDATE: I found a solution

      Apparently the problem was on my TPLINK Router with DD-WRT Firmware. I tried my other Router and that worked fine.

      So here's what I did to my TPLINK Router with DD-WRT Firmware to fix this problem.

      Go to DD-WRT > Administration > Commands

      Copy and Paste the Code below and Click "Save Startup" Button and reboot


      Try adding the following to the router's startup script and rebooting.

      Code:
      LAN_IF="$(brctl showstp br0 | grep -Eom1 "^eth[0-9]")"
      swconfig dev $LAN_IF set enable_vlan 1
      swconfig dev $LAN_IF set apply

      That's it.

      Screengrab:
      Click image for larger version  Name:	lT47ENj.jpg Views:	0 Size:	121.6 KB ID:	786278

      It should work now. I can Access my FTP on my PC and Play games with Steam Link.

      Here's the thread that helped me.
      https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1129917

      Hope that helps if anybody else is having this problem.

      Comment


        #4
        Originally posted by maga_man View Post
        UPDATE: I found a solution

        Apparently the problem was on my TPLINK Router with DD-WRT Firmware. I tried my other Router and that worked fine.

        So here's what I did to my TPLINK Router with DD-WRT Firmware to fix this problem.

        Go to DD-WRT > Administration > Commands

        Copy and Paste the Code below and Click "Save Startup" Button and reboot


        Try adding the following to the router's startup script and rebooting.

        Code:
        LAN_IF="$(brctl showstp br0 | grep -Eom1 "^eth[0-9]")"
        swconfig dev $LAN_IF set enable_vlan 1
        swconfig dev $LAN_IF set apply

        That's it.

        Screengrab:
        Click image for larger version Name:	lT47ENj.jpg Views:	0 Size:	121.6 KB ID:	786278

        It should work now. I can Access my FTP on my PC and Play games with Steam Link.

        Here's the thread that helped me.
        https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1129917

        Hope that helps if anybody else is having this problem.
        +1

        Comment

        Working...
        X