Unconfigured Ad Widget



No announcement yet.

Cyanogenmod 11 booting in E-Ceros Revolution

  • Filter
  • Time
  • Show
Clear All
new posts

    Cyanogenmod 11 booting in E-Ceros Revolution

    Probably TL;DR
    Had some free time so decided to play with stuffs.
    I haven't done any developments, just did a little of this and a little of that and finally was able to boot up Cyanogenmod 11 in E-Ceros Revolution.

    Here are the steps I did.

    1. Downloaded CM 11 for Radxa Rock from another topic: http://freaktab.com/forum/tv-player-...cyanogenmod-11

    2. Flashed it in the tablet.

    3. It boots up (makes small kirk-kirk sound) but nothing in the display. Since it was for Radxa Rock, I was pretty sure it was giving out display from HDMI, connected it to TV and yes, it works. I saw the Cyanogenmod welcome screen where we need to select our language and other settings.
    Tried tapping tablet :P of course it doesn't work.
    Connected USB OTG and tried variety of devices, mouse, keyboard, fly mouse, nothing works.

    4. Flashed stock rom so that I can take out Kernel.img & boot.img. (Doing that seemed easier that downloading and setting up RK tools to extract image ATM)

    5. Flashed both boot.img & kernel.img in the table.

    6. Yes, it works. Shows up in the tablet. But with Crappy Resolution, Crappy Aspect Ratio.
    And... Shit.. It is constatly popping up an error "Unfortunately, the process com.android.phone has stopped".
    Difficult to navigate around, as no matter how many times I press "OK" button, it just pops up. :/
    Had to keep another finger ready on which button I want to tap as soon as I tap "OK" in that error msg.
    Navigated upto wifi doing that, just to check if wifi works or not...
    And.. Unfortunately (as expected after reading comments), no, it did not work.

    7. Backed up system.img, mounted it and deleted "Telephony.apk" from apps and "TeleService.apk" from priv-apps. (Oh, how I wish I had flashed TWRP earlier)
    8. Flashed modified system.img and yes, it works. The error message goes away, am able to navigate easily.

    1. No internal storage detected.
    2. No WiFi or bluetooth
    3. No Brightness control
    4. No onscreen NavBar (I thought CM had an option in Personalization about enabling it.. didn't find). Had to press the hardware-back button.
    5. I guess no camera.. (It did not have camera app by default, so haven't tested yet)
    6. Sound works

    Will test:
    Resolution Changer
    Camera App
    Maybe Antutu

    Have attached some pictures. Didn't figure out where to save screenshot, as it did not detect the internal storage. (I guess SD card is also not detected... )

    This much for first post. Will update as I play around it a bit.
    Would love suggestions on resolving the issues.

    Uploaded Images.