Announcement

Collapse
No announcement yet.

Alfawise X5 Mini PC - Intel Atom X5-Z8350 2GB DDR3 + 32GB ROM Gig LAN Windows 10 Android 5.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #91
    Originally posted by imranlah View Post
    ...problem is i dont know how the hell cloudready literally wipe the boot logo (android/win boot logo and intel)..as soon as i turn on the pc it boot straight to cloudready logo skipping bios..i cant enter bios now..every key pressed from f1 to f12 del nothing happened.
    bios cannot be skipped, to enter it on my x5 i use the escape key not FX/del.

    Not sure how the dualboot thingy/logo actually works but that can most certainly be wiped, initially thought it was on the hdd efi partition but i cleared all those to install a single win10 partition and the boot choice is still there.. so it's probably embedded in the bios..

    Comment


      #92
      Originally posted by eldonT View Post

      here's a dump from my x5 bios, done in win 10 using Aptio V gui tool.
      Did 5 dumps, 2 had different sums, 3 identical.

      https://drive.google.com/open?id=1SA...s9PlOxlzsR52jv

      not sure how you'll update it but well..
      Many thanks eldonT, but it is very confused, the chip gigadevice 25lq64cvig has 8MB of memory, but when i did a backup, my file like your file, has only 4MB, and with the chip programmer, i need 8MB of rom file

      Comment


        #93
        yeah, when i dumped the bios with the tool, it only displayed reading the second part of the rom, i have no idea why and there didn't seem to be any option to configure the "save" function.
        i tested the other tools but aptio V was the only one recognizing this rom.

        unfortunately i wiped my windows install to put a linux server, but it seems my device is actually faulty and keeps randomly rebooting with the linux too.

        if you have a picture of the motherboard pinout to read the flash and setup/tools, i can try to do that, i just don't have time to look it up myself.

        of course i could try to dump it in linux between to reboots, i'll try that over the weekend.

        Comment


          #94
          Originally posted by Kayler View Post
          Many thanks eldonT, but it is very confused, the chip gigadevice 25lq64cvig has 8MB of memory, but when i did a backup, my file like your file, has only 4MB, and with the chip programmer, i need 8MB of rom file
          okay dumped the whole 8MB flash in linux with flashrom , 3 times, identical md5sums.

          files are on the same gdrive share in the directory flashrom.

          Comment


            #95
            weird thing, i still get the dual boot screen but only the android logo on the left and will try to boot it and fail of course.

            i can boot ubuntu from the bios, if you know how to fix that i'd be interested, i remember getting rid of the dual boot with a windows tool but i really don't want to install win again..

            Comment


              #96
              Previously reinstall Windows 10 from backup image on this forum..delete all partition and boot from USB and successfully reinstall Windows without android OS..but the Android/windows logo was still there...now when I installed cloudready (chromium based OS) the boot selection logo is gone..I need to enter bios..ESC del F1-F12,changed usb port, on/off 5times,reset button like 10 times same thing nothing happened...I thought maybe i have enabled fastboot option so I dissambled the device and remove the battery connector ..it took a little bit longer to initialize then it still boot to OS..any trick for me to try?I'm stuck with cloudready OS now..sure its a good simple browsing OS but no hardware acceleration for the device..basically slow internet browsing/video streaming..can't change display resolution to fixed at 1025x768..

              Comment


                #97
                we would have to investigate that boot system, having wiped the hdd, my guess is that it is stored in the bios, i know you can store boot logos in there.
                I don't know if it's efi specific or not.

                AMI have tools to edit bios options and logos and such, unfortunately you can't download it directly from their website, maybe when i have time i'll check that, kinda interesting.

                Comment


                  #98
                  Originally posted by eldonT View Post

                  okay dumped the whole 8MB flash in linux with flashrom , 3 times, identical md5sums.

                  files are on the same gdrive share in the directory flashrom.
                  Many thanks eldonT, finally i have repair my x5 . Now i only like to find a bios version with auto boot when power failure...

                  Comment


                    #99
                    Originally posted by Kayler View Post
                    Many thanks eldonT, finally i have repair my x5 . Now i only like to find a bios version with auto boot when power failure...
                    nice, if you find compatible bioses with more features make sure to post them here, thx.

                    Also if you did flash a wrong bios, how you restored your dead box ?
                    Last edited by eldonT; 01-14-2019, 04:39.

                    Comment


                      Originally posted by eldonT View Post

                      nice, if you find compatible bioses with more features make sure to post them here, thx.

                      Also if you did flash a wrong bios, how you restored your dead box ?
                      Yes, I'm searching a bios with power failure feature.

                      You can buy this programmer for write any bios: CH341A

                      Comment

                      Working...
                      X