Announcement

Collapse
No announcement yet.

LIVA Q2 Review ? Windows 10 and Ubuntu 18.10 (Linuxium) (CNXSOFT)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    LIVA Q2 Review ? Windows 10 and Ubuntu 18.10 (Linuxium) (CNXSOFT)

    LIVA Q2 Review ? ECS Micro PC Tested with Windows 10 and Ubuntu 18.10


    ECS (Elitegroup Computer Systems) is a Taiwanese company that has been offering mini PCs for several years now. Last year they announced their ?pocket-sized? model the LIVA Q. Originally featuring Apollo Lake SoCs it has now been upgraded and renamed as the LIVA Q2 and offers a choice of Gemini Lake SoCs.
    LIVA Q2 Review
    ECS LIVA Q2 Package
    The distinguishing feature of the LIVA Q series however is the form-factor. Compared with Intel Compute ?stick? PCs and Intel NUC ?mini? PCs the LIVA Q2 is a ?micro? PC. This micro PC is like a minimalist mini PC that includes just the minimum number of useful ports namely a couple of USB ports (3.1 and 2.0) on one side, a micro SD card slot on another and finally an HDMI (2.0) and gigabit Ethernet at the rear. The resultant micro PC is beautifully small consisting of a 70mm (2.76″) square case by 33.4mm (1.31?) tall which can still be mounted on the back of a monitor using the included VESA bracket and screws.

    LIVA Q2 specifications

    The LIVA Q2 is available with either 32 or 64GB eMMC flash, 2 or 4GB DDR4 RAM together with optionally pre-installed Windows 10. It can be purchased with either the Intel Gemini Lake N4000, N4100 or the N5000 processors. ECS kindly provided a 32GB eMMC, 4GB DDR4 RAM, N4000 model with Windows 10 for review. The Intel Celeron N4000 is a dual core processor bursting up to 2.60 GHz together with the Intel UHD Graphics 600 processor that is capable of 4K support at 60Hz. The 32GB of eMMC comes partitioned as:

    LIVA Q2 disk management

    The initial boot show a customized wallpaper and two pre-installed applications: eBLU (ECS BIOS Live Update) and eDLU (ECS Driver Live Update):
    Windows 10 Desktop LIVA Q2 initial boot Click to Enlarge
    Starting with a quick look at the hardware information shows it is aligned to the specification: ECS-LIVA-Q2-System-Information Click to Enlarge
    Intel N4000 HWiNFO64 LIVA Q2

    As usual I ran my standard set of benchmarking tools to look at performance under Windows:























    The results need interpreting carefully otherwise they could be misleading when compared to other Intel mini PCs. This is because mini PC benchmark results are heavily influenced by the quantity and type of memory and storage installed:


    Intel Mini PC Windows 10 Comparison

    The LIVA Q2 model tested with its N4000 SoC shows commendable performance being at the start of the Gemini Lake processor line up.
    Next I shrunk the Windows partition and created new a 10GB partition so I could install and dual boot Ubuntu using an Ubuntu 18.10 ISO.

    Once installed I first ran some basic commands to look at the hardware in more detail:
    Code:
        
    1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 linuxium@LIVA-Q2:~$ lsb_release -a Distributor ID: Ubuntu Description: Ubuntu 18.10 Release: 18.10 Codename: cosmic linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ uname -a Linux LIVA-Q2 4.18.0-13-generic #14-Ubuntu SMP Wed Dec 5 09:04:24 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ inxi -Fc0 System: Host: LIVA-Q2 Kernel: 4.18.0-13-generic x86_64 bits: 64 Desktop: Gnome 3.30.1 Distro: Ubuntu 18.10 (Cosmic Cuttlefish) Machine: Type: N/A System: ECS product: LIVA Q2 v: 1.1 serial: END911184200278 Mobo: ECS model: PB02CF serial: END911184200278 UEFI: American Megatrends v: LIVAQ2.06 date: 09/11/2018 CPU: Topology: Dual Core model: Intel Celeron N4000 bits: 64 type: MCP L2 cache: 4096 KiB Speed: 1327 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 2467 2: 2487 Graphics: Device-1: Intel driver: i915 v: kernel Display: server: X.Org 1.20.1 driver: i915 resolution: 1920x1080~60Hz OpenGL: renderer: Mesa DRI Intel UHD Graphics 600 (Geminilake 2x6) v: 4.5 Mesa 18.2.2 Audio: Device-1: Intel driver: snd_hda_intel Sound Server: ALSA v: k4.18.0-13-generic Network: Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci IF: wlp1s0 state: down mac: 98:22:ef:b1:3d:8d Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: f4:4d:30:c3:69:c8 Device-3: Atheros type: USB driver: btusb Drives: Local Storage: total: 29.16 GiB used: 22.29 GiB (76.4%) ID-1: /dev/mmcblk0 model: TA2832 size: 29.16 GiB Partition: ID-1: / size: 9.78 GiB used: 5.77 GiB (59.0%) fs: ext4 dev: /dev/mmcblk0p5 Sensors: System Temperatures: cpu: 52.0 C mobo: N/A Fan Speeds (RPM): N/A Info: Processes: 195 Uptime: 13m Memory: 3.67 GiB used: 867.1 MiB (23.1%) Shell: review-tests.sh inxi: 3.0.24 linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ df -h Filesystem Size Used Avail Use% Mounted on udev 1.9G 0 1.9G 0% /dev tmpfs 376M 1.6M 374M 1% /run /dev/mmcblk0p5 9.8G 5.8G 3.5G 63% / tmpfs 1.9G 0 1.9G 0% /dev/shm tmpfs 5.0M 4.0K 5.0M 1% /run/lock tmpfs 1.9G 0 1.9G 0% /sys/fs/cgroup /dev/mmcblk0p1 96M 55M 42M 58% /boot/efi /dev/loop0 88M 88M 0 100% /snap/core/5662 tmpfs 376M 48K 376M 1% /run/user/1000 /dev/mmcblk0p3 18G 17G 1.5G 92% /media/linuxium/46C6B926C6B91761 /dev/loop1 141M 141M 0 100% /snap/gnome-3-26-1604/70 /dev/loop2 2.3M 2.3M 0 100% /snap/gnome-calculator/238 /dev/loop3 13M 13M 0 100% /snap/gnome-characters/124 /dev/loop4 15M 15M 0 100% /snap/gnome-logs/45 /dev/loop5 3.8M 3.8M 0 100% /snap/gnome-system-monitor/57 /dev/loop6 43M 43M 0 100% /snap/gtk-common-themes/701 linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ lsblk -a NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT loop0 7:0 0 87.9M 1 loop /snap/core/5662 loop1 7:1 0 140.9M 1 loop /snap/gnome-3-26-1604/70 loop2 7:2 0 2.3M 1 loop /snap/gnome-calculator/238 loop3 7:3 0 13M 1 loop /snap/gnome-characters/124 loop4 7:4 0 14.5M 1 loop /snap/gnome-logs/45 loop5 7:5 0 3.7M 1 loop /snap/gnome-system-monitor/57 loop6 7:6 0 42.1M 1 loop /snap/gtk-common-themes/701 loop7 7:7 0 0 loop mmcblk0 179:0 0 29.2G 0 disk ├─mmcblk0p1 179:1 0 100M 0 part /boot/efi ├─mmcblk0p2 179:2 0 128M 0 part ├─mmcblk0p3 179:3 0 18G 0 part /media/linuxium/46C6B926C6B91761 ├─mmcblk0p4 179:4 0 1G 0 part └─mmcblk0p5 179:5 0 10G 0 part / mmcblk0boot0 179:8 0 4M 1 disk mmcblk0boot1 179:16 0 4M 1 disk linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ sudo lshw -C cpu *-cpu description: CPU product: Intel(R) Celeron(R) N4000 CPU @ 1.10GHz vendor: Intel Corp. physical id: 34 bus info: cpu@0 version: Intel(R) Celeron(R) N4000 CPU @ 1.10GHz slot: SOCKET 0 size: 2522MHz capacity: 2700MHz width: 64 bits clock: 100MHz capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg cx16 xtpr pdcm sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave rdrand lahf_lm 3dnowprefetch cpuid_fault cat_l2 pti cdp_l2 ssbd ibrs ibpb stibp ibrs_enhanced tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust smep erms mpx rdt_a rdseed smap clflushopt intel_pt sha_ni xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts umip rdpid arch_capabilities cpufreq configuration: cores=2 enabledcores=2 threads=2 linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ sudo lshw -C memory *-firmware description: BIOS vendor: American Megatrends Inc. physical id: 0 version: LIVAQ2.06 date: 09/11/2018 size: 64KiB capacity: 5056KiB capabilities: pci upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int14serial int17printer acpi usb biosbootspecification uefi *-memory description: System Memory physical id: 23 slot: System board or motherboard size: 4GiB *-bank:0 description: DIMM LPDDR4 Synchronous 2400 MHz (0.4 ns) product: 123456789012345678 vendor: ABCD physical id: 0 serial: 1234 slot: A1_DIMM0 size: 2GiB width: 16 bits clock: 2400MHz (0.4ns) *-bank:1 description: DIMM LPDDR4 Synchronous 2400 MHz (0.4 ns) product: 123456789012345678 vendor: ABCD physical id: 1 serial: 1234 slot: A1_DIMM1 size: 2GiB width: 16 bits clock: 2400MHz (0.4ns) *-bank:2 description: DIMM DDR2 Synchronous [empty] product: Array1_PartNumber2 vendor: A1_Manufacturer2 physical id: 2 serial: A1_SerNum2 slot: A1_DIMM2 *-bank:3 description: DIMM DDR2 Synchronous [empty] product: Array1_PartNumber3 vendor: A1_Manufacturer3 physical id: 3 serial: A1_SerNum3 slot: A1_DIMM3 *-cache:0 description: L1 cache physical id: 32 size: 112KiB capacity: 112KiB capabilities: synchronous internal write-back configuration: level=1 *-cache:1 description: L2 cache physical id: 33 size: 4MiB capacity: 4MiB capabilities: synchronous internal write-back unified configuration: level=2 linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ free -mh total used free shared buff/cache available Mem: 3.7Gi 653Mi 335Mi 194Mi 2.7Gi 2.6Gi Swap: 472Mi 1.0Mi 471Mi linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ sudo lshw -C network *-network description: Wireless interface product: QCA6174 802.11ac Wireless Network Adapter vendor: Qualcomm Atheros physical id: 0 bus info: pci@0000:01:00.0 logical name: wlp1s0 version: 32 serial: 98:22:ef:b1:3d:8d width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=ath10k_pci driverversion=4.18.0-13-generic firmware=WLAN.RM.4.4.1-00079-QCARMSWPZ-1 latency=0 link=no multicast=yes wireless=IEEE 802.11 resources: irq:127 memory:82000000-821fffff *-network description: Ethernet interface product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller vendor: Realtek Semiconductor Co., Ltd. physical id: 0 bus info: pci@0000:02:00.0 logical name: enp2s0 version: 15 serial: f4:4d:30:c3:69:c8 size: 1Gbit/s capacity: 1Gbit/s width: 64 bits clock: 33MHz capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=xxx.xxx.xxx.xxx latency=0 link=yes multicast=yes port=MII speed=1Gbit/s resources: irq:23 ioport:e000(size=256) memory:82404000-82404fff memory:82400000-82403fff linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ dmesg | grep "MMC card" [ 2.080227] mmc0: new HS400 MMC card at address 0001 linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ lsusb Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 003: ID 0cf3:e300 Atheros Communications, Inc. Bus 001 Device 010: ID 046d:c52b Logitech, Inc. Unifying Receiver Bus 001 Device 011: ID 10d5:55a4 Uni Class Technology Co., Ltd Bus 001 Device 009: ID 1a40:0101 Terminus Technology Inc. Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub linuxium@LIVA-Q2:~$ linuxium@LIVA-Q2:~$ lspci 00:00.0 Host bridge: Intel Corporation Device 31f0 (rev 03) 00:02.0 VGA compatible controller: Intel Corporation Device 3185 (rev 03) 00:0e.0 Audio device: Intel Corporation Device 3198 (rev 03) 00:0f.0 Communication controller: Intel Corporation Device 319a (rev 03) 00:13.0 PCI bridge: Intel Corporation Device 31d8 (rev f3) 00:13.1 PCI bridge: Intel Corporation Device 31d9 (rev f3) 00:13.2 PCI bridge: Intel Corporation Device 31da (rev f3) 00:15.0 USB controller: Intel Corporation Device 31a8 (rev 03) 00:1c.0 SD Host controller: Intel Corporation Device 31cc (rev 03) 00:1f.0 ISA bridge: Intel Corporation Device 31e8 (rev 03) 00:1f.1 SMBus: Intel Corporation Device 31d4 (rev 03) 01:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32) 02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15) 03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01) linuxium@LIVA-Q2:~$
    I then ran Octane and the result was slightly higher than in Windows: Liva Q2 Ubuntu 18.10 Octane 2Liva Q2 Ubuntu 18.10 Octane 2
    Finally I looked at real-world usage.
    I started by playing videos under Windows using both Edge and Chrome browsers. Under both browsers 4K@30fps and 4K@60fps videos played fine:
    Windows 10 chrome browser-4k-video-LIVA-Q2 ECS-LIVA-Q2-N4100-windows-edge-browser-4k-at-60fps-video LIVA Q2 Review windows-edge-browser-4k-video LIVA Q2 windows 10 chrome browser 4k at 60fps video
    although on Chrome the 4K@60fps video sometimes dropped frames which caused the occasional stutter.

    In contrast playing videos on Ubuntu was a similar story to other Intel processor-based mini PCs. Both Firefox and Chrome could not play 4K@30fps video as the result was unwatchable: however they were fine when played at 1080p:


    liva-q2-ubuntu-firefox-browser-4k-video liva-q2-ubuntu-chrome-browser-4k-videoliva-q2-ubuntu-firefox-browser-1080p-video liva-q2-ubuntu-chrome-browser-1080p-video
    The 4K@60fps and 1440p@60fps videos resulted in frames being dropped and were also unwatchable: liva-q2-ubuntu-firefox-browser-4k-at-60-video liva-q2-ubuntu-chrome-browser-4k-at-60-video
    and even at 1080p@60fps the video was juddering every few seconds: liva-q2-ubuntu-firefox-browser-1080p-at-60-video liva-q2-ubuntu-chrome-browser-1080p-at-60-video
    Playing videos using Kodi on Windows with VP9 codec and H.264 codec encoded videos used hardware to decode and were fine: Liva-q2-windows-kodi-vp9 Liva-Q2-windows-kodi-h264
    Videos encoded with H.265 or HEVC also played fine as again hardware decoding was used: ECS-LIVA-Q2-Review-windows-kodi-h265 LIVA-Q2-windows-kodi-hevc
    Gemini-Lake-windows-kodi-8k-vp9
    It was also possible to play and 8K video:
    and although this increased the CPU temperature the LIVA Q2?s quiet internal fan kept it under control at around 74?C.
    LIVA-Q2-windows-kodi-8k-temperature
    When testing Kodi on Ubuntu I first used the default ?distro? version (17.6 Krypton) as installed using ?apt?.
    Both VP9 and H.264 codec encoded videos used hardware to decode and played fine:liva-q2-ubuntu-kodi-vp9
    liva-q2-review-ubuntu-kodi-h264
    For videos encoded with H.265 or HEVC when hardware decoding was used they were fine: LIVA-Q2-ubuntu-kodi-h265
    but when software decoding was required due to specific pixel formats the video stalls: liva-q2-ubuntu-kodi-hevc
    This was resolved by installing the latest version of Kodi (18.0 Leia) from their ?ppa?: liva-q2-review-ubuntu-latest-kodi-hevc
    However regardless of the Kodi version software decoding was used when playing 8K videos resulting in stalling and dropped frames: LIVA-Q2-ubuntu-kodi-8k-vp9
    As can be seen playing videos can create higher CPU usage resulting in higher internal temperatures. The LIVA Q2 includes a virtually silent fan and is only just audible even under these load conditions when it cycles on and off. Cooling is effective and under Ubuntu I ran an VP9 video in Kodi for 20 minutes and the internal temperature remained under control averaging around 74?C with the external temperature of the device reaching in places a maximum of 34?C: fan-effectiveness-liva-q2
    The device doesn?t include any headphone jack so audio is provided only by HDMI. So for sound on Ubuntu for example when using the HDMI port you get: LIVA-Q2-Ubuntu-sound-hdmi

    ECS-LIVA-Q2-windows-sound-hdmi

    Network connectivity throughput was measured on Ubuntu using ?iperf?:

    liva Q2 review network throughput

    The download speeds for the 2.4 GHz network differed widely when repeated during testing so the figure show is an average reading.

    Power consumption was measured as follows:
    • Powered off ? 1.1 Watts
    • Shutdown ? 0.3 Watts (Windows)
    • BIOS* ? 4.2 Watts
    • Boot menu ? 3.9 Watts
    • Idle ? 4.2 Watts (Windows) and 5.7 Watts (Ubuntu)
    • CPU stressed ? 12.7 Watts (Ubuntu)
    • Video playback** ? 7.6 Watts (4K in Windows) and 10.2 Watts (1080p in Ubuntu)

    * BIOS (see below)
    ** The power figures fluctuate so the value is the average of the median high and median low power readings.

    A brief overview of the BIOS is available in the following video:


    The BIOS is limited however it does include settings for System Wake Up and Power Management.

    Drivers are available from the company?s product page.

    This remarkable micro PC achieves its size through using a sandwiched motherboard:
    ECS LIVA Q2 motherboard ECS LIVA Q2 Teardown
    Given its tiny form-factor it is impressive with the performance it delivers making it perfect for browsing the web and ideal for home or office use or as a powerful digital signage solution.

    The LIVA Q2 was slated to cost from $180 including Windows 10 however Intel?s continued short supply of Gemini Lake processors has meant that models are in short supply. It is anticipated that post March the supply of Gemini Lake SoCs will become more abundant and the LIVA Q2 will be available on Amazon.com and sites like Newegg.com.


    SOURCE: https://www.cnx-software.com/2019/02...ubuntu-18-10/?
    tЯeboЯ
    Please consider
    Donating to Freaktab
Working...
X