Announcement

Collapse
No announcement yet.

Problems with my wired network connection

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mr Dasher
    started a topic Problems with my wired network connection

    Problems with my wired network connection

    Hi,

    The only problem I am having with my X7 is the network connections. My Wifi is faster than my wired. Using speedtest.net my wired is 17Mbps and my wireless is 45Mbps.

    I have a concern that there my be issues with the wired network device due to the fact that it appears to actually be connected via USB. (As stated in the device manager) and 17Mbps is as good as it gets.

    If someone has access to both Wifi and Lan and could test their speeds that would be a big help.

    Thanks

  • jonkoontz
    replied
    Sorry to post in old thread, but it was the best one I found while searching for this issue. I have x9s windows 10 pipo's with a dell touchscreen 24" monitor attached via HDMI/USB. I was having this issue with the ethernet not being in device manager after every reboot. Scan for hardware changes in device manager would bring it back. In the display settings I had set it to show desktop on monitor 2 only, and I believe this was the issue. I guess since nothing was displayed on the pipo, it lost the ethernet device for whatever reason. When I changed it to extend display, and set monitor 2 as the main display it stopped losing the connection / device on reboot. Just thought this may help someone like me.

    Leave a comment:


  • cjeman
    replied
    oversx... Mind posting the link to MS Driver? I can only find the Windows 8 from Davicom. Thanks

    Leave a comment:


  • oversx
    replied
    I have not written for a long time. After upgrade to Win10 I did a clean install Win10. Lan driver for Davicom DM9261A is downloaded (digitally signed) directly from Microsoft. From reinstalling everything works (without fake VGA monitor, manually speeding LAN etc.).

    Leave a comment:


  • arrhenius
    replied
    Originally posted by jschmidt1492 View Post
    Possible Solution: Connect to false VGA monitor.

    From what I have gathered, the X7 enters a low power standby state whenever a display device is not connected (HDMI disconnected, TV is off, etc.). This standby mode disables the LAN (causing the internal USB ethernet connect/disconnect) and the GPU processing (Firefox and Chrome windows being all white when viewing with TeamViewer remote desktop).

    I believe I may have found a solution. I would like to see if this is the only fix required or if it was one of my many previous modifications combined with this step.


    With the main display powered on, right click on the desktop and click on screen resolution.
    Click on detect.
    Click on another display not connected.
    Under the Multiple Displays tab, choose try to connect anyway on VGA.
    Click Apply.

    Afterwards, your display should default to your main display when on, then to the nonexistent VGA display when your main display is off.

    This fools windows into thinking a display is connected when it is not and prevents standby mode.

    I have made a few other modifications previously which may have contributed to the fix but I am not sure that they're necessary.
    First is editing the Connected Standby registry settings. (Open regedit.exe, go to edit then find then search for csenabled. Set value from 1 to 0. Go under Control Panel to Power Management and Device Manager to Device Properties to put everything into Full Power/Do not turn off Mode).
    Second is manually updating to the latest Intel drivers by extracting the .exe file with 7zip and installing it through device manager. Drivers link here (https://downloadcenter.intel.com/dow...7-8-8-1-32-bit)

    I am very curious to see if this fixes the issue for other users and if the other modifications are necessary. Let me know!
    worked forme for 32 days in a round, but i have the problem again!!!


    someone still have the issue?

    Leave a comment:


  • vertical
    replied
    Ah, good old display preferences. Thanks virusX. Worked like a dream. Everything back to normal. Hope MS will not ditch classic Control Panel or at least pass all preferences to the new layout.

    Leave a comment:


  • virusX
    replied
    I had the same issue, you will have to do this in the classic Windows Control Panel: All Control Panel Items > Display > "Adjust Resolution" menu item
    It's not possible with Intel parameters or Win10 parameters.

    Leave a comment:


  • vertical
    replied
    Originally posted by jschmidt1492 View Post
    Possible Solution: Connect to false VGA monitor.

    From what I have gathered, the X7 enters a low power standby state whenever a display device is not connected (HDMI disconnected, TV is off, etc.). This standby mode disables the LAN (causing the internal USB ethernet connect/disconnect) and the GPU processing (Firefox and Chrome windows being all white when viewing with TeamViewer remote desktop).

    I believe I may have found a solution. I would like to see if this is the only fix required or if it was one of my many previous modifications combined with this step.


    With the main display powered on, right click on the desktop and click on screen resolution.
    Click on detect.
    Click on another display not connected.
    Under the Multiple Displays tab, choose try to connect anyway on VGA.
    Click Apply.

    Afterwards, your display should default to your main display when on, then to the nonexistent VGA display when your main display is off.

    This fools windows into thinking a display is connected when it is not and prevents standby mode.

    I have made a few other modifications previously which may have contributed to the fix but I am not sure that they're necessary.
    First is editing the Connected Standby registry settings. (Open regedit.exe, go to edit then find then search for csenabled. Set value from 1 to 0. Go under Control Panel to Power Management and Device Manager to Device Properties to put everything into Full Power/Do not turn off Mode).
    Second is manually updating to the latest Intel drivers by extracting the .exe file with 7zip and installing it through device manager. Drivers link here (https://downloadcenter.intel.com/dow...7-8-8-1-32-bit)

    I am very curious to see if this fixes the issue for other users and if the other modifications are necessary. Let me know!
    After upgrading the Pipo X7 to Win10, when I click detect I do not get "another display not connected" so the issue with disappearing network when I switch off my amp came back. Are there any people that had the issue and upgraded to Win10? Any new recommendations how to fool windows thinking that there's another display connected?

    Leave a comment:


  • ultrabit
    replied
    Originally posted by vertical View Post
    Did you get this result with the 3A PSU?
    yes, this one
    http://www.stontronics.co.uk/Stontro...08fb62b395.pdf

    Leave a comment:


  • vertical
    replied
    Did you get this result with the 3A PSU?

    Leave a comment:


  • ultrabit
    replied
    I thought I'd update the thread for those who are interested. Since replacing the power supply with the one in my post above I've not had one ethernet or wifi disconnection in 6 days continuous use. Previously the ethernet, wifi and HDMI would come and go of their own accord, the ethernet icon in network settings flashing enabled then disabled at random.

    I'm pretty sure the power supply that comes with the X7 doesn't supplying enough juice and isn't fit for purpose. Most likely it doesn't supply a stable 2.4A as is printed on the base.

    Leave a comment:


  • ultrabit
    replied
    I use windows remote desktop to access my Pipo leaving it on 24/7 so having it switch off ethernet, wifi and HDMI on it's own was not good.
    I tried the following:

    Set ethernet to 100baseTX - did not work
    Make new power plan with never switch hard disk and monitor off - did not work
    Turn off bluetooth (to save a few milliwatts)- did not work
    Add a secondary VGA monitor as described above- only worked short term and when pulling out the HDMI cable. If the unit was on for prolonged periods it would still switch off HDMI, ethernet and wifi.

    Then I changed the power adapter to this 3A one made in the UK (same company who make the official raspberry pi 2 power supply).
    http://www.stontronics.co.uk/Stontro...08fb62b395.pdf

    Now I've not had a wifi disconnection in the last 24 hours and the ethernet and HDMI have stay powered overnight whereas previously they would disconnect.
    Useful to note that the pin inside the power socket is 2.4mm, so a 2.1 -> 2.4mm adapter is needed.

    The below was interesting reading. The stream uses the same wifi/bluetooth chip as the pipo and there have been disconnection issues with that unit too..
    http://h30434.www3.hp.com/t5/Windows...s/td-p/4762494

    I'll update the thread if I have any further disconnections.

    Leave a comment:


  • loko
    replied
    I had exactly the same idea two days ago, so I had already "found" the solution before you did so, but I did not bother checking it out because I thought that I would have to extend my desktop to the newly added monitor, thus having mouse navigation problems while using the primary monitor. As it seems, still living in the Windows XP world has its drawbacks.

    I would have probably checked it out this weekend and posted the solution, but I am glad that you did so today, because I could just be lazy enough and not even bother trying it.

    Since I hate Windows Vista/7 configuration layout, you can guess that I really hate the "improved" Windows 8/8.1 configuration layout.

    Any way, you can also enable GodMode. Create a new folder wherever you like, and rename it to GodMode.{ED7BA470-8E54-465E-825C-99712043E01C}. This will give you a lot of configuration options in one place. You can actually type whatever else you like instead of GodMode, the only thing needed is keeping the extension as ".{ED7BA470-8E54-465E-825C-99712043E01C}" (without quotes).

    Leave a comment:


  • johnnygal
    replied
    Originally posted by jschmidt1492 View Post

    With the main display powered on, right click on the desktop and click on screen resolution.
    Click on detect.
    Click on another display not connected.
    Under the Multiple Displays tab, choose try to connect anyway on VGA.
    Click Apply.

    Afterwards, your display should default to your main display when on, then to the nonexistent VGA display when your main display is off.

    This fools windows into thinking a display is connected when it is not and prevents standby mode.
    Big thanks from me too. I only got my Pipo today and it was showing this issue. My intention is to run this headless so really needed the LAN to work without HDMI connected.
    Doing this change alone solved it. What a star!

    Leave a comment:


  • Kyrie
    replied
    Originally posted by jschmidt1492 View Post
    With the main display powered on, right click on the desktop and click on screen resolution.
    Click on detect.
    Click on another display not connected.
    Under the Multiple Displays tab, choose try to connect anyway on VGA.
    Click Apply.
    Man, you rock! Thank you!

    That works for me.

    Leave a comment:

Working...
X