Unconfigured Ad Widget

Collapse

Announcement

Collapse
No announcement yet.

Ethernet don't start ar reboot

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    init.d may not work for this as init.d is run early in boot and the ethernet device may not be ready yet.
    Smanager is an app and will run the script once fully booted.
    So this maybe why init.d for this specific script may not work.

    I will try it later and see for sure.


    Bob
    "Pzebacz im, bo nie wiedzą, co czynią"
    "Прости им, они не ведают, что творят"
    "Perdona loro perché non sanno quello che fanno"
    "Vergib ihnen, denn sie wissen nicht, was sie tun"
    "Vergeef hen want ze weten niet wat ze doen"
    "Pardonne-leur car ils ne savent pas ce qu'ils font"
    "Perdónalos porque no saben que lo que hacen"
    "Oprosti im, jer ne znaju što čine"
    "Forgive them as they know not what they do"





    Comment


      #17
      Originally posted by Finless View Post
      init.d may not work for this as init.d is run early in boot and the ethernet device may not be ready yet.
      Smanager is an app and will run the script once fully booted.
      So this maybe why init.d for this specific script may not work.

      I will try it later and see for sure.


      Bob
      Yeah, that's what I thought was happening.

      Comment


        #18
        ALso just to be sure... Put this as the first line of the init.d script

        #!/bin/sh

        Bob
        "Pzebacz im, bo nie wiedzą, co czynią"
        "Прости им, они не ведают, что творят"
        "Perdona loro perché non sanno quello che fanno"
        "Vergib ihnen, denn sie wissen nicht, was sie tun"
        "Vergeef hen want ze weten niet wat ze doen"
        "Pardonne-leur car ils ne savent pas ce qu'ils font"
        "Perdónalos porque no saben que lo que hacen"
        "Oprosti im, jer ne znaju što čine"
        "Forgive them as they know not what they do"





        Comment


          #19
          Working fine in SManager (didn't have to install busybox)

          Bob, I have actually removed that auto generated line when creating the file in SManager
          and it still works fine. But will try your option as well.

          EDIT: it didn't work Bob

          Comment


            #20
            Hey! I have an idea that I think will work without smanager. lifeisfun, can you test this for me please?

            go into /system/bin and find chrome.sh
            In this script at the bottom add the ethernet commands
            Also make sure you leave ONE BLANK line at the end of the script. This is required for some reason.

            Let me know,
            Bob
            "Pzebacz im, bo nie wiedzą, co czynią"
            "Прости им, они не ведают, что творят"
            "Perdona loro perché non sanno quello che fanno"
            "Vergib ihnen, denn sie wissen nicht, was sie tun"
            "Vergeef hen want ze weten niet wat ze doen"
            "Pardonne-leur car ils ne savent pas ce qu'ils font"
            "Perdónalos porque no saben que lo que hacen"
            "Oprosti im, jer ne znaju što čine"
            "Forgive them as they know not what they do"





            Comment


              #21
              Originally posted by lifeisfun View Post
              Working fine in SManager (didn't have to install busybox)

              Bob, I have actually removed that auto generated line when creating the file in SManager
              and it still works fine. But will try your option as well.
              Well, I'm happy to have solved the problem for you.

              Regardes

              Comment


                #22
                Originally posted by Finless View Post
                Hey! I have an idea that I think will work without smanager. lifeisfun, can you test this for me please?

                go into /system/bin and find chrome.sh
                In this script at the bottom add the ethernet commands
                Also make sure you leave ONE BLANK line at the end of the script. This is required for some reason.

                Let me know,
                Bob
                Will do ...

                Comment


                  #23
                  Bob, unfortunately it doesn't work for me

                  BTW, also tried to set Ethernet to OFF before reboot and after rebooting it was still OFF so
                  I presume the script didn't execute at all - right?
                  Last edited by lifeisfun; 01-30-2013, 07:56.

                  Comment


                    #24
                    Hello Bob.

                    How can I set the default microphone to use? I have a keyboard which usb dongle, in addition to mause and keyboard, is also recognized as a microphone and headphones, but unfortunately it does not work. I also have a webcam with a microphone that does work. Unfortunately, when I imito start is selected microphone of usb dongle. I have all the time to set up my webcam. Is there a way to do this automatically?

                    Thank you.

                    Comment


                      #25
                      OK bummer. I guess these scripts that run early actually run but when system loads, the services and framework are turning it off again. OR the hardware is just not up yet until system loads and it is initialized. I would need to do a dmesg and logcat to see what is going on in that order. I will look into a solution for this when I get some time.

                      Prova100, I honestly have no idea here. I have not looked into microphone stuff at all. My webcam works but not reliably and the mic in my webcam does not show up at all so it has never worked. One day I will get a newer webcam so I can test this kind of stuff better. Mine is a older FaceVision camera. Sorry I cannot help at this time with that issue.

                      Bob
                      "Pzebacz im, bo nie wiedzą, co czynią"
                      "Прости им, они не ведают, что творят"
                      "Perdona loro perché non sanno quello che fanno"
                      "Vergib ihnen, denn sie wissen nicht, was sie tun"
                      "Vergeef hen want ze weten niet wat ze doen"
                      "Pardonne-leur car ils ne savent pas ce qu'ils font"
                      "Perdónalos porque no saben que lo que hacen"
                      "Oprosti im, jer ne znaju što čine"
                      "Forgive them as they know not what they do"





                      Comment


                        #26
                        Hi guys, I experience the same issue but wit bluetooth, anyboby else?

                        Comment


                          #27
                          Hi bob.
                          Is a usb/lan adapter with Asix AX88772A chip supposed to work well with your rom? I'm having many problems with it, it does not get an ip and when it does, it's very very very slower than wi-fi.

                          Comment


                            #28
                            Hello.

                            I am happy to make a valuable contribution to the forum, below in detail what to do:

                            1) Install app from market SManager
                            2) Create a file with the extension. "sh"
                            3) Edit the file as follows:

                            ifconfig eth0 down
                            ifconfig eth0 up

                            4) Run SManger, and configure it to run at system startup the script that you created in step 3. Make sure that the script is run with root permissions, and most likely that you have installed BusyBox on your imito, I'm not sure that the command ifconfig is available without BusyBox.

                            Alternatively, as advised the friendly Bob, you run this script by inserting it in the / etc / init.d of magnificent 1.5 release finless. The script runs every face you start the device.

                            I hope I have been helpful.

                            Hello to all.
                            [/QUOTE]


                            Prova.
                            I have used this fix on my UG802 stick and it works fine. I have had problems with wifi not turning on at start up and other issues (power supply is ok). I now use ethernet all the time, I find it more stable, and I do not have to keep switching it on at start up. Thanks again.
                            Last edited by jim11525; 02-09-2013, 05:13.

                            Comment


                              #29
                              You must install "Bash X" also............

                              Comment

                              Working...
                              X