Announcement

Collapse
No announcement yet.

MK808B WiFi Connection Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    MK808B WiFi Connection Problem

    Hi there,

    I am having an issue with my MK808B connecting to my home network. I can connect fine to numerous other hotspots (samsung galaxy nexus, ipad, mifi, etc), but for some reason it does not want to connect to my home network.

    The MK808B shows strong signal, but every time I hit "Connect", it will say connecting for a few seconds and then just revert to saying "Saved, Secured" but without any connection being made. I have of course tried all the normal stuff about rebooting routers, etc. I have tried "Forgetting" the network several times and re-connecting - no luck. I tried setting a static IP address to my home computers thinking there might be an IP conflict issue, but that doesn't seem to be it. I also tried taking off all security on the network, but it still does the same thing.

    Some of the other forums I have looked at suggest going to some "Advanced" wifi settings on android, but the MK808b doesn't seem to have that option that I can find. I looked into my router settings and I do not have any unusual permission settings that I can tell - i.e. no "MAC address filtering" or "Access Control" enabled.

    My router is a Cradlepoint MBR-1000, and I am tethering it to a Pantech UML290 Modem for Verizon LTE internet.

    I can connect fine to this network on several other devices, including the Samsung Galaxy Nexus, which is also running Android 4.2.2.

    Admittedly I am no network expert, and it seems like there must be some simple issue that I am overlooking.

    Anybody got any ideas?

    Thanks!


    #2
    WEP Enabled?

    Originally posted by profarcity View Post
    Hi there,

    I am having an issue with my MK808B connecting to my home network. I can connect fine to numerous other hotspots (samsung galaxy nexus, ipad, mifi, etc), but for some reason it does not want to connect to my home network.

    The MK808B shows strong signal, but every time I hit "Connect", it will say connecting for a few seconds and then just revert to saying "Saved, Secured" but without any connection being made. I have of course tried all the normal stuff about rebooting routers, etc. I have tried "Forgetting" the network several times and re-connecting - no luck. I tried setting a static IP address to my home computers thinking there might be an IP conflict issue, but that doesn't seem to be it. I also tried taking off all security on the network, but it still does the same thing.

    Some of the other forums I have looked at suggest going to some "Advanced" wifi settings on android, but the MK808b doesn't seem to have that option that I can find. I looked into my router settings and I do not have any unusual permission settings that I can tell - i.e. no "MAC address filtering" or "Access Control" enabled.

    My router is a Cradlepoint MBR-1000, and I am tethering it to a Pantech UML290 Modem for Verizon LTE internet.

    I can connect fine to this network on several other devices, including the Samsung Galaxy Nexus, which is also running Android 4.2.2.

    Admittedly I am no network expert, and it seems like there must be some simple issue that I am overlooking.

    Anybody got any ideas?

    Thanks!

    Do you have WEP security enabled? I turned off my wireless security and it connected fine, but once I turned it on, nothing. I had to change the security to WPA and it worked fine, also had to reconnect ever other device in the house with the new information, but have had no connection problem since.
    Currently Inactive on Freaktab.com
    I use: MK903V | MELE F10 Deluxe | Roku 3600R
    RIP: MK808b | MK809III | PIPO M9 Pro

    Comment


      #3
      Originally posted by budgetgeek View Post
      Do you have WEP security enabled? I turned off my wireless security and it connected fine, but once I turned it on, nothing. I had to change the security to WPA and it worked fine, also had to reconnect ever other device in the house with the new information, but have had no connection problem since.
      Thanks for trying to help - I did try taking all security off the router to see if that would solve the problem, but it did not. I will try again though. Any other ideas from anyone?

      Comment


        #4
        Originally posted by profarcity View Post
        Thanks for trying to help - I did try taking all security off the router to see if that would solve the problem, but it did not. I will try again though. Any other ideas from anyone?
        Try to change the router wifi channel. Lower channels like 11

        Comment


          #5
          If you are using a 2.4 Ghz wireless controller... try using a USB extension cable with it ( the receiver that is ) so you can rule out interference

          PS... A 2.4 Ghz wireless phone system can also affect the connection as well
          Last edited by rdsok; 12-27-2013, 16:29. Reason: clarify and add about the wireless phones

          Comment


            #6
            This might solve your problem..

            I am not an expert with any of this network stuff....but, I had the same problem with my mk808b and connecting to my wifi. My wifi works on all my other devices but for some reason when I tried to connect, it would just say Save, Secured with WEP.. or something like that. So I tried connecting to a mobile hotspot, using my phone and 4g network, and it connected!
            So... my modem/ router had to be the problem for my mk808b! And, rather than change around some network/ security settings, which is way over my head, or buy a new modem/ router...I had an idea to share my wifi from my laptop...to skip over any of the network configuration jargon. I use Connectify-Me (google it.. or find something similar to it maybe). I connect to my wifi on my laptop..run connectify-me and set up a separate network name and password using the same connection...and it works! I just have to leave my laptop connected but thats not a big deal. Hope this helps!

            Comment

            Working...
            X