Announcement

Collapse
No announcement yet.

Kodi install on Ugoos UT3S Linux OS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Kodi install on Ugoos UT3S Linux OS

    Hello.

    I tried to install Kodi 15.1 Program on my device using the commands below and received an error:

    sudo apt-get install software-properties-common
    sudo add-apt-repository ppa:team-xbmc/ppa
    sudo apt-get update
    sudo apt-get install kodi

    anyone knows what can happen? thanks

    #2
    What version of Linux are you using? Is it an official Ugoos Linux or the MAC_L1 version?

    Comment


      #3
      hi. the official one who comes with it as Dual boot.

      Comment


        #4
        Originally posted by lsivan View Post
        hi. the official one who comes with it as Dual boot.
        Can only install Mac_L1 Kodi,
        Official Kodi doesn't have the 3D GPU files compiled to install or run correctly on RK3288 devices.

        Comment


          #5
          if you want to install Kodi on to A UT3 or UT3S go here:

          open up a browser window within your UT3 And go to this website:
          kodi.tv/download
          Then click on Android ARM not X86.
          It should start downloading immediately.

          Good luck

          Comment


            #6
            Originally posted by ugoos.australia View Post
            if you want to install Kodi on to A UT3 or UT3S go here:

            open up a browser window within your UT3 And go to this website:
            kodi.tv/download
            Then click on Android ARM not X86.
            It should start downloading immediately.

            Good luck
            Was MAC_L1's fix/patch merged into official kodi ARM already? Or are they/kodi using a different approach?

            Comment


              #7
              MAC_L1's requires three things, Frame buffer console disabled, MACHYBRIS and MACKODI, so I don't think "kodi.tv" will ever have all the bits required. MAC_L1 and Ugoos provide a firmware package for the UT3(S). The Ugoos Linux used is 14.10, but it will also work with 15.04, but requires a small change prior to Flashing.

              Comment


                #8
                BTW MAC_L1 works around the lack of proper Linux support from Rockchip, Mali. So Kodi probably will not address this, as it is out of their interest or control. MAC_L1 works some magic between Linux and Android to make this work.

                Comment


                  #9
                  Originally posted by mo123 View Post
                  Can only install Mac_L1 Kodi,
                  Official Kodi doesn't have the 3D GPU files compiled to install or run correctly on RK3288 devices.
                  Hi mo123,

                  Which is that? You have a linky plz?

                  Comment


                    #10
                    Here. MAC_L1 has also provided a script to accomplish this on an existing install of 15.04 or SD boot 15.04.

                    Comment

                    Working...
                    X