Announcement

Collapse
No announcement yet.

Announcement

Collapse
No announcement yet.

OpenELEC for s82, M8, MXIII, Tronsmart S89

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hardworx
    replied
    puhhh i really lost track in this Thread...
    I have ordered an "Tronsmart MXIII Android 4.4.2 TV Box Amlogic S802 Quad Core 1G/8G" and i am really not sure which version is the newest and confirmed working. It would be really helpful if somebody could drop a Link with the files for NAND. With the links posted i cannot find MXIII in the filename.

    Leave a comment:


  • bergl
    replied
    yep, right. but before reboot you must do "chmod +x autostart.sh" in shell, to make it executable.
    and change IP for box and router of course. in my example the first ip gets the box, the second sets the IP to the gateway/your.router in box. if you use WLAN, change eth0 to wlan0.

    Leave a comment:


  • Dan0r
    replied
    Im no good at all at Linux commands. Just to make sure:

    First I SSH into the box
    Then I type the code below that makes me create the file autostart.sh
    Code:
    nano /storage/.config/autostart.sh
    I then add the folowing to the file

    Code:
    ifconfig eth0 up
    ifconfig eth0 192.168.2.85
    route add default gw 192.168.2.1
    (Where the last IP is the actual IP I want)

    Then I save the file and reboot right?

    Leave a comment:


  • Dan0r
    replied
    Originally posted by bergl View Post
    Try to fix this with the autostart.sh in /storage/.config folder.
    my autostart.sh e.g.:

    Code:
    ifconfig eth0 up
    ifconfig eth0 192.168.2.85
    route add default gw 192.168.2.1

    Gonna try that tonight.
    Highly appriciated Bergl!

    Leave a comment:


  • bergl
    replied
    Try to fix this with the autostart.sh in /storage/.config folder.
    my autostart.sh e.g.:

    Code:
    ifconfig eth0 up
    ifconfig eth0 192.168.2.85
    route add default gw 192.168.2.1

    Leave a comment:


  • Dan0r
    replied
    Flashed the new 5.95.3 version but have a problem: It won't remember the static IP settings. Every reboot it gets another IP while in the OpenELEC settings I have switched to manual IP .
    Tried a complete new flash after trying an update via SSH. Still the same problem

    Anyone, any suggestion on how to fix this?

    Leave a comment:


  • bergl
    replied
    The newest openelec find here .
    To flash it, it's the same as Android-Firmware. Unpack the downloaded file, put the 3 files in root of sd-card, put it in the box and press power-button while pressing reset-button with a toothpick.

    Leave a comment:


  • Toobie
    replied
    Hey iam new here.
    Iam owning a MXIII 4K 2GB Version.

    How can I install openelec on this box?
    Which is the latest version?

    Thanks in advance.

    Leave a comment:


  • jed
    replied
    did you try a "reboot recovery" command from a PC SSH'd to the box ? I've used this recover from an OpenElec build without any recovery bootloader, but unsure if this is a Linux-only thing or if it can be used from Android too .....

    Leave a comment:


  • Kezz
    replied
    Ok I will try that I haven't yet!!!

    Leave a comment:


  • XCH
    replied
    One thing you can try i had my box flashed with a other firmware for android with a img file i flashed with my pc and otg tool usb burner next i flashed with OpenElec.

    Leave a comment:


  • Kezz
    replied
    I have tried it every way that can be tried with no luck the boot loader is locked and it will not allow access to the USB or SD card!

    Leave a comment:


  • jed
    replied
    I flashed mine back to 5.0.8 and "Power Off System" works from the power menu ! Also with 5.0.8 while playing a video you can drag (with a mouse, holding down left button) the slider to seek backwards and forwards within the video but with the 5.95 versions, this function is broken, you can only click to where you want to go. So for me, 5.0.8 is currently the best MXiii option. I wonder if the difference is that the 5.0.8 has the Google TV bootscreen and the 5.95.x has Tronsmart boot screen so perhaps the bootloaders are different ? Just a thought.

    The Analogue Audio however is not working with 5.0.8 (as it is not with 5.95 either as previously reported) and I have tried all options plus passthrough etc and still nothing. I am wondering though if the incorrect driver is in the build as it says "AML-M8AUDIO Analog" and perhaps the MX3 analog audio driver is different from that which is there (M8 ?). I hope this feedback can lead to a fix. Many thanks.

    Leave a comment:


  • XCH
    replied
    Go in to recovery with te toothpick with no sd in the mx3 then put in to your sd card with the 3 files and select install from extern en go to your sd.

    that works for me after a bricked 2 boxes.

    Leave a comment:


  • jed
    replied
    Originally posted by Kezz View Post
    lucky you!!!
    Can't you flash by USB then either ?

    Leave a comment:

Working...
X