Hello everyone, well i for some few months i bought the T95 S1 Android tv box. supposing itself says 2GB ram, and 16 storage. but like i bricked his firmware. now i used from Turewell site (not Sunvell) the firmware provided. and it boots but i have now 1Gb in the system.
I use CoreELEC distros like Emuelec, ArchLinux, Armbian. and similar versions. it boots perfectly. but i am surprised.
The ELEC distros show me like my CPU is S905L Rev B. and the board printing, Firmware, including manual says is S905w. how i can be sure i am not getting scammed. and risk damage my device?
Note: the tvbox shows his 16gb of storage, all fine.. but the ram is faked LOL. now i am running the Turewell website firmware. the only one who worked perfectly.
I tried some firmware called T95S1_2GB_TS10022 it boots, but have several issues : bootloop , clock frozen
other version idk if works was T95S1_1GB_TS10011 but itself says 1gb
finally, the stable version i got is from this website: Turewell [ https://www.turewell.com/pages/tvbox-document ]
is the only one what worked on my TVBOX.
His revision says TV BOX-AML-S905W-20190308-V1.4Click image for larger version

Name:	IMG_20210530_141229.jpg
Views:	358
Size:	56.6 KB
ID:	824908
Attached Files