Announcement

Collapse
No announcement yet.

Tanix TX6 TV Box - Allwinner H6 4/32GB Dual WiFi BT4.1 or 5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Shajuk
    replied
    Hi all,

    I managed to bring back my TX6 4/32 from brick after installing Magisk. Might be the file got corrupted during installation process.
    I used PhoenixSuit method. Tried several firmwares until I got the one that my TX6 work as usual - bluetooth, wifi and remote.
    Thanks all for your kind ideas, methods and how-to guide.

    Leave a comment:


  • Odjiex
    replied
    Originally posted by sangramd21 View Post

    Anyone has a solution for this? Bluetooth & wifi not working.
    Do not instal this firmware, it's buggy.
    try latest build 15.4.2019.
    It work for me.

    Leave a comment:


  • jietang
    replied
    Originally posted by jillblow777 View Post
    To anyone interested I got this box running great by using a root explorer/cleaner called sd maid which allowed me to remove glichy Alice ux. I installed top launcher 2 then remove alice. Also lets you remove all the garbage factory bloatware apps and now I actually like this box. Nova launcher and a few others don't run right on this box just to save you time on having to reburn your box.
    Hello. Would you please provide more details on how you accomplished this? What ROM version, the filename(s) and path(s)? SD Maid didn't provide Alice UX or any files matching "com.oranth.tvlauncher" as removable options. I had set alternate launchers to default and removed all files with names containing "com.oranth.tvlauncher" from the root file system, but the box would still boot up with Alice UX. Perhaps the stock launcher info is hard-coded into the kernel and/or bootloader?

    Leave a comment:


  • Rccm1112
    replied
    You can defeat the activation banner by overwriting the systemui.apk on your TX6 with the systemui.apk from a Pendoo X6. I tried it with the TX6 07-22-2019 Android 9 firmware on a different box and the banner disappeared after rebooting.

    Leave a comment:


  • sangramd21
    replied
    Originally posted by sangramd21 View Post
    Wifi & Bluetooth not working. Please help.

    Whenever I try to turn on bluetooh on my TX6 a error keeps on popping "Bluetooth keeps stopping".

    So i tried turning wifi on to see if atleast wifi is working but whenever I try attempting to turn the wifi on in settings the switch remains “greyed out” instead of switching to blue in colour to reflect it is on. I have spent hours trying to remedy this online, and whilst there have been no specific solutions for TX6 device, I have attempted several solutions that I’ve found online for android devices in general but none of these have worked.

    Using my TX6 on ethernet cable now. Please if someone can help.
    Anyone has a solution for this? Bluetooth & wifi not working.

    Leave a comment:


  • sangramd21
    replied
    Originally posted by palpunjabi View Post
    I am already on this firmware. Could someone please help me with the issue.

    Leave a comment:


  • palpunjabi
    replied
    https://us16.mailchimp.com/mctx/clic...pool=&subject=

    Try this firmware
    Last edited by palpunjabi; 01-18-2020, 11:47.

    Leave a comment:


  • sangramd21
    replied
    Originally posted by palpunjabi View Post

    Check on the bootom but TX6 you have is than TX6-A or just tx 6 ?
    It's TX6

    Leave a comment:


  • palpunjabi
    replied
    Originally posted by sangramd21 View Post
    Wifi & Bluetooth not working. Please help.

    Whenever I try to turn on bluetooh on my TX6 a error keeps on popping "Bluetooth keeps stopping".

    So i tried turning wifi on to see if atleast wifi is working but whenever I try attempting to turn the wifi on in settings the switch remains “greyed out” instead of switching to blue in colour to reflect it is on. I have spent hours trying to remedy this online, and whilst there have been no specific solutions for TX6 device, I have attempted several solutions that I’ve found online for android devices in general but none of these have worked.

    Using my TX6 on ethernet cable now. Please if someone can help.
    Check on the bootom but TX6 you have is than TX6-A or just tx 6 ?

    Leave a comment:


  • sangramd21
    replied
    Wifi & Bluetooth not working. Please help.

    Whenever I try to turn on bluetooh on my TX6 a error keeps on popping "Bluetooth keeps stopping".

    So i tried turning wifi on to see if atleast wifi is working but whenever I try attempting to turn the wifi on in settings the switch remains “greyed out” instead of switching to blue in colour to reflect it is on. I have spent hours trying to remedy this online, and whilst there have been no specific solutions for TX6 device, I have attempted several solutions that I’ve found online for android devices in general but none of these have worked.

    Using my TX6 on ethernet cable now. Please if someone can help.

    Leave a comment:


  • palpunjabi
    replied
    How can I get TX6-A firmware ? it has XR819 wifi chip ?

    Leave a comment:


  • tbfa
    replied
    Hi,there. Is there a way to change boot logo ?( Not bootanimation) . I would like change Tanix/Pendoo to Tx6.

    For those want uninstal AliceUx, with no popup asking for settings every Reboot , you just remove first Alice Ux, then, TV settings.apk (not settings.apk), ATV launcher is a good launcher.


    Thanks.
    Last edited by tbfa; 01-11-2020, 11:33.

    Leave a comment:


  • Avax
    replied
    Originally posted by Kotalke View Post
    ... The best shot was Eachlink-H6-Mini-20181122_V2 firmware. This firmware was able to downmix 5.1 sound to stereo, because it has its own built-in audio decoder. ....
    ... Have you thought about trying with S/PDIF?
    Hi Kotalke,
    My idea is to let my Receiver do the decoding for DTS or AC3 rather than having TX6 to do the decoding. As I believe Receiver should do this job better than TX6. So that firmware which does the downmix just doesn't do the job. TX6 just focus on the picture of the movies.
    I did think of S/PDIF, but I can't get the S/PDIF port to work too... my receiver just doesn't detect any data from the port. In fact, I still don't know if it is an optical or coaxial S/PDIF.... Also reading back the earlier pages, some fellow owners here also having the issue that S/PDIF is not working. so I kind of give it up for now.
    Thank you for the advice. Hoping to hear more ideas.

    Leave a comment:


  • Kotalke
    replied
    Originally posted by Avax View Post
    I really would like to have this fixed as I wanted to watch my BD ripped movies on this TX6.
    Hence I wonder if anyone here had tried Audio pass-thru and it works flawlessly for TX6 box?
    My firmware has the Build info as p281-userdebug 9 PPR1.181005.003 20190722-184353 test-keys
    Is this the correct and latest firmware? If I do any firmware update, will it wipe all my installed programs? As my unit seems to have lots of pre-installed applications, I don't want to lose them.
    Looking forward for any advice.
    Hi Avax,

    I must admit that I have tried with 10 or more different firmwares already on my Tanix TX6 4/32 in order to check how the AC3 and DTS work. The best shot was Eachlink-H6-Mini-20181122_V2 firmware. This firmware was able to downmix 5.1 sound to stereo, becasue it has its own built in audio decoder. Maybe it would be the best firmware for you too? Unfortunately, on this firmware the front display (boot and clock) on the box doesn't work at all (v2) or displayed ceaselessly "boot" (v1). It's also android 7, not 9.
    Have you thought about trying with S/PDIF? I don't have any AV receiver to check whether it works or not with your audio settings.

    The only speakers I have are the ones installed in my Samsung TV. And I use only HDMI cable.

    Originally posted by RiCkLaR_atvX View Post
    Avax hello and welcome to the FreakTab forum.

    I have purchased the new Tanix TX6S and hope to see if it will work properly with the Vizio surround sound when I get it in a couple of days.

    Cheers.
    RiCkLaR_atvX,

    I look forward for your opinion about the new Tanix TX6S model.
    Will you investigate if it plays AC3 and movies with 5.1 correctly in stock android app like TvdVideo via HDMI?

    Thanks in advance!

    Leave a comment:


  • Avax
    replied
    Originally posted by RiCkLaR_atvX View Post
    Avax hello and welcome to the FreakTab forum.

    So, my TX6 worked for surround sound and Audio-Pass-through with Kodi, VLC, and MXplayerPRO; this is how 1) connected hdmi to Samsung TV for decoding - 2) used SPDIF from TV to old Sony Surround sound system.
    Hi RiCkLaR_atv,
    Glad to hear your experience.
    I am guessing that the 2 TV that I had must be outdated, it will always down sample the audio and output to spdif in stereo. Hence i will never get surround from TV to Receiver.
    I can never get the VLC to play in surround or audio pass thru, don't know what setting I had missed.
    i really hope the TX6 can work. Or if anyone got any model to recommend that fall into TX6 price range and work well decoding BD rip with 4K and surround pass thru, I seriously will consider.
    Again, Thank you for reading and suggesting.

    Leave a comment:

Working...
X