Announcement

Collapse
No announcement yet.

Firmware U2C Z-Super Amlogic S912 3GbRAM 32ROM - HELP can not FIND

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Firmware U2C Z-Super Amlogic S912 3GbRAM 32ROM - HELP can not FIND

    Hello i have u2c z-Super android tv box and after update SuperSu box stock in logo.

    Im looking how to Unbrick that box firmware is : NHG47L/20170904

    Im not sure if i can install older firmware PLS if somebody know to help

    Thank you !

    #2
    See:
    https://www.amazon.co.uk/gp/product/...?ie=UTF8&psc=1
    Under need by the customer replys...there is there email adress ( there support seems decent )

    The name NHG47L is used by many devices/Fw...and the s912 has many different ram versions / revision... ect
    So, your best bet is customer service

    Goodluck

    Comment


      #3
      Originally posted by galleria1313 View Post
      Hello i have u2c z-Super android tv box and after update SuperSu box stock in logo.

      Im looking how to Unbrick that box firmware is : NHG47L/20170904

      Im not sure if i can install older firmware PLS if somebody know to help

      Thank you !
      Hi ,

      first you got into the latest SuperSu Bug of the last Month , other Users had similar Problems ,

      of course u can install a older FW , but you must do it with PC .

      Maybe you can use one of the CustomRoms from here , but for this we need more Infos over

      your Box .Example : Wifichip

      hope it helps / greetings / gefattern

      Comment


        #4
        I have the same problem and I'd like to be helped. Haven't got any firmware so far to unbrick it.
        This is what I have of specs.

        * CPU Amlogic S912
        * RAM 3G
        * ROM 32 Gb FairChild, THGBMFG8C4LBAIR (1X)
        * Ethernet 1 Gbit Realtek, RLT8211F

        Thanks

        Comment


          #5
          I have the same problem after installing SuperSU from GooglePlay, my U2C Z SUPER TV BOX is stuck on boot-up at the "MBOX" logo-screen.
          I tried resetting it to factory setting but it did not solve the problem.
          Been searching all over the net for the original stock firmware flash-file (or maybe an updated firmware flash-file) but with no luck.
          -Without the original stock firmware flash-file (or maybe an updated firmware flash-file), my U2C Z SUPER TV BOX is useless.

          So if ANYONE could please help me (and many others) either by posting a link where to download the U2C Z SUPER TV BOX stock firmware flash-file.. Or be so kind to make a flash-copy of the original stock firmware from their own U2C Z SUPER TV BOX and post a link to it or mail it to me: [email protected]<a href="https://www.youtube.c...otmail.com</a>, I will be very greatful. -In fact any help in this matter is highly appreciated., thx.

          Comment


            #6
            I am also finding myself in exactly the same situation after installing SuperSU. Anway, there is mention elsewhere of trying other firmware variations, such as the Vorke z6 firmware. But when I downloaded and tried to flash that, it just refused and gave some kind of Footer error or something like that. Someone else mentioned that they had asked U2C via Amazon, and they had given them the firmware. But the amazon link is now dead and I can't seem to find any homepage etc or info on the company.

            Plus I am not at all knowledgeable about android firmware etc and have practically given up with all the mass of very bewildering info on the subject. So if someone could please find the correct firmware from somewhere, then that would be fantastic and very much appreciated indeed.

            Comment


              #7
              I managed to find the original u2c sellers on Amazon and sent them an email late in the day yesterday . And they had already promptly replied when i checked this morning. They gave me a download link to the correct and proper firmware. And voila, a short while later my Z-Super is now up and running completely fine again. Here is the download (q9377-Z-Super-ota-20171129.zip) link: https://drive.google.com/open?id=160...iySp29Px0FE9MJ

              Hope this is helpful to others who have like me, found themselves floundering around and panicking, thinking that they would likely have to abandon or throw away their bricked Z-Super.

              Comment


                #8
                Hello doodeezipzah.

                do you have the email address of the u2c sellers please?

                I have a z-turbo which is 3gb ram and 16gb rom with s912 processor. I haven't been able to find firmware anywhere.

                Many thanks
                Andy

                Comment


                  #9
                  Sorry...not trying to hijack this thread, but I have a very similiar problem.

                  I have a U2C X Super with 3 gb RAM and 32 GB ROM. Yes....I installed SuperSU from Google playstore and have the same problems....I only have a dim blue light on the panel, cannot get into recovery mode and is not recognized by USB burn tool. I'm going to try the Bootcard maker program with micro SD, but still need the original firmware. Does anyone know if the U2C Z Super firmware is compatible with the U2C X Super that I have? My original firmware build is NHG47L.20171123 test-keys


                  Thanks in advance

                  Comment


                    #10
                    Hi guys. You can use the link below to contact the seller on Amazon. But i think you have to be a member of Amazon to actually contact them. Because it only really allows you - at least initially - to contact them through Amazons own contact form.
                    https://www.amazon.com/U2C-Control-C...rds=u2c+remote

                    Just explain to them about what happened when you downloaded SuperSU from Google Play Store, and that you need the firmware to get it working again. And hopefully you could have a reply within a day even. Best of luck, guys.

                    PS. If you could just also remember to take a few moments to come back here and post the link on the forum if you get it, i'm sure there will be others who would massively appreciate it.

                    Comment


                      #11
                      Thanks for the link. I already contacted U2C thru Amazon Ca and have a reply. They sent me the zip files to use the upgrade option assuming that you can either use the backup/upgrade in the setup or enter the recovery mode and link to the files from there. I can't do either. I have a grey screen when I power on...that's it. I did manage to get my computer to recognize the box in the USB burning tool. I had to short nand pins 17 & 18 on the Samsung chip, then voila.
                      I have attached the link to the firmware website for anyone that needs it. I have also requested the img file I need so hopefully I can revive this box with USB burn tool.
                      Keep you posted....

                      https://drive.google.com/open?id=1W6...2eLXCQuYkLoVWk zip file


                      https://drive.google.com/file/d/1F4u...p1WxJbDAK/view img file

                      Note to Admins: Pls post firmware in appropriate place..thks

                      U2C X Super Android 7.1 TV Box
                      U2C Android TV BOX 3gb Ram Hardware specification:
                      CPU:Amlogic S912 Octa core ARM Cortex-A53 [email protected]
                      GPU:ARM Mali-T820MP3 GPU up to 750MHz
                      RAM:3G DDRIII
                      ROM:32G eMMC
                      DC In: DC 5V/2A
                      USB Host:3 High speed USB 2.0 port and 1 OTG port,support U disk and USB HDD
                      TF Card Reader:Maximum Support: 128G(Micro SD Card)
                      Lan:1000M Gigabit RJ-45
                      Wifi:802.11 b/g/ AC(2.4G+5G)
                      BT:BT 4.1
                      AV In:AV(3 in 1) port
                      SPDIF:Optical SPDIF interface
                      Power Indicator:Power On/Off:Blue/Red
                      LED Display:White light digital display,Show time and device connecting information(Wifi/BT/Lan/AV/HD/SPDIF)

                      Software information:
                      O.S.:Android 7.1
                      Decoder Formats:4K, H.265, MPEG1/2/4, H.264, HD AVC/VC-1, RM/RMVB, Xvid/DivX3/4/5/6, Real Video 8/9/10
                      Video Formats:[email protected], H.265, AVI, H.264, VC-1, MPEG-2, MPEG-4, DIVD/DIVX, Real8/9/10, RM,RMVB, PMP, FLV, MP4, M4V, VOB, WMV, 3GP, MKV
                      Music Format:MP1, MP2, MP3, WMA, OGG, AAC, M4A, FLAC, APE, AMR, RA, WAV
                      Photo Format:JPEG/BMP/GIF/PNG/TIFF
                      DLNA: DLNA files sharing
                      Languages:English/French/German/Spanish/Italian etc. 24 languages
                      App Functions:Google play store,Amazon alexa,Netflix,Youtube,Facebook,Twitter,Online movies,etc.
                      Mouse/ Keyboard:Support mouse and keyboard via USB;Support 2.4GHz wireless mouse and keyboard via 2.4GHz USB dongle
                      Other feature:Free Internet searching,many kinds of games,etc.
                      Last edited by mcdave; 03-31-2018, 15:24.

                      Comment


                        #12

                        Comment


                          #13
                          mcdave, thanks very much for sharing with us this information. I got other ROM that worked pretty much the same but not all of the remote control buttons where assigned to the same function they were intended to.
                          I don't know if someone else tried to download the two files you shared but the second one is incorrectly linked, it download the same file as the first one, the associated text is fine.

                          Something else, you could ask your vendor to share the link where he can upload upgrades to the box so we are always up to date. This one is a life saver thou.

                          Thanks again for sharing!!

                          One more thing, the firmware is rooted too, I installed supersu and is working fine but don't update the binary!!!! It will brick again. I don't know who needs to patch this issue, the supersu developers or the tv box manufacturer.

                          Comment


                            #14
                            emesma I just took the vendor link from Amazon and sent them an email. They were very responsive and eager to help. As far as upgrades go, I'm sure that any would be made available via OTA

                            I believe I have fixed the img link above.
                            I'm not sure how long these files will stay at these links...so get them now.
                            Last edited by mcdave; 03-31-2018, 15:27.

                            Comment


                              #15
                              i didnt have chance to thank you i did fix some how with different soft and no freezes works perfect up to today.
                              Now im looking best tv box for my sister in UK but i want to have support at least if something happen. i was looking :
                              Beelink GT1 Ultimate 3GB looks same as u2C but better performance and little bit cheaper.
                              What you will suggest?
                              Last edited by galleria1313; 12-02-2018, 21:30.

                              Comment

                              Working...
                              X