Unconfigured Ad Widget

Collapse

Announcement

Collapse
No announcement yet.

Help! Pipo x9s Windows 10 drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help! Pipo x9s Windows 10 drivers

    Took delivery of a Pipo X9s yesterday but the windows 10 installation was corrupt. Tried recovery but it didn't work. It was constantly blue screening! Installed a fresh copy of Windows 10, but it has no driver's! Can someone please help as the place where I bought it from don't seem to want to help! Also tried downloading the software from pipo but the download keeps failing and I don't know how to install it either!!!

    Any help would be gratefully accepted!!!

    #2
    You can download a new firmware from http://www.pipo.cn/En/index.php?m=Ab...an_show&id=284 This is a 5.8GB big and you need to copy into an 8GB USB drive formatted using NTFS and with label WINPE. I have done a reinstallation on X9S and this firmware will do a fresh installation, only problem will be the audio. If you need help on the audio part, I could repack the audio driver.

    BTW, when you're done with reinstallation, can you let me know if you've any problem with the USB ports? I couldn't get it to work properly, if I connected a mouse or keyboard, after few minutes I turned it on, the mouse or keyboard will not work and the USB device not recognised error coming up on the screen.

    Update: Found where I downloaded the driver, https://docs.google.com/uc?id=0B4EXB...xport=download and use driverdump utility to install the missing drivers. This is for x64, I've no idea if this work for x86.
    Last edited by wiraone; 05-02-2016, 03:21. Reason: Link to download the missing drivers on Win10 x64.

    Comment


      #3
      Hi, thanks for the link, but I've tried to download from that link already and it always fails, baidu doesn't like me! I also tried the links from geekbuying blog but when I try to extract them it says they are corrupt! Not sure what to do now..
      Don't want to return the item really, wanted to use it as a media server, bought a DAC and headphone amp to go with it too. I think the hardware of the X9S is good, it's the software implementation that's bad!

      Comment


        #4
        As well as the link you provided, i tried this one - http://blog.geekbuying.com/index.php...ware-20160414/

        I could actually download these, but they seem to be corrupt.

        As far as the USB thing goes, did you go into the USB settings and untick the 'Allow windows to switch this off' setting!?

        Comment


          #5
          I had the same problem with baidu, managed to download the files at certain time of the day when probably less traffic going to baidu. If you've re-installed the standard win10 distribution, just download the drivers as per my above link (2nd link, it is for obook 11 but it works for me).

          Comment


            #6
            Just installed the OBOOK drivers and it's done all but 4. They are all Unknown devices!!! The audio works now, but the touchscreen still doesn't!

            p.s. I 'updated' the drivers individually. Not sure what you mean by driverdump utility...?
            Last edited by nelson996; 05-02-2016, 05:42.

            Comment


              #7
              I'm sorry, it was double driver (http://www.majorgeeks.com/files/deta...le_driver.html) app.

              On the USB problem, I've tried all the recommended settings found on the net but still have a problem with any USB devices connected to the USB2 ports. I've actually packed back the X9S into the box and I've no idea what I'm going to do with it now. My intention of buying it is to be a gateway for my ham radio stuff (which uses USB) and now since I couldn't get it to work, probably will sell it off but I'll feel bad if the buyer couldn't get the USB working either.

              BTW, I'll see if I can find the touchscreen driver(s) using the double driver, if yes, I'll upload it into dropbox and share it here.

              Comment


                #8
                Alright, here is the drivers dump (selected the non-intel, non-microsoft drivers):

                https://drive.google.com/open?id=0B_...FRHcGI2TWZUMUk

                It has kionik sensors driver, Goodix Touch driver (I guess this is for the touch screen), audio driver and network drivers (wired and wireless).

                Hope the above will helps you to get everything sorted. Good luck.
                Last edited by wiraone; 05-02-2016, 15:55. Reason: correct google drive link

                Comment


                  #9
                  I re-installed a fresh Win10 downloaded from Microsoft server just now. It seems the USB works without any problem .. not until I restore all the drivers originally dumped using the double driver app. I'm going to do another fresh install and will not load the drivers from pipo and see how it goes.

                  Comment


                    #10
                    Thank you. Will try it all when I get home! If you can get it all to work, what about Windows 10 activation???!!!

                    Comment


                      #11
                      Hi wiraone, just to let you know, the drivers worked!!! everything functioning as I need so far. Got foobar going with my Lenovo android mobile controlling it! Only issue now is getting an activation code. Do I need to install the multilingual version of windows to get a working code? Tried to contact the seller but heard nothing from them for about 5 days so far (there's a surprise!).

                      If all else fails may have to try Linux...

                      Either way, thank you very much for your help! It's very much appreciated!!! You're a star!!

                      Will post anymore findings or troubles I have here...

                      Comment


                        #12
                        ...looks like Linux isn't as straight forward to install as I'd hoped!!! Any luck with activation for Windows 10?

                        Comment


                          #13
                          When I did a fresh install on mine, it is already pre-activated with Windows 10 home. I will PM you the activation code that is in the firmware when I get back home (I'm on GMT+8).

                          Comment


                            #14
                            Don't worry! I just installed the multi-language version of Windows 10 and it has activated!!! Thanks again for all your help!! Only issue I’m finding is the touchscreen can be a little temperamental, only works when it wants!!!

                            So the next project... get it dual booting with Linux!!! :-)

                            Comment


                              #15
                              Great to hear that and good luck with the Linux installation.

                              Comment

                              Working...
                              X