Announcement

Collapse
No announcement yet.

MXQ Pro 4k Bricked!! What pins to short for NAND.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MXQ Pro 4k Bricked!! What pins to short for NAND.

    I need to correctly identify what pins on this specific board\NAND chip to short. I have seen other pics of nand chips but can not locate any that identifies the pins for this chip.

    See Pic for reference.

    After screwing with this box for a week it looks as though i may have to short out the nand pins to reinstall firmware unless someone knows another way of getting it starting again.

    Hostory of problem.
    Box was given to me as not working. Orginally the MBOX logo would come on screen but that doesnt even come up now. Just a black screen. After reading alot and trying different methods I came across a post that says there are known issues with reset button on some manufacturers of these boards. I am hoping that is my issue.
    SD card method does nothing
    USB method gets a Erase bootloader/Lowper/Identify/Error result" within seconds of starting.

    If anyone has other ideas or options please feel free to suggest them. Specific instructions for any other workaround is apprerciated.

    BOX details:
    Sold as a 2017 Model GooBang Doo Android 6.0 TV Box, MXQ Pro Android TV Box 64 Bits Amlogic S905X
    Only identification written on PC board is MXQ_S95X V2_0 and 20161020
    The NAND is stamped as:
    Sandisk C423105451
    SDTNRGAMA-008G
    WAE52501SA
    CHINA

    Seller sent me files named
    aml_sdc_burn.ini
    aml_upgrade_package.img
    u-boot.bin.sd.bin
    and instructions on doing the usb update method. I tried the usb and SD card method but nothing happened only error message as above. not sure if these files were for an upgrade or the correct ones for getting box started again.

    Thanks for any assistance.



  • Dabolx
    replied
    I know this thread is old but I faced the same problem and I have found out how to resolve it. Maybe it is still going to help someone.

    Here is how you can recover MXQ_S905X V2_0 20161020. You will need to use aml usb burning tool.

    1. Download rom from here
    2. Short nand pins between 8 and 9
    3. Connect tv box to pc and it should show up on aml usb burning tool
    4. Flash firmware

    Leave a comment:


  • digitalriver
    replied
    In USB Burning Tool I have error on 2%, or 4%. Shorting 29-30 pins dont help, reset key dont work, and box after connecting to pc immediately enable loader mode without need to pressing or shorting something.This happened after the trying firmware 7 Android If I understand, wrong firmware changes in my bootloader frequency of memory, and now box not start with this very high frequency

    Leave a comment:


  • digitalriver
    replied
    Hello All!
    People, can somebody help me. I have similar problem
    My box is t95n s905x. In console i see this:
    BL2 Built : 13:48:56, Sep 23 2016.
    gxl g7459bd4 - jianxin.pan@droid06

    set vcck to 1120 mv
    set vddee to 1000 mv
    Board ID = 1
    CPU clk: 1200MHz
    DQS-corr enabled
    DDR scramble enabled
    DDR3 chl: Rank0+1 @ 528MHz - PASS
    GXL:BL1:9ac50e:a1974b;FEAT:ADFC318C;POC:3;RCY:0;EM MC:0;READ:0;CHK:AA;SD:0;READ:0;0.0;CHK:0;
    no sdio debug board detected
    TE: 228553


    I see this message, when i trying to do something from micro sd port. Works only micro usb port, usb ports box don't see. When I trying to start box without microsd, in console I always see this:
    GXL:BL1:9ac50e:a1974b;FEAT:ADFC318C;POC:3;RCY:0;EM MC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP:1;EMMC:0;READ :0;CHK:AA;SD:800;USB:8;LOOP:2;EMMC:0;READ:0;CHK:AA ;SD:800;USB:8;LOOP:3;EMMC:0;READ:0;CHK:AA;SD:800;U SB:8;LOOP:4;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP :5;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP:6;EMMC:0 ;READ:0;CHK:AA;SD:800;USB:8;LOOP:7;EMMC:0;READ:0;C HK:AA;SD:800;USB:8;LOOP:8;EMMC:0;READ:0;CHK:AA;SD: 800;USB:8;LOOP:9;EMMC:0;READ:0;CHK:AA;SD:800;USB:8 ;LOOP:A;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP:B;E MMC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP:C;EMMC:0;REA D:0;CHK:AA;SD:800;USB:8;LOOP;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP:E;EMMC:0;R EAD:0;CHK:AA;SD:800;USB:8;LOOP:F;EMMC:0;READ:0;CHK :AA;SD:800;USB:8;LOOP:10;EMMC:0;READ:0;CHK:AA;SD:8 00;USB:8;LOOP:11;EMMC:0;READ:0;CHK:AA;SD:800;USB:8 ;LOOP:12;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP:13 ;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP:14;EMMC:0; READ:0;CHK:AA;SD:800;USB:8;LOOP:15;EMMC:0;READ:0;C HK:AA;SD:800;USB:8;LOOP:16;EMMC:0;READ:0;CHK:AA;SD :800;USB:8;LOOP:17;EMMC:0;READ:0;CHK:AA;SD:800;USB :8;LOOP:18;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP: 19;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;LOOP:1A;EMMC: 0;READ:0;CHK:AA;SD:800;USB:8;LOOP:1B;EMMC:0;READ:0 ;CHK:AA;SD:800;USB:8;LOOP:1C;EMMC:0;READ:0;CHK:AA; SD:800;USB:8;LOOP:1D;EMMC:0;READ:0;CHK:AA;SD:800;U SB:8;L

    Leave a comment:


  • scooter2014
    replied
    Youll find your not alone re OCD

    http://freaktab.com/forum/main-categ...short-location

    Most comon locations there if you do find it post it for others following as i am sure you wont be last one looking for its location.



    Keep at it youll get it.

    Leave a comment:


  • Labrador
    replied
    Thanks scooter

    Still the same
    Starts, goes to 4% stays on saying "download Uboot" for 3 or so seconds then this error :12:08:33 085][HUB3-1][Err]--[0x10302001]Romcode/Switch status/Check connect/Enum device error

    I have tried leaving nand short on while loading, taking it off when load starts, holding reset button on while loading , letting it go when it starts.

    Also can u confirm that the pins i am shorting are correct. My chip has three large circles and one small one on the top. I assume i start counting pins from the small circle corner

    This BOX is not going to BEAT me!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    LOL

    Thanks for your insight....You give me a shimmer of light at end of tunnel

    D

    Leave a comment:


  • scooter2014
    replied
    V88 firmware will work on it xany firmware should as well as the x96 firmware all those work with that wifi.

    http://freaktab.com/forum/tv-player-...ith-remote-fix

    Leave a comment:


  • scooter2014
    replied
    I post link to firmware i know work on your wifi but have to load it when home.

    Leave a comment:


  • Labrador
    replied
    Update
    I am able to get the load process started for about 4 %. then it stops with the following.
    On burn tool top screen where it shows usb it says Download Boot
    Then i get error on bottom part of program that says
    [0x10302001]Romcode/Switch status/Check connect/Enum device error.

    Then everything stops.
    I tried a few different firmware files.

    Hope this gives some insight.
    Last edited by Labrador; 04-18-2017, 16:32.

    Leave a comment:


  • Labrador
    replied
    see attached photo.

    id on it says
    8189ETV
    G816G32
    GG37

    Leave a comment:


  • scooter2014
    replied
    Here ya re ocd. try 7/8 from dot. Take photo of wifi chip too.

    Leave a comment:


  • Labrador
    replied
    See pics below. Let me know if you need any other info. Thanks for help. My OCD wont let me quit on this box.....LOL

    Leave a comment:


  • scooter2014
    replied
    No one has device so you may have to crack open and take photos. Some come with wierd nan and memory even different chips for storage on same device.

    If resetting and flashing firmware on tool not working now its dr detective to find out why other firmware not working. I cant remember if i ordered one of amazon or not but if i did its still a few weeks out from shipping snail mail...

    Id say get supported devices but even that becoming crap shoot as they changing gutz as soon as stable roms made lol.... China gadget life

    Leave a comment:


  • Labrador
    replied
    I I found some info where someone else had to short the pins on same chip but different board. I tried it on mine. Got a little further on install (4%). then i got this error
    0x10302001]Romcode/Switch status/Check connect/Enum device error
    any ideas?
    Thanks

    Leave a comment:


  • Labrador
    replied
    tried that still no luck. I noticed by accident that i can do exactly the same thing via loading through burn tool whether the reset button is pressed and held pressed or released. It is as though the reset button is not doing anything. I would of thought if button is pressed the program would not be able to start the load process. I have included the last part of the text file from latest load failure The only time i get a different result than the one reported above is if i start the load program then plug in USB. hope that may shed some light on problem

    thanks

    [17:15:02 730][HUB3-1][Inf]--------------ERASE BOOTLOADER------------
    [17:15:02 755][HUB3-1][Inf]--2-2-0-0
    [17:15:02 772][HUB3-1][Inf]-------------Download DDR.USB-----------
    [17:15:02 772][HUB3-1][Inf]--Close device handle 0x0000081c
    [17:15:02 823][HUB3-1][Inf]--Open device handle \\?\usb#vid_1b8e&pid_c003#5&77e775c&0&1#{a5dcbf10-6530-11d2-901f-00c04fb951ed} 0x0000081c
    [17:15:02 874][HUB3-1][Inf]--2-2-0-0
    [17:15:02 875][HUB3-1][Inf]--Control write pll reg1 0xd9000000:0x000000b1
    [17:15:03 377][HUB3-1][Inf]--Control write pll reg1 0xd9000000:0x00005183
    [17:15:03 879][HUB3-1][Inf]--Write initial succeed
    [17:15:03 879][HUB3-1][Inf]--Upload encrypt at 0xc8100228
    [17:15:03 880][HUB3-1][Inf]--ulValue = 0xadfc318c
    [17:15:03 881][HUB3-1][Inf]--Read encrypt value succeed
    [17:15:03 897][HUB3-1][Inf]--Transfer complete
    [17:15:03 899][HUB3-1][Inf]--Run at address 0xd9000000
    [17:15:03 901][HUB3-1][Inf]--RunInRam succeed
    [17:15:03 924][HUB3-1][Inf]--2-2-0-0
    [17:15:03 924][HUB3-1][Inf]--CheckFileRunState succeed
    [17:15:03 925][HUB3-1][Inf]--runResult:0x 0,paraMagic:0x7856efab
    [17:15:03 925][HUB3-1][Inf]--ddrCapacity:0x 800
    [17:15:03 926][HUB3-1][Inf]-------------Download UBOOT.USB-----------
    [17:15:03 928][HUB3-1][Inf]--2-2-0-0
    [17:15:03 928][HUB3-1][Inf]--ulValue = 0xadfc318c
    [17:15:03 928][HUB3-1][Inf]--Download DDR.USB buffer at 0xd9000000
    [17:15:03 943][HUB3-1][Inf]--Transfer complete
    [17:15:03 943][HUB3-1][Inf]--Download UBOOT.USB buffer at 0x0200c000
    [17:15:04 242][HUB3-1][Inf]--Transfer complete
    [17:15:04 250][HUB3-1][Inf]--DownCheckPara succeed
    [17:15:04 250][HUB3-1][Inf]--Run at address 0xd9000000
    [17:15:04 292][HUB3-1][Err]--generatedAddSum:0x8abfae59;srcAddSum:0x17b94557;ru nResult:0x e6;paraMagic:0x7856efab
    [17:15:04 292][HUB3-1][Inf]--ReadCheckPara failed
    [17:15:04 408][HUB3-1][Err]--[0x110f0902]Unknown
    [17:15:04 410][HUB3-1][Inf]--Close device handle 0x0000081c

    Leave a comment:

Working...
X