Announcement

Collapse
No announcement yet.

[ROM][BETA] Custom Mod Rom for MXQ Pro 4K based on XannyTech Custom Mod Rom

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [ROM][BETA] Custom Mod Rom for MXQ Pro 4K based on XannyTech Custom Mod Rom

    After some testing i'm comfortable enough to share this beta build, here is a new modded rom for the MXQ Pro 4K Board S905XQ_V1.0 it's based on XannyTech rom,
    Be aware that this board is newer and I didn't test it with the older "MXQ Pro 4K" as I don't own that device. Using this rom is at your own risk!

    Device information:

    https://docs.google.com/document/d/1...it?usp=sharing

    Based on the latest 2016-11-01 P212 firmware 1GB Ram/8GB Rom.








    Features:

    - Restores the android notification bar
    - DeBloated
    - Xposed Framework prebuilt in and activated
    - Init.d support built-in
    - SuperSu
    - SquareHome2 Launcher highly customizable
    - Supports floating windows by using the
    XHFW3 xposed module.


    Preinstalled apps:

    - ADAway
    - Chrome
    - SPMC
    - Netflix
    - MxPlayer
    - Total Commander + 3 useful plugins
    - YouTube
    - Terminal Emulator
    - BootManager
    - XposedInstaller 3.11


    Bugfixes:

    Enabling CEC changes language at boot.

    Known issues:

    - no TWRP, this board does not support any TWRP s905x version out there, I need help with this one.

    You tell me!


    Latest version download:

    https://drive.google.com/drive/folde...0dpelNjZ0didU0

    Installation notes:

    To install my rom you need to use Amlogic USB burning tool 2.0.8 there is no flash-able zip version yet as this rom has no TWRP build-in yet...

    - After first boot update the su binary by opening the Supersu app, use the normal installation method.



    Enjoy!
    Last edited by Toetje583; 06-12-2017, 08:21.

    #2
    I've tested it.

    I installed KODI 16 and when I tried to run it shows green screen.

    KODI 17 works
    Last edited by yaro8558; 01-21-2017, 05:09.

    Comment


      #3
      Originally posted by yaro8558 View Post
      I've tested it.

      I installed KODI 16 and when I tried to run it shows green screen.

      KODI 17 works
      I diden't test Kodi 16, did you mean playing a videofile? This is mosly a videocodec issue.
      If you have any more questions let me know!

      Best Regards,

      Toetje

      Comment


        #4
        Have a S905XQ_V1.0 board , gotta get a USB cable going as well as my old laptop, been out of the modding/programming scene for years after starting back in the Ma-Bell days (telling my age here).
        bought this box on a whim , and now have a device that is not a necessity to play with and pre built toys to work with.
        looks like I might be making a small comeback not sure how far I will make it , but might pursue a related degree once I get back into school.

        Any one who has any links the cover the basics of modding /backup and flashing Android devices written for tech geeks. I would appreciate it.

        I have found plenty info but mostly just step by step instructions that doesn't really cover anything about how why or give info that can be applied across many devices .

        thanks


        UPDATE:
        ok so i built my cable, tested it (via Multimeter) , the device powers on by the cable to recovery mode, thing is it is not detected at all not in Burning tool or computer with sound notification.
        not sure where to go from here, i did order a factory cable cant imagine that is the problem.

        update II
        factory male A to Male A cable arrived still no connectivity.

        Would short resetting the NAND likely fix USB connectivity or is it more likely a hardware error?
        Last edited by deebee123; 02-04-2017, 19:20.

        Comment


          #5
          Hello,

          I've got a problem with my wifi. It loss connection every 10-30 minutes. I bought usb wifi card and i tried to use it but it has realtek 8192SU chipset and there is no module for this card.
          Can You add that module to your software ?

          thanks
          Last edited by yaro8558; 02-06-2017, 09:51.

          Comment


            #6
            Originally posted by yaro8558 View Post
            Hello,

            I've got a problem with my wifi. It loss connection every 10-30 minutes. I bought usb wifi card and i tried to use it but it has realtek 8192cu chipset and there is no module for this card.
            Can You add that module to your software ?

            thanks
            You should trouble shoot connection issue. Seen before try higher or less used channel on router to stop the disconnects. Adding mod not needed you need to find the issue. If wifi really bad concider wifi mod to make better.
            Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

            Comment


              #7
              There is only one network (mine) around me and I tried almost all channels. Other devicess don't have issues with wifi connection.

              My MXQ Pro 4K has RTL8189es buil-in network card, i bought another one to do the test, but it has RTL8192SU chipset and there is no module in this software, so I can't use it.

              Comment


                #8
                Originally posted by yaro8558 View Post
                Hello,

                I've got a problem with my wifi. It loss connection every 10-30 minutes. I bought usb wifi card and i tried to use it but it has realtek 8192SU chipset and there is no module for this card.
                Can You add that module to your software ?

                thanks
                I suggest to solder an antenna on the current wifi chip, it's really easy. Just drill a hole in the back/side and connect the wires to the antenna
                Last edited by Toetje583; 02-07-2017, 06:22.

                Comment


                  #9
                  Yes, I ve done it. That changed  Nothing.

                  Comment


                    #10
                    Originally posted by yaro8558 View Post
                    Yes, I ve done it. That changed Â*Nothing.
                    To be honnest, I will test the WIFI on my end first, maybe it's just a firmware issue!

                    Comment


                      #11
                      Just found out My NAND is a refurb as denoted by the two Rows of letters RM repeating over top of the manufacturer "SanDisk"

                      I have almost the full 8 gig so there are probably only a few bad blocks that were formatted out.

                      This may explain why my box is blocked from any raw flashing,

                      I am gonna bet that if I short the pins to get into mask mode and flash a rom , there are no provisions to skip any bad blocks.
                      .
                      Looks like I will either have to buy a fully functional NAND or leave this device as is.
                      if anyone finds that the aml usbt has the ability to handle bad blocks let me know.

                      I got a feeling that alot of people with inexpensive devices containing ReMan nands have tried to flash over these ReMan chips and ended up with updates failing at a certain percent or completing but then having errors in various files.

                      Last edited by deebee123; 02-09-2017, 06:09.

                      Comment


                        #12
                        Thanks for this Rom, the first one for the MXQ Pro 4K S905x! I will flash my box tonight and will provide you with feedback if I find a bug (hopefully not )

                        Update:
                        Installation went smooth, first impression is really good! Launcher performs well and Terrarium TV streams full hd movies without problems.

                        Thanks for this good rom Toetje583 !
                        Last edited by bartj12; 02-09-2017, 12:04.

                        Comment


                          #13
                          Originally posted by bartj12 View Post
                          Thanks for this Rom, the first one for the MXQ Pro 4K S905x! I will flash my box tonight and will provide you with feedback if I find a bug (hopefully not )

                          Update:
                          Installation went smooth, first impression is really good! Launcher performs well and Terrarium TV streams full hd movies without problems.

                          Thanks for this good rom Toetje583 !
                          Thanks, enjoy it

                          Comment


                            #14
                            Thanks for this ROM. I tried it out and looks very nice. I have only one problem. My wi-fi wont turn on. Can you help me? I only have the original rom in zip format. Do you know where the drivers are or how I can fix this problem?

                            Comment


                              #15
                              Originally posted by blazinramirez View Post
                              Thanks for this ROM. I tried it out and looks very nice. I have only one problem. My wi-fi wont turn on. Can you help me? I only have the original rom in zip format. Do you know where the drivers are or how I can fix this problem?
                              Are you sure you got the newer Board S905XQ_V1.0 in your device?

                              Comment

                              Working...
                              X