Announcement

Collapse
No announcement yet.

Keyboard "Enter" key bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Same problem here with Minix NEO U9-H and Logitech K400+. The latest firmware update of the Minix (appr. 500Mb / May or June 2017) solved the issue!

    Comment


      #17
      Hello,

      How can I edit keyboard layout file? I tried to do that with ES File Explorer, but after editing it didn't allow me to save changes to this file. How can I change the properties of the file to get write access?

      Best Regards

      Comment


        #18
        Originally posted by Voncky View Post
        Hello,

        How can I edit keyboard layout file? I tried to do that with ES File Explorer, but after editing it didn't allow me to save changes to this file. How can I change the properties of the file to get write access?

        Best Regards
        Hi ,

        do you have "root" ??? , you need it , did you start "RootExplorer" inside "ES File Ex" ???

        otherwise it can not work .

        greetings / gefattern

        Comment


          #19
          Hello,

          I don't know whether I have root - I haven't try to root the device. I just purchased this device and did a few rom installations, but I guess device is not rooted yet. Can You advice how to do that in first place?

          Comment


            #20
            Ok,

            I was successful to edit keyboard layout file. Noticed finally the Root Explorer option in ES file explorer.
            I did modified the Generic.kl file located at /system/usr/keylayout, assigning keyword ENTER to key 28, but that didn't help. I even restarted the box and still Enter key is launching what's below mouse cursor instead of what is currently selected by keyboard arrow keys.
            Shall I edit another file?
            Just to be clear, I am using Logitech K400r keyboard attached to H96 MAX Rockchip RK3399 running on 20180502.093741 build. Kernel version 4.4.103

            Comment


              #21
              Originally posted by Voncky View Post
              Ok,

              I was successful to edit keyboard layout file. Noticed finally the Root Explorer option in ES file explorer.
              I did modified the Generic.kl file located at /system/usr/keylayout, assigning keyword ENTER to key 28, but that didn't help. I even restarted the box and still Enter key is launching what's below mouse cursor instead of what is currently selected by keyboard arrow keys.
              Shall I edit another file?
              Just to be clear, I am using Logitech K400r keyboard attached to H96 MAX Rockchip RK3399 running on 20180502.093741 build. Kernel version 4.4.103
              Hi, I too am having the same issue on the same Rom .The original Rom for my box was dated Dec 2017 and did not have this issue! This box has been much more flakey than expected...... Dammed Rockchip!!!
              I just tried a Playstore app " External keyboard helper demo " . I enabled the app as the input method in settings. Then in the app went to advanced settings and checked the box for "failsafe mode". Now my enter key works!
              I will look into it further to see if it changes the key layout file.....
              Good Luck
              Last edited by quincydog; 05-28-2018, 10:42. Reason: Added info

              Comment


                #22
                Originally posted by Voncky View Post
                Ok,

                I was successful to edit keyboard layout file. Noticed finally the Root Explorer option in ES file explorer.
                I did modified the Generic.kl file located at /system/usr/keylayout, assigning keyword ENTER to key 28, but that didn't help. I even restarted the box and still Enter key is launching what's below mouse cursor instead of what is currently selected by keyboard arrow keys.
                Shall I edit another file?
                Just to be clear, I am using Logitech K400r keyboard attached to H96 MAX Rockchip RK3399 running on 20180502.093741 build. Kernel version 4.4.103
                Hello,
                I think for now that I have solved the problem?
                Using Es file explorer I opened the /system/usr/keylayout (Same as you!). I then renamed the Generic.kl file to Generic.kl.crap.
                I then copied qwerty.kl renamed the copy to Generic.kl
                The main keyboard now works but not my num pad to the left of the main board.

                For interest if you look at the Generic.kl you will see that key 28 is mapped as DPAD_CENTER.......
                I tried a Bluetooth Keyboard, a USB wired and USB 2.4Ghz Kb they all worked the same.... No enter key function with stock Generic.kl . I will now look into what needs to be changed to get my Num Pad to work.
                If the Generic.kl was modified a bit that may be all that is needed. Here is a working file Generic.txt , just rename to.kl

                Good Luck!

                I wonder if this discusson should be in the RK3399 section?
                Last edited by quincydog; 06-04-2018, 14:22. Reason: Attach a working Generic.kl

                Comment


                  #23
                  these might be it ( but now clicking plus trying to do enter )

                  key 28 DPAD_CENTER to key 28 ENTER
                  key 96 DPAD_CENTER to key 96 NUMPAD_ENTER

                  the only other differences between your working generic and mine are

                  key 102 HOME key 102 MOVE_HOME
                  key 133 COPY # key 133 "KEY_COPY"
                  key 135 PASTE # key 135 "KEY_PASTE"
                  key 137 CUT # key 137 "KEY_CUT"

                  Comment


                    #24
                    Hello, did you ever made it work?
                    I have K400r keyboard on X99 (RK3399) box and have same problem.
                    It seeems, that the device sends MouseClick on KeyDown and Enter on KeyUp...<enter> in mapping sw has really keycode 28, but doesn't work and <fn>+<enter> works, but had keycode 96...
                    I have even tried to copy Generic.kl from other box (X905), where it worked, but unsuccessfully and External Keyboard helper didn't help.
                    So PLEASE, if you have solution let me know, as I'm getting ready to go back to old box with X905.

                    Thanks
                    Jan

                    Comment


                      #25
                      I have fix the problem today.

                      ----------------------------
                      Android TV model: X96 Max 4Gbyte 64G
                      Keyboard: logitec k400 plus
                      ----------------------------

                      You need to find what is your keyboard using the keyboard layout file.

                      - Open shell from the Android TV
                      ( I used app. [ Android Terminal Emulator ] )

                      - type "su" for change user to super user.
                      - type "dumpsys input"

                      You can find your keyboard layout file like the following.
                      ----------------------------
                      Identifier: bus=0x0003, vendor=0x046d, product=0xc52b, version=0x0111
                      KeyLayoutFile: /vendor/usr/keylayout/Generic.kl
                      KeyCharacterMapFile: /system/usr/keychars/Generic.kcm
                      ----------------------------

                      vender 046d = Logitech
                      product = c52b

                      Sometime, the KeyLayoutFile is /system/usr/keylayout/Generic.kl

                      Open the file and check the key 28.
                      I think the line showing key 28 DPAD_CENTER
                      Edit the line to key 28 ENTER



                      If you can not edit, I think you need ROOT permit or adb.

                      If you use the adb, type following

                      ### Conect check
                      adb devices

                      ### open the divic's shell
                      adb shell

                      ### check the directory (ro mean is Read Only)
                      mount|grep vender
                      >/dev/block/bootdevice/by-name/vendor /vendor ext4 ro,seclabel,relatime,data=ordered 0 0

                      mount|grep system
                      >/dev/block/bootdevice/by-name/system /system ext4 ro,seclabel,relatime,data=ordered 0 0



                      ### change to super user
                      su

                      ### remout the space for changing from read only to write mode
                      mount -o rw,remount /vendor
                      mount -o rw,remount /system

                      ### edit the file by vi editor
                      vi /vendor/usr/keylayout/Generic.kl
                      or
                      vi /system/usr/keylayout/Generic.kl

                      ( How to use vi editor )


                      ### Exit from
                      exit
                      exit


                      After then, you need reboot the Android box for apply the effect.

                      I hope it will you make happy. Thank you.

                      Comment


                        #26
                        I experienced the same situation last month. I tried various options, but nothing seemed to work properly. And when I asked one guy what could help, he told me to change the keyboard. So I did so, and it helped. But now I see I could use a different solution. I am from the New York zip code area. Is anybody here in my time zone to give me a consultation? I am not against paying for it.
                        Last edited by loopiks; 04-21-2020, 03:46.

                        Comment

                        Working...
                        X