Announcement

Collapse

Geekbuying 7th Anniversary with great Promotion!

Around the world, you can find a lot of online stores. But in short, one of the most loved by users is Geekbuying.
Not only because it has an impressive number of products that are in all categories, but also because it presents us with
great promotions. Freaktab and Geekbuying have been grown together so let us celebrate it!

https://forum.freaktab.com/forum/adv...sary-is-coming
See more
See less

Mk902II LE (Linux Edition) Firmware?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I changed nothing on the Ugoos SD version just installed to SD card network works I tried to unpack file to replace resources file but failed on rk tools.
    Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

    Comment


      #17
      @ scooter2014
      Sorry, it would be really nice, if you would also use chars like
      .
      ,
      return
      at your text (it would be much easyer to read )


      The last post isn't a problem, but you also handle it this way at posts with text with 5 or more lines/rows...
      RK3288 Devices
      - Overview BOX (LINK !)
      - Overview STICK (Dongle) (LINK !)

      MINIX NEO: Z64 W/A - (Intel Z3735F); X8-H Plus - (Amlogic S812H); A2 Lite (sponsored by minix.com.hk)
      UGOOS UT3S (4/32GB with fan) - FW 2.0.6 - (RK3288) (sponsored by GearBest.com)
      Tronsmart Draco AW80 Meta (2/16GB) - FW v2.0rc3 - (Allwinner A80) (sponsored by GeekBuying.com)
      Beelink / UBOX R89 - FW 111k4110_1219 - (RK3288) (sponsored by Netxeon (Beelink))

      RK3188: pcb => "CH001 1332 TN-BX09_V2.1" (K-R42 / CS918...) => wasser KK 1.0.3 (old rev)
      Fly Mouse Mini Wireless Keyboard with 2 mode learning IR remote 'iPazzPort KP-810-16'

      Comment


        #18
        Can someone please help me splitting the Rikomagic boot.img.
        I have only been able to unpack the img using FW_Tools 5.23.18 but have no idea how to split to boot.img and kernel.img.
        split_bootimg.pl gives me only "No Authorization/Keine Berechtigung" when i run it.
        Thanks a lot!
        Loewenzahn

        EDIT: Sorry, had the wrong pemission for the script. Still fighting to split to 2 image files
        Last edited by Loewenzahn; 06-02-2015, 14:12.

        Comment


          #19
          Boot and kernel in out put file when un packed. But why you un packing file for Linux I say ugoos works with network no split needed. You would have to un pack Linux file from ugoos to install resource file that all that need changed.
          Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

          Comment


            #20
            Thanks Scooter, i flashed now the UT3 image to the SD-Card and the network runs (very slow).
            Still i want to see the original image from Rikomagic on this box (booting from SD-Card)
            I splitted the boot.img and created a new separate kernel.img for tvbox from the extracted files.
            Onto a 2nd SD-Card i flashed the kernel, resources and linux-rfs images but the box wont boot. The screen stays off. No penguins appear.
            I have totally no clue where to start searching for a root-cause. I extracted and created the kernel for the 1st time, so maybe i forgot something?
            I will start from scratch using the guide from Linuxium and will just load his example files onto the card to see whether the box boots up.

            Comment


              #21
              I think I have the ricomagic Linux rom on hd someplace I look later tomorrow see if I can find and send you pm
              Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

              Comment


                #22
                Originally posted by scooter2014 View Post
                Yes if you have 16 gig box use duel boot the ut3 works with network not WiFi. I have running on mk902ii and best build if ugoos and or mac get acel running so I can use ubuntu it's good bye andriod lol... takes some time write to SD card with win image. Then insert SD card power on and it will boot to ubuntu. Wait till it loads and click on network top right select auto network it will start driver. Your on line.
                Hi, this image is that you refeer?. I have the same box [mk902ii] and I need to boot linux from sd card with ethernet working....
                Thanks.

                Best regards

                Comment


                  #23
                  Yes ugoos rom duel boot. If you swap kernel and resource should work. try without swap first. i forget what I used now but i think it works with no wifi bluetooth on stock.
                  Many devices now mk902ii/Shield/Mk68 /Ugoos/neox5/minix5 (yes they still work lol) mk80 no it doesnt work lol.

                  Comment

                  Working...
                  X