Announcement

Collapse
No announcement yet.

Libreelec for rk3328

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Originally posted by Digit97 View Post
    hi bables150 can you help me please? I have an h96 max+ and my dream is install libre elec on it or debian, i have downloaded the generic rk 3328 image from libre elec site and the result is this
    (picture)

    I have tried also with your images but the result is the same or in some case i receive only black screen

    i think thath i not understand something,there is a particulares steps?

    An user suggest me to use the right dtb but i not found it. Thank you in advance for your work
    Use the option to run simultaneously from two media (SD card and USB flash drive). This works for Armbian and LE.

    https://forum.armbian.com/topic/8082...&comment=77161

    Comment


      #62
      Update image 20190427

      Comment


        #63
        For those of you who want remote control on MX10 I made a custom rc_keymap . Add this to your libreelec distribuition with winscp ( ctr-alt-h for view hidden folders ) and reboot.More info and step by step tutorial at https://wiki.libreelec.tv/infrared_remotes.
        Attached Files

        Comment


          #64
          Originally posted by ukmark62 View Post

          Yeah - weird. All I did was upgrade using following image https://androidtvbox.eu/new-firmware...-soc-20190108/
          Used android tool v2.59 to erase flash and then upgrade and did nothing else. All these entries appeared once I upgraded to Android 9.0
          any progress on installing to emmc? I have the same mx10 box and I get the same messages when I try to install to internal emmc.

          Comment


            #65
            Originally posted by mihaianti View Post

            any progress on installing to emmc? I have the same mx10 box and I get the same messages when I try to install to internal emmc.
            Sorry, no progress - it would be up to balbes150 to find a solution - but I wouldn't expect it any time soon.

            Comment


              #66
              Internal memory of MX10

              Comment


                #67
                a dual boot option will be nice
                Last edited by mihaianti; 05-21-2019, 22:49.

                Comment


                • mo123
                  mo123 commented
                  Editing a comment
                  I hope you made a backup of Android, otherwise you will forever be stuck with LibreELEC since a PC won't detect the device anymore.

                #68
                I don't make a backup ! But is no problem i can go into maskroom mode and reinstall android with android tool ( already did that once ) , thank you !

                Comment


                  #69
                  New images 20190517 dual core 4 and 5.

                  Comment


                    #70
                    Originally posted by antonio6o6 View Post
                    I put this file on my R10 TV BOX and now I have Internet connection and PVR Addons is working on my stocker LibreELEC-RK3328.aarch64-9.1-devel-20190124145800-2f2cce8-box-trn9.img Thank you for you help and for pointed me the file. mo 123.
                    Would you mind describing the full process and maybe providing the link to this image file. Also, what device tree did you use. I used a later date aarch64 img file and it boots into Kodi but I get no audio and no Internet

                    Comment


                      #71
                      New image 20190612 kernel 4.4 and test 5.x

                      Comment


                        #72
                        Originally posted by balbes150 View Post
                        New image 20190612 kernel 4.4 and test 5.x
                        Thanks for your latest builds, I tried 5.x test build but has no ethernet so not very useful yet.

                        Comment


                          #73
                          Originally posted by polo_joe View Post

                          Thanks for your latest builds, I tried 5.x test build but has no ethernet so not very useful yet.
                          balbes150

                          In 4.4 kernel as phy-supply = <&vcc_phy>;
                          https://github.com/150balbes/LibreEL...ts.patch#L4733

                          In mainline as phy-supply = <&vcc_io>
                          https://github.com/Kwiboo/LibreELEC....lec.patch#L732

                          Mainline has missing &gmac2phy & vcc_phy, present in 4.4 kernel.

                          Maybe something about that cause ethernet to not work?

                          You perhaps know why LibreELEC forum removed Github 3rd party login?
                          I can't login now to their forum.

                          Comment


                            #74
                            Originally posted by mo123 View Post

                            balbes150

                            In 4.4 kernel as phy-supply = <&vcc_phy>;
                            https://github.com/150balbes/LibreEL...ts.patch#L4733

                            In mainline as phy-supply = <&vcc_io>
                            https://github.com/Kwiboo/LibreELEC....lec.patch#L732

                            Mainline has missing &gmac2phy & vcc_phy, present in 4.4 kernel.

                            Maybe something about that cause ethernet to not work?

                            You perhaps know why LibreELEC forum removed Github 3rd party login?
                            I can't login now to their forum.
                            I'm not sure, but this value is used for all models. Perhaps in the new core it has changed.

                            Comment


                              #75
                              New test version 20190630.
                              Please note that the new versions are built using the main (under development) branch of LE and may contain some non-working functions. Importantly. New images have dtb (box) file by default. To work correctly, you need to change it to the desired version. All dtb files are now placed in the /dtb/rockchip directory.

                              Comment

                              Working...
                              X