Unconfigured Ad Widget

Collapse

Announcement

Collapse
No announcement yet.

Libreelec for rk3328

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    LE version update (201200105). Updated u-boot.
    Added a secondary image of rk3328-old with the previous u-boot settings (for those who may have problems with the new u-boot).

    Comment


      Question to admins and users, can be worth combine themes rk3328 Linux and LE with a similar theme for rk3399 ?


      Comment


        Important. Changed the directory location of the images. Now all images (for all supported platforms) are in one place. LIBREELEC — Yandex.Disk


        Comment



          LE 20200303 kernel 5.6 (arm and aarch64)

          Comment


            Hello,
            I have a MX10 Tvbox under android 7.1.2, and I would like to try libreelec but I did not understand how we proceed to install it, could you explain for a beginner how it is done, thank you ..

            Comment


              Hi! And thanks for the fantastic work! I'm trying to customize two MX10 boxes. I've tried the LibreELEC image and it boots, network ok, Kodi launches, but video playing is decoded by software (pressing O says SW) and Kodi UI moves slowly. Looks like GPU acceleration wouldn't work. I booted with rk3328-box.dtb.

              Is there an specific DTB that can provide better results? Aside from the DTB is something more needed (rockhip kernel, compiled ffmpeg, licenses, extra firmware...). I made some experiments without results. I attach original android dmesg log (kernel 3.10) and DTS (out of /proc with dtc tool).
              Attached Files

              Comment


                Originally posted by Ac2n View Post
                Hello,
                I have a MX10 Tvbox under android 7.1.2, and I would like to try libreelec but I did not understand how we proceed to install it, could you explain for a beginner how it is done, thank you ..
                Download the 3328 image, unpack it and write it to your SD card. You don't need to configure anything for MX10. Connect to the TV box and turn on the power.

                Comment


                  Originally posted by jesuslop View Post
                  Hi! And thanks for the fantastic work! I'm trying to customize two MX10 boxes. I've tried the LibreELEC image and it boots, network ok, Kodi launches, but video playing is decoded by software (pressing O says SW) and Kodi UI moves slowly. Looks like GPU acceleration wouldn't work. I booted with rk3328-box.dtb.

                  Is there an specific DTB that can provide better results? Aside from the DTB is something more needed (rockhip kernel, compiled ffmpeg, licenses, extra firmware...). I made some experiments without results. I attach original android dmesg log (kernel 3.10) and DTS (out of /proc with dtc tool).
                  The information was not confirmed. I recorded the last image 20200331 for rk3328. Launched LE on the MX10. The video is played with HW. What image do you use ? What settings did you make ? What video do you launch ?

                  Comment


                    Originally posted by balbes150 View Post

                    The information was not confirmed. I recorded the last image 20200331 for rk3328. Launched LE on the MX10. The video is played with HW. What image do you use ? What settings did you make ? What video do you launch ?
                    Holly Molly!

                    It is working for some files!

                    A quick sample of several files, first non accelerated, next the hardware accelerated ones, ffmpeg -i outputs:

                    Code:
                    SW -> Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 720x304 [SAR 1:1 DAR 45:19], 1099 kb/s, 23.98 fps, 23.98 tbr, 23.98 tbn, 23.98 tbc
                    SW -> Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 720x304 [SAR 1:1 DAR 45:19], 1996 kb/s, 23.98 fps, 23.98 tbr, 23.98 tbn, 23.98 tbc
                    SW -> mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 720x384 [SAR 1:1 DAR 15:8], 1095 kb/s, 23.98 fps, 23.98 tbr, 23.98 tbn, 23.98 tbc
                    SW -> Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 720x304 [SAR 1:1 DAR 45:19], 1045 kb/s, 24 fps, 24 tbr, 24 tbn, 24 tbc
                    SW -> mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 720x304 [SAR 1:1 DAR 45:19], 1094 kb/s, 23.98 fps, 23.98 tbr, 23.98 tbn, 23.98 tbc
                    
                    HW -> Video: h264 (High), yuv420p(tv, bt709, progressive), 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
                    HW -> Video: h264 (High) (H264 / 0x34363248), yuv420p(tv, smpte170m/smpte170m/bt709, progressive), 720x302, 2107 kb/s, 24 fps, 24 tbr, 24 tbn, 48 tbc
                    HW -> Video: h264 (High), yuv420p(tv, bt709, progressive), 1920x804 [SAR 1:1 DAR 160:67], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
                    HW -> Video: h264 (High), yuv420p(progressive), 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
                    Seems to me the question is in those with XVID codec. In the Kodi of your image it says SW video decocer, "ff-mpeg4-drm_prime (SW)", pixel format: yuv420, deinterlace method: none.

                    With (standard Play Store) Kodi 18.5 in the original android firmware, it says video decoder amc-mpeg4(S)(HW), pixel format Surface, deinterlace method hardware.

                    Also reporting, CEC works like a charm, but IR remote not. Tested image LibreELEC-ARM-ALL.arm-9.80-devel-20200331084636-569f834-rk3328.

                    Settings in the stock android Kodi include:

                    settings, player, videos, processing
                    enable hq scalers for scaling above 20%
                    allow hardware acceleration - media codec (surface): on
                    allow hardware acceleration - media codec: on

                    no settings touched in SD-card image, default:
                    allow hardware acceleration: prime
                    prime render method, direct to plane

                    Chaging the render method to EGL results on green play screen.


                    All in all, this can be it. Much thanks again for this effort!
                    Last edited by jesuslop; 04-03-2020, 22:32.

                    Comment


                      An example video of the problem reported in #114 is at http://demo.nimius.net/video_test/videos/test.avi

                      Comment


                        https://forum.libreelec.tv/thread/20...422#post137422

                        Comment


                          Hope I'm understanding you. I downloaded LibreELEC-ARM-ALL.aarch64-9.80-devel-20200406174101-569f834-nanopi-k2.img, wrote it to sd-card with Etcher, put it in my MX10, booted, and the result is that it boots to stock Android (no LibreELEC in sight).

                          Comment


                            You need to configure the DTB, change it in the file (uEnv.txt)

                            FDT=/dtb/rockchip/rk3328-box.dtb

                            Comment


                              Originally posted by balbes150 View Post
                              You need to configure the DTB, change it in the file (uEnv.txt)

                              FDT=/dtb/rockchip/rk3328-box.dtb
                              yes, I did that (forgot to say in the post) and booted to stock Android. After that I tried LibreELEC-ARM-ALL.aarch64-9.80-devel-20200406175716-569f834-rk3328.img and it booted to LibreELEC.

                              Comment


                                Hi, I boot my MX10 on LibreELEC-ARM-ALL.aarch64-9.80-devel-20200406175716-569f834-rk3328.img
                                But I find the playback of video not very fluid especially with video in h265, and when I try to read a h265 HDR I have good sound but no image ..
                                Is there something to do?
                                Do I need to install e-MMC for it to work better?
                                Thank you.

                                mo123 says me "You can perhaps try an old 4.4 kernel LibreELEC image and see if one boots on your device, HDR will work correctly with it."
                                What would be the most suitable LE version for my MX10, noted mxq-rk3328-d4_A ver: 1.0 on the motherboard.

                                Comment


                                • mo123
                                  mo123 commented
                                  Editing a comment
                                  Mainline 5.x LibreELEC doesn't yet support H265 or HDR, only mpeg2/4,H264,VP8.
                                  So you have to use an old 4.4 kernel LibreELEC or wait 6-12 months until H265 & HDR is supported in mainline LibreELEC with hardware decoding.

                                • mo123
                                  mo123 commented
                                  Editing a comment
                                  Maybe here, you will have to try all the rk3328 ones - http://kwiboo.libreelec.tv/test/old/
                                  But you will have to unpack the dtb file to dts, edit it to match the mx10 dts settings and repack it if things don't work.
                                  I can't help further.
                                  It will be best to buy a Mi Box, FireTV 4K or Ugoos X2 stick instead.
                              Working...
                              X