No announcement yet.

[TWRP] LibreELEC for S905x plus EXTRAS!! (NEW)

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

    [TWRP] LibreELEC for S905x plus EXTRAS!! (NEW)

    NOTICE: OK, so since pinguy has retired this project, I have taken over. We are now up to LE 8.2 and 9.0 beta. Because of this, I am not making this thread version specific.

    [LibreELEC] Bolt Ons! AceStream & EmulationStation + RetroArch/Libretro for S905/S905X devices!

    I will admit I have had huge issues with the Nexbox A5 with the Amlogic S905X SOC.
    I thought all the issues was due to the S905X. I was wrong. The issues is due to the poorly built Android ROM.

    I was about ready to sell the Nexbox until I came across the LibreELEC build. I honestly can't empathize how much of an improvement installing LibreELEC has been. You just need to try it yourself.

    Since installing LibreELEC I have had no issues.

    All of my HEVC videos work fine and I have had no frame drops or stutters. CEC also works.

    The difference from running LibreELEC compared to Android is night and day.


    For this to work you need to restore the original firmware back to the box so TWRP can install. If you are already using the original firmware you can ignore this.
    For TX5 Pro owners you need to restore firmware version 20160805. Newer versions disabled the ability to boot from SD.

    Other Original Firmwares:
    LibreELEC will work with all S905X Devices that have a reset button.

    To install LibreELEC you need TWRP.

    This is the TWRP recovery for S905X. To install, rename the file recovery.img and place it onto a 16GB or smaller Micro SD card and put it into the box. Then hold in the reset button while powering on the device and it will boot into TWRP. You can install TWRP to the box recovery by going to install, selecting "image" instead of zip, and flashing it to "recovery".

    The MD5 for TWRP is: 46cb115fbe0d31c4ed3db72179963003

    Once the TWRP recovery is installed you can now flash LibreELEC. The version you want to install is this one: (Works with both 1/2GB RAM Models)
    (I would use TWRP to make a backup of the installed Android system before installing LibreELEC. Just make sure you store the backup to an external storage device.)

    The guys working on it are updating it all the time. So check here for updated info:
    All I am doing is converting the images so they can be installed via TWRP (The default booting from SD method they use didn't work for me).


    Here is a zip with a few remote.conf for those that need them:

    The remote.conf needs to be placed in the .config folder (I use FileZilla to connect to the box).

    user: root
    password: libreelec

    If you are having any playback issues try replacing the guisettings.xml in /.kodi/userdata/ with this one (make sure you unzip it first), then reboot the device. The file uses all the correct settings for smooth playback.

    You could also test out these Kodi Build's that have the correct setup. He has plenty of video's showing how to setup and install his repo, and builds.

    Here are the original threads. They have some good details on various issues.

    If you need to change your device tree and are able to boot into twrp you can use this zip and replace the device tree in it.!Vs0DARZB!R4XZyEyeR...XUbWH-r_Rrf1mc
    Last edited by Urgodfather; 11-07-2017, 16:25.

    [LibreELEC] Bolt Ons! AceStream & EmulationStation + RetroArch/Libretro for S905/S905X devices!

    To use these "Bolt Ons!" you need to be running LibreELEC on your S905/X Box.

    AceStream 3.1.19 (Works with LibreELEC 8)

    ssh -l root "LibreELEC IP" Password: libreelec cd /storage curl -LO tar xopf Acestream_S905.tgz rm -f Acestream_S905.tgz reboot
    EmulationStation + RetroArch 1.5.0 (Works with LibreELEC 8)

    ssh -l root "LibreELEC IP" Password: libreelec cd /storage curl -LO tar xopf EmulationStation_S905.tgz rm -f EmulationStation_S905.tgz reboot
    Due to the way the packages are put together, updating LibreELEC won't effect AceStream/EmulationStation/Libretro. They run from the storage partition so won't be affected by the update (but the update may break a lib, so post here is something stops working).

    Working Systems:

    ROM Folder / (System ) / : Core / Supported Extensions
    • fba (Final Burn Alpha): fbalpha / .ZIP .iso .ISO (BIOS in this folder with lowercase .zip are hidden, and ROMs with uppercase .ZIP show)
    • neogeo (NEO・GEO): fbalpha / .ZIP .iso .ISO (Same as above)
    • ngp (Neo Geo Pocket): mednafen_ngp / .ngp .NGP .ngc .NGC
    • mame (MAME 078): mame2003 / .zip .ZIP .chd .CHD .7z .7Z
    • nes (Nintendo): nestopia / .nes .NES .fds .FDS .zip .ZIP
    • snes (Super Nintendo): snes9x2010 / .smc .SMC .fig .FIG .sfc .SFC .gd3 .GD3 .gd7 .GD7 .dx2 .DX2 .bsx .BSX .swc .SWC .zip .ZIP
    • n64 (Nintendo 64): mupen64plus / .n64 .N64 .v64 .V64 .z64 .Z64 .bin .BIN .u1 .U1 .ndd .NDD .zip .ZIP
    • gb (Game Boy): gambatte / .zip .ZIP .gb .GB
    • gbc (Game Boy Color): gambatte / .zip .ZIP .gbc .GBC
    • gba (Game Boy Advance): vba_next / .zip .ZIP .gba .GBA
    • nds (Nintendo DS): desmume / .nds .NDS .bin .BIN
    • mastersystem (Sega Master System): picodrive / .zip .ZIP .sms .SMS
    • genesis (Sega Genesis): picodrive / .zip .ZIP .md .MD
    • megadrive (Sega Mega Drive): picodrive / .zip .ZIP .md .MD
    • segacd (Sega CD): picodrive / .cue .CUE .iso .ISO (You need both .bin and .cue files for sound to work. .bin files are hidden so games are not shown twice)
    • sega32x (Sega 32X): picodrive / .zip .ZIP .32x .32X
    • gamegear (Sega Game Gear): genesis_plus_gx / .zip .ZIP .gg .GG
    • psx (Playstation): pcsx_rearmed / .bin .BIN .iso .ISO .img .IMG .mdf .MDF .pbp .PBP .toc .TOC .cbn .CBN .m3u .M3U (I would use .PBP)
    • psp (Playstation Portable): ppsspp / .elf .ELF .iso .ISO .cso .CSO .prx .PRX .pbp .PBP
    • atari2600 (Atari 2600): stella / .a26 .A26 .bin .zip .ZIP .7z .7Z
    • atarilynx (Atari Lynx): handy / .lnx .LNX .zip .ZIP
    • atarist (Atari ST): hatari / .st .ST .msa .MSA .zip .ZIP .stx .STX .dim .DIM .ipf .IPF
    • videopac (VideoPac): o2em / .bin .BIN
    • zxspectrum (ZX Spectrum): fuse / .tzx .TZX .tap .TAP .z80 .Z80 .rzx .RZX .scl .SCL .trd .TRD .zip .ZIP
    • pcengine (TurboGrafx 16): mednafen_pce_fast / .pce .cue .zip .PCE .CUE .ZIP
    • msx (MSX): fmsx / .rom .ROM .mx1 .MX1 .mx2 .MX2
    • c64 (Commodore 64): vice_x64 / .crt .CRT .d64 .D64 .g64 .G64 .t64 .T64 .tap .TAP .x64 .X64 .zip .ZIP .prg .PRG
    • amiga (Commodore Amiga): uae4arm / .adf .ADF .dms .DMS .ipf .IPF .zip .ZIP .adz .ADZ .uae .UAE
    • pc (DOS x86): dosbox / .com .COM .sh .SH .bat .BAT .exe .EXE
    • scummvm (ScummVM): scummvm / .sh .SH .svm .SVM

    To launch EmulationStation there is an included add-on to launch it (it will show up under "Program add-ons").

    To return back to EmulationStation after opening a game, select "Quit RetroArch".

    To boot back into Kodi select the Kodi option within EmulationStation.

    The default ROM folder is at: /storage/roms/

    Place your games in there (Emuparadise is a pretty good place to go looking for ROMs).

    EmulationStation can also use ROMs from a USB Storage device and SD Card.

    To get it working you must first format and label/name the SD Card sdcard. This is so when it gets mounted, its mounted as 'sdcard'. If it doesn't, it won't work.
    Same thing with the USB Storage device. It needs to be labelled/named usb.

    Once you have done that download this zip and extract it onto the sdcard/usb.

    It should look like this:
    • /sdcard/roms/"Systems"

    Now just place your ROMs into the folders.

    Once you connect the USB/SD Card, EmulationStation will look for ROMs on them.

    The only issue you may face is if you spread ROM's for the same system over all 3 locations.

    What I mean by this, is if you put PSX games onto the USB, SD Card and in the internal storage, EmulationStation will show the PlayStation tab 3 times. Once for each location.

    So the best thing to do is pick one location per system. That way the same system won't show up multiple times.

    The scraper in EmulationStation does work but it is a bit on the slow side (and can't do Arcade games). You will be better off following theses guides to get the metadate and artwork (the app does work locally so you don't have to do it over a network).

    Thanks to scottmu64, niabi & JoKeRz for making this possible.


    For PSX games that have multiple CDs (Final Fantasy Series, Metal Gear Solid etc.) you will be better off using the .PBP format (PSX2PSP eBoots).
    To be honest .PBP is the better format as it does compression. So will make your game collection smaller.

    Bluetooth controllers do work wireless, but you need to connect them within the LibreELEC settings. (I am using a PS3 Dualshock 3 Controller with my setup but it does take a few goes before it first connects. Once you get it connected that first time, it reconnects without any issues).

    If you have controller issues with RetroArch you can setup your controller within the RetroArch settings. But most controllers will work fine out of the box.

    When first opening EmulationStation it may not fit the screen correctly. If this happens just reboot the box and re-open EmulationStation. Also when first changing the theme. It might not apply. Again just reboot the box. These issues only happen when first using EmulationStation.


    The version of RetroArch/Libretro comes from AlexELEC build as do most of the cores.
    The version of EmulationStation comes from niabi build as do the missing cores that AlexELEC don't have.
    For the rest of the missing cores I get them from Lakka or JoKeRzBoX.

    The package should be super simple to keep updated.
    • /storage/.emulationstation/emulationstation (the emulationstation binary)
    • /storage/.kodi/addons/ (the retroarch binary)
    • /storage/.kodi/addons/ (the folder where the cores are kept)

    Will be the only things that will need replacing when there is an update from niabi, AlexELEC or Lakka/JoKeRzBoX (but read the release notes first. Not every update will be useful for this package).

    Default locations:
    • emulationstation & retroarch are in the /usr/bin folder on niabi & AlexELEC images.
    • libretro cores are in the /usr/lib/libretro folder on niabi & AlexELEC images (only need the .so files).

    If you would like to add more cores to your system that are not included in this package, you will need to edit the es_systems.cfg file (in /storage/.emulationstation/) for them to show up in EmulationStation. For tips on how to setup the es_systems.cfg file, the RetroPie-Setup wiki has some good resources (default bios folder is /storage/emulators/retroarch/system).

    As for updated controller config files. You can get them from here.
    And they go into this folder:
    • /storage/.kodi/addons/

    Once you have made all the changes make sure you set the correct permissions and make sure the binaries are executable.


      >>I tried EmulationStation + RetroArch on, but when i try to start i get corrupted image (first half the screen and then whole).
      >>hojnikb can you provide more details. what device, what build, by whom?

      I've fixed the issue by downgrading libreelec to 8.0.2. It now works just fine, i just can't get the select+start combo to work (to quit the game).
      Also, any chance to setup libreelec so that it boots straight to emulationstation ?


        I have X96 and running XannyTech Rom. So you said I need to be in original firmware meaning I have to find and flash back to original image before I can apply this? Right?


          hojnikb thanks for providing an update. honestly i havent had the chance to test on 8.2 but if i get some free time this weekend i can update accordingly.
          DhiJay23 you should be fine provided that this rom that you are using has the right device tree in it and you can boot into recovery and/or sd card. I always suggest having the original firmware as a backup plan in case you cannot boot. However if you flash the zip and it attempts to boot but hangs on the amlogic logo, then you should be able to get into recovery and use the zip at the bottom of my first post to change your device tree after flashing my LE image. make sure that you download the right device tree for your device from kszaq 's site


            Urgodfather is there a elec available for V88 that you aware of?


              DhiJay23 that device appears to be a RK3229 based unit. I don't support those. I would suggest searching based on that processor.


                Another thing i noticed; when i connect my dualshock3 via bluetooth, it connects just fine, but 4 red leds keep flashing constantly. Any way to disable them ? Controller works just fine though.


                  Ok so I looked into the Extras, they are all functioning as they should in LE 8.2. hojnikb the only thing i can assume is that when you downloaded, the file was corrupted. in regards to the ps3 controllers, i noticed that a long time ago. I'm pretty sure that has something to do with the drivers or config files. Not specific to this build.. Maybe you can find a thread to shed some light on it? I dont use ps3 controllers. I have 8bitdo controllers, they work perfect.


                    Originally posted by Urgodfather View Post
                    Ok so I looked into the Extras, they are all functioning as they should in LE 8.2. hojnikb the only thing i can assume is that when you downloaded, the file was corrupted. in regards to the ps3 controllers, i noticed that a long time ago. I'm pretty sure that has something to do with the drivers or config files. Not specific to this build.. Maybe you can find a thread to shed some light on it? I dont use ps3 controllers. I have 8bitdo controllers, they work perfect.
                    apperently that issue is fixed in 3.15 kernel

                    maybe backport of the driver or something ?

                    Another thing i noticed. Whatever remap i do in emulationstation it has no effect whatsoever in actual game (only works in the menus). If is setup the controller in retroarch, it works. BUT if i want to setup two different controllers, thats literally not doable. I tried setting one controller to user1 and second controller to user2, but this only works when i have both controller hooked up. When i only have one controller connected, remap doesn't work so i have to do it all over again. Pretty lame.


                      I can't make it work on Mini M8S III. I installed TWRP and I flashed it by choosing the zip file. But after boot I see corrupted grayscale Amlogic 64 logo and then it says the file system is corrupted. I tried both versions and result is the same. Any idea what I do wrong?


                        Hi @all ,

                        is it possible to update Emulationstation?


                          Can you update modules of acestream from AlexELEC last releases?
                          Mini M8S II


                            I´ve found simultaneous new releases of AceStream to Libreelec but i dont know how install.
                            If you take a look here:
                            Mini M8S II


                              ok this thread is dead...
                              Mini M8S II