Announcement

Collapse
No announcement yet.

[ROM] AlfaWise H96 PRO+ 3/16Gb - 3/32Gb - 3/64Gb - SCV7A 7.1.2 (DDR3/DDR4 and 9377 Wifi Chipset)

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • lyubodelev
    replied
    Originally posted by koutsouk View Post
    I have an h96 pro but with wifi chip ap 6255. Does any one know which firmware should I install for the wifi to work? I tried many and superceleron among them but wifi does not work and ethernet hungs after 5 minutes.
    Any help appreciated
    What is your ram - LPDDR or not LPDDR?

    Leave a comment:


  • koutsouk
    replied
    I have an h96 pro but with wifi chip ap 6255. Does any one know which firmware should I install for the wifi to work? I tried many and superceleron among them but wifi does not work and ethernet hungs after 5 minutes.
    Any help appreciated

    Leave a comment:


  • ReaperMan
    replied
    LOL, way..way past my skill level.
    (didn't like MS DOS either.)

    So..if it seems to have an issue...maybe..try a windows machine.(Yes it may do the same and likely be better...but, It maybe the reason it's not working?)
    If you can flash SCV2 ..then the board should be capable. My other box is V2.2...Except for YouTube/Chrome video issues, SCV7a runs fine.(HW video acceleration fail issue..returned to SCV1)

    Leave a comment:


  • tht
    replied
    @seedless,

    Under the best conditions it is always best to hold the reset button in then plugin the power supply then connect the usb cable to the box, the 3gb ram boxes seem more prone to this.

    I was a Unix System Administrator back in the 90's and I was considered Old then, Unix/Linux 20+ years, Computers 30+ years.

    Leave a comment:


  • seedless
    replied
    tht

    Correct, I'm using the khadas fork of the aml-flash-tool. I had actually setup a Windows box to do the flashing and had all of 0 success after many dozens of tries. I got nothing but checksum errors at different states of flashing (different cables/different boxes/different OS's/different ROMS/different versions of the flashing tool). I only recently realised that I can flash 6.0 Android ROM's successfully so never tried those in the Windows burn tool but probably worth a flash to see if I can get any success with that tool at all.

    I should note that I also tried the SD card update method and would get a red X after the update started. I started thinking maybe something is up with the NAND as Android 6 images are smaller, but the fact that SCV4/SCV7 TWRP doesn't work via SD and the version shipped with SCV2 does makes me second guess that. Maybe I'll try writing/reading a bunch of garbage to the chip and reading it back to make sure it's healthy.

    I work in embedded systems so I've been using a RTOS/Linux for a good 10+ years. Another Linux fan?

    Leave a comment:


  • tht
    replied
    @seedless,

    And Are you using the Linux update that comes from the khadas git to burn the resulting img file to the player?

    I have had inconsistent results using the update depending on the Player and firmware sometimes it works very well and the box is fine other times I get Boot Loops Nothing more than the Boot Logo.

    Been on Linux very Long?

    Leave a comment:


  • seedless
    replied
    Originally posted by tht View Post
    @seedless,

    There is one other thing it might be but I hate to mention it but have to ask Has the SCV4 Been Modified at all if so by which tool?
    No, it's a valid question and I appreciate any help I can get. I don't give up easily and this is driving me nuts. I downloaded the stock image and haven't modified it in any way.

    Leave a comment:


  • seedless
    replied
    Originally posted by ReaperMan View Post
    @seedless,


    The only micro help I could think...Did you select "Flash BootLoader" Android 6(SCV2) --> Android 7(SCV4)?
    Yep. I use a Linux tool so the process is slightly different but I start by nuking the current bootloader:
    ./aml-flash --destroy (Erase the bootloader and reset the board)

    I then proceed to flash the complete image including bootloader (bootloader|dtb|logo|recovery|boot|system)
    ./aml-flash --img=firmware/SCV4-A7.1.2-x64-Alfawise.H96.ProPlus.img --soc=gxl --wipe --reset=n --parts=all

    Leave a comment:


  • tht
    replied
    @seedless,

    There is one other thing it might be but I hate to mention it but have to ask Has the SCV4 Been Modified at all if so by which tool?

    Leave a comment:


  • ReaperMan
    replied
    @seedless,


    The only micro help I could think...Did you select "Flash BootLoader" Android 6(SCV2) --> Android 7(SCV4)?

    Leave a comment:


  • seedless
    replied
    Anybody else come across a h96 pro + board that will only boot a select few ROMs? This is an older model cz-s32-v2.2, 20161012(A15) QL 1648. It's marked as a 3G/32G/9377. I can flash stock Android 6 and SCV2 which is also Android 6. i.e.)
    -- aml_6.0.1_s912_q9377-H96PROPLUS(3+32)_mac-2016xxxx.img -> aml_6.0.1_s912_q9377-H96PROPLUS(3+32)_mac-2017xxxx.img
    -- SCV2-Alfawise.H96.Pro+.img

    I can't flash any stock Android 7.1 and when I flash SCV4, it succeeds but it's stuck on the splash screen. I decided to pull TWRP from SCV4 and from SCV2 and boot via SD. SCV2 works whereas SCV4 does not. I'm curious what the differences in the board config between the two are. Might have to ping the builder of these great ROMs for that info. Chips on this board look familiar to most working boards but something must be slightly different.

    Leave a comment:


  • Henngel
    replied
    Originally posted by Henngel View Post

    I don't want the remote in my car. The touch screen is easier but needs navigationbar so I can go back and go home from other windows and apps.
    I need to use the touch screen but unluckily some touches like swiping and scrolling don't work on some of the sitting menu. Other work with two fingers. Some apps work fine like maps but with two fingers for moving, 3 finers for zooming! !!
    I added touch xml file from a nother rom but no difference.
    Beside the navigationbar disappear .
    here's a video shows how the box responds to touch! !
    https://youtu.be/7nVKWicNFrw
    Last edited by Henngel; 10-13-2018, 06:18.

    Leave a comment:


  • seedless
    replied
    I can't for the life of me seem to flash SCV4 on my h96 Pro+. I have the green PCB (CZ-S32-V2.2). I've tried 3 different versions of the USB burning tool with 3 different USB cables on 2 different windows boxes and always end up with an invalid checksum at some point. Usually it's pretty early in the process but one time, it reached 96% before hitting a checksum error. The md5 of the downloaded SCV4 images checks out.

    I found a Linux flashing tool and I managed to complete the flashing process one time and one time only. On startup, the box hung on the SuperCeleron splash screen (left it for 20 minutes). I haven't been able to re-flash the device on windows or Linux. I've probably tried 40+ times at this point. Does anybody have an suggestions? Not sure where to go from here. Thanks.

    Leave a comment:


  • bloptra18
    replied
    Out of curiosity, I ran speed test on the box. I am using 100 Mbps fibre broadband. The speed test I got are as follows :

    2.4G 88-103 download and 60-80 upload speed
    5G 98-105 download and 80-90 upload speed
    LAN 50-70 download and 30-50 upload speed (with modem wifi switched off)

    I though LAN speed should be better than wifi and not the other way round. I am using cat 6 network cable. Is there any setting in the box that hinder the LAN speed.

    Test run the LAN speed on laptop connected to the modem using the same cat 6 cable and got 100 download and 95 upload.

    Leave a comment:


  • Henngel
    replied
    Originally posted by gefattern View Post

    Hi , why not using a BT Mouse & Keyboard , much better then stock Remote ,

    greetings / gefattern
    I don't want the remote in my car. The touch screen is easier but needs navigationbar so I can go back and go home from other windows and apps.

    Leave a comment:

Working...
X