Announcement

Collapse
No announcement yet.

[ROM] Beelink GT-King Android TV by Sasvlad (Android TV 9.0)

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [ROM] Beelink GT-King Android TV by Sasvlad (Android TV 9.0)

    Update: [ROM] Beelink GT-King AndroidTV by Sasvlad v.2.0_906P0


    Hi guys and girls, at your numerous requests, I present the universal Android TV firmware for Beelink GT-King.
    Many thanks to Beelink for the sample box.


    Best thing to do before flashing your box is to check which Serial Number you currently have on the bottom of your box.

    I've made 4 different ROM's for these boxes two for boxes starting with SN: 922X & SN:95X2 and another two for SN:B922
    (English and Russian localization for each)
    Please download the correct ROM for your box

    Changelog v1.0:
    • built-in modified TWRP recovery 3.2.3-1.
    • changed init.d mechanism
    • removed the ancient Chinese busybox
    • updated busybox and all its links in vendor
    • a newest SU binary is installed
    • installed patched SuperSu 2.82 that does not require updating
    • USB debugging is enabled by default, full AdbShell support, Selinux is disabled
    • Noise reduction disabled
    • Installed a program to manage the service Auto Frame Rate (afrd)
    • changed Framework. Cut out the System Tray, but left the Navigation Bar
    • 13 WiFi channels



    Changelog v2.0:
    • Used latest version of Stock's ROM 906P0
    • Fix IPTV Problem
    • New TWRP
    • Optimization system
    • Minor bug fixes


    Added the following applications:
    • Opengapps Atv (at the very minimum)
    • App Drawer
    • Explorer X-plore, for remote
    • Alternative Market AptoideTV
    • GoogleChrome v.57. Do not update it, if you want to use copy-paste


    Want to buy me a beer?

    Donation Link Press Here

    Download:

    v.1.0:

    v2.0:


    Install instructions:
    • Use USB Burning tool 2.1.7.0
    • Refer to Beelink own tutorial how to flash this box!

    Enjoy it!

    Screenshots:
    Click image for larger version  Name:	Eng_Interface.png Views:	46 Size:	252.0 KB ID:	780071

    Click image for larger version  Name:	Eng_Search.png Views:	53 Size:	419.5 KB ID:	780072

    Click image for larger version  Name:	Eng_Settings.png Views:	49 Size:	337.7 KB ID:	780073

    Click image for larger version  Name:	Eng_DevPref.png Views:	46 Size:	338.8 KB ID:	780074

    Click image for larger version  Name:	Eng_About.png Views:	46 Size:	337.4 KB ID:	780075

    Click image for larger version  Name:	Eng_DroidSettings.png Views:	87 Size:	354.2 KB ID:	780070
    Last edited by Sasvlad; 11-06-2019, 08:49. Reason: Update: [ROM] Beelink GT-King AndroidTV by Sasvlad v.2.0_906P0

    #2
    nice work ,tnx

    Comment


      #3
      Tks.For your work. I will try this with my B922 box next week , to see if it fixed the no Lan/eternet bug. Regards

      Comment


        #4
        thk..
        Last edited by sssss2sssss; 08-03-2019, 11:00.

        Comment


          #5
          Thanks for the new firmware,

          However I installed the Netflix from Play store but it said "The device model is not compatible with the app version". Can anyone help me?

          Comment


            #6
            @Eltoncheng you can run Netflix in 1080p only on CoreELEC with Netflix add-on.

            Comment


              #7
              Just installed today, looks pretty good so far, but can't find the bluetooth settings. I had it working with straight 'droid before installing this ATV, so feel a bit confoozelated...

              Help, please??

              Comment


                #8
                Originally posted by aacarr View Post
                Just installed today, looks pretty good so far, but can't find the bluetooth settings. I had it working with straight 'droid before installing this ATV, so feel a bit confoozelated...

                Help, please??
                If you change the gray settings to white - bluetooth works.

                How to do it:
                1. Explorer with root access go to the system \ priv-app \ Settings \ folder
                2. kill everything there
                3. put the contents of the archive there
                4. set the rights on files - 644, on folders - 755
                5. Reboot the box.
                Download the Settings.rar

                Comment


                  #9
                  Originally posted by Sasvlad View Post

                  If you change the gray settings to white - bluetooth works.

                  How to do it:
                  1. Explorer with root access go to the system \ priv-app \ Settings \ folder
                  2. kill everything there
                  3. put the contents of the archive there
                  4. set the rights on files - 644, on folders - 755
                  5. Reboot the box.
                  Download the Settings.rar

                  Hmmmm ..... Cyrillic alphabet at that link?? You're not from around here, are you? LOL

                  Seriously, Thanks for the help.Not sure I understand everything (as I've said before, I've been a coddled Windows user since Windows 3.1), but I'll take s stab at this on I wake up (0700 here) and try translating what that link points to, but it looks like a 404 error.

                  Oh well, breakfast now, and I'' come back to this later today....

                  Thanks again for being so quick to help!

                  Comment


                    #10
                    Originally posted by aacarr View Post


                    Hmmmm ..... Cyrillic alphabet at that link?? You're not from around here, are you? LOL

                    Seriously, Thanks for the help.
                    Try here.

                    Comment


                      #11
                      Originally posted by Sasvlad View Post
                      Thank you SO much, kind sir! Link works, file-s 100%!

                      Gives me something to do when I get home!

                      Well, that and

                      Comment


                        #12
                        Sasvlad could you put here a flashable TWRP zip.file which i could flash to my stock original rom. Would be very greatful.

                        I got my box B922 some days before and would like to try first some days the stock rom before I perhaps change to your custom rom, thanks

                        I would like to make a backup with your TWRP.

                        Comment


                          #13
                          Originally posted by Sasvlad View Post

                          If you change the gray settings to white - bluetooth works.

                          How to do it:
                          1. Explorer with root access go to the system \ priv-app \ Settings \ folder
                          2. kill everything there
                          3. put the contents of the archive there
                          4. set the rights on files - 644, on folders - 755
                          5. Reboot the box.
                          Download the Settings.rar
                          Hi Sasvlad,
                          this doesnt work for me. I get always a "read only system" failure. Equal, if you use the RootExplorer, ESFile-Explorer or whatever.

                          After i tried to remount the system with
                          su
                          mount -o rw, remount /system

                          but it didnt helped.

                          Could you give some other hint how to solve this problem?

                          Thank you

                          Comment


                            #14
                            Originally posted by TheRealDeal View Post

                            Hi Sasvlad,
                            this doesnt work for me. I get always a "read only system" failure. Equal, if you use the RootExplorer, ESFile-Explorer or whatever.

                            After i tried to remount the system with
                            su
                            mount -o rw, remount /system

                            but it didnt helped.

                            Could you give some other hint how to solve this problem?

                            Thank you
                            This is Android 9. It's different. You need to give root access to /
                            su
                            mount -o rw,remount /

                            or so:
                            mount -o rw,remount /dev/root

                            Comment


                              #15
                              Okay thanx...will try it now...

                              Comment

                              Working...
                              X