Announcement

Collapse
No announcement yet.

X96 Air Amlogic S905X3 Android 9.0 Media Player

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hi, Ive read this thread with interest as I recently bought a cheap x96 to play with. The interface I thought was rubbish and so to the performance.
    Apps kept crashing, wifi wouldnt connect and so on. So with all the info on here I sucessfully followed the various instructions and flashed it using twrp.
    All seemed well except it doesnt boot or has any lights on. Basically dead.

    My thoughts are I probably flashed the wrong rom but after checking out google as well as here I think the odds of picking the correct rom for my device would be astronomical.
    There are just so many very similar.
    I will upload a picture later of the board because after searching I just cannot find any the same. It seems though dozens of sites describe the box I have but the board is quite different.
    Anyway, what I have is a x96air with s905x3 and 2x16gb. There is a sticker inside that says '2+16+8189 zf191202.
    The box lid has rounded edges with a couple of rows of grooves and has a clock on the front.
    Unfortunatley there isnt much else to identify it. Can anyone help or advise please.

    Comment


      Originally posted by ecobit View Post
      P1, P2, P3 hwersion clean, stable ATV9 rom: https://4pda.ru/forum/index.php?show...#entry91789616
      Try to flash one of the roms in this post. The correct hardware version should flash. Myn is a 4/64 with 1000m Lan which is P2 version.

      Comment


        Originally posted by cdicky View Post
        ...Anyway, what I have is a x96air with s905x3 and 2x16gb. There is a sticker inside that says '2+16+8189 zf191202...
        With this memory configuration you probably need to flash X96Air_V2 version firmware.
        atvXperience on Tanix BOX

        Comment


          unfortunately I need to get to recovery 1st.
          At the moment its dead.
          here are pictures of my board.

          Ive looked at online 'fixes' to get to recovery by shorting pins on the board. but these are all different

          Comment


            Originally posted by cdicky View Post
            unfortunately I need to get to recovery 1st...
            You should get a male to male usb cable and flash image with USB Burning Tool.
            atvXperience on Tanix BOX

            Comment


              I tried that but it wont turn on or connect to pc.

              Comment


                If you can't flash an IMG file through USB burning tool it may not be powering up at all. I'm assuming you know about the reset button in the AV port and keeping it pressed before you connect the UBT cable.

                Comment


                  I had a similar thing (I wrote about it in this thread I believe) I had to 'revive' my P2 model by shorting some pins, somewhere in the centre of the board.
                  I did this whole it was connected to the usb burning tool using the USB 3 port.

                  At that point it came partially back to life, I was able to flash about 45% of the ROM.
                  Obviously not good, but enough, because in the beginning of the ROM is also the recovery partition :-)

                  So, after the partial flash, I could boot into recovery now available in the box, and from there I could load TWRP from SD card, and from there I could restore the dayviet ROM.

                  I consider myself quite lucky it worked like this....

                  I use my P2 box now with the SlimBox ROM from 4PDA. For me the best so far...

                  Maybe this helps.

                  Un saludo,

                  Leo

                  Comment


                    Originally posted by cdicky View Post
                    unfortunately I need to get to recovery 1st.
                    At the moment its dead.
                    here are pictures of my board.

                    Ive looked at online 'fixes' to get to recovery by shorting pins on the board. but these are all different
                    And you must use sharp-pointed tweezers

                    Click image for larger version  Name:	00.png Views:	0 Size:	249.6 KB ID:	800867
                    Attached Files

                    Comment


                      Thank you for the picture. I did read your earlier post which is what inspired me to search on google for more info.
                      It does look like the same board so I'll try more attempts tomorrow.

                      Do you have a link please to the exact rom you used so I dont pick a wrong un.

                      Comment


                        Originally posted by cdicky View Post
                        Do you have a link please to the exact rom you used so I dont pick a wrong un.
                        Im use this firmware(links and descriptions):

                        http://4pda.ru/forum/index.php?showt...#entry92367633

                        Direct link AOSP for P2 mainboard:
                        _mega.nz/#!dEFzjQrA!_G2bNkBx0EEdL6RFwmsYnfUx4VcOwRnmg7OSdAB HQ_8

                        Comment


                          It is with great sadness that today I must report that my x96air passed away last night.
                          This brings the total to 1

                          After some great advice, i spent a full day with it in intensive care. I tried every trick in the book with it hooked up to my life support pc.
                          But to no avail...

                          Unfortunately there was no responce or any signs of life from the poor thing, even after storage in the freezer for a couple of hours, and many attempts at cpu stimulation.
                          In the end late last night I made the decision to end life support and consign some of its components to the parts bin. I knew thats what it would have wanted.

                          It was only 3 months old...sob!
                          R.I.P. little friend

                          I would just like to thank all the well wishers that offerd advise and support.

                          Comment


                            How is the heating problem with this box? Is it so much that I should look at x96 max plus instead? Lags? Freezes and hangs? Are games smooth? Is the wifi good enough? And the custom ron support? Can the good people here help me choose? I am upgrading from h96 max x2 which has pretty bad wifi module

                            Comment


                              my tvbox 2/16 stock firmware is X96Air_20191017-1108.
                              I flash v2 firmware clock it isnĀ“t working. Neither in coreelec.
                              Where can I download stock firmware ?, I need stock to fix it
                              thanks

                              Comment


                                Originally posted by l3g0r View Post
                                Where can I download stock firmware ?
                                CGR, first find out (boot into recovery) wich hardware revison and firmware you have on your tv box.

                                atvXperience on Tanix BOX

                                Comment

                                Working...
                                X