Announcement

Collapse
No announcement yet.

Announcement

Collapse
No announcement yet.

Lollipop - Wasser Firmware for Tronsmart R68 with 100M LAN

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    BeeLink R68 (GigE) Question: Can It Run Wasser Firmware?

    Hi, I am a first time poster and long time reader of the Wasser RK3288 firmware for Beelink/Tronsmart units section of Freakstab. I used Wasser's 2.02 - 2.09A firmware on my RK3288 Tronsmart Orion R28 Meta (2/16 GB) for about a year successfully. Many thanks to Wasser!

    A few days ago picked-up a RK3368 based Beelink R68 (GigE + external antenna + metal enclosure + 2/16 GB) from Amazon ( http://bee-link.com/beelink-product/Beelink-R68-Smart-Android-TV-Box.html ). Not the Beelink i68 which came out first, is in plastic box, has 10/100 Ethernet, and is also based on the RK3368 - and is the twin of the Tronsmart R68.

    I am now running a large 4K Samsung HU9000 Series and the old Tronsmart RK3288 units was having some strange video and audio issues when I set the old Tronsmart box above 1920 by 1020P. The new Beelink seems very nice, and has no problems that I can detect so far running at 4K @60hz.

    One major issue for me is that the Beelink has a 2.5GB of application partition limitation, which isn't going to work for me. You would think if you buy a unit with 16GB, maybe the manufacturer could give you at least 6-8GB or a flexible partition for Apps?

    I would like to make the switch from the Beelink factory firmware to Wasser firmware - Can I switch to the "Wasser Firmware for Beelink/Tronsmart R68 (Lollipop)" on the Beelink R68 (GigE)? The original post says this firmware is for the Tronsmart R68 or Beelink i68, but what about the new Beelink R68? Has anybody done this successfully. I would hate to brick the new box.

    Thanks in advance!
    N900GL
    Junior Member
    Last edited by N900GL; 12-06-2015, 04:56.

    Comment


      Originally posted by bluesmanuk View Post
      My feedback: for 3.1.2

      Smooth UI and general fluidity of usage although when selecting apps to swipe off the screen there can be quite a delay before seeing them appear at times.

      WiFi/Ethernet speeds as for the stock ROM.

      Youtube/OGYoutube 1080p not good. Continual stutter which is not really watchable. Youtube Kodi addon works very well though up to 720p.

      SPDIF playback works with 5.1 and DTS through MX Player and Internal video player and so far unable to find any flaws at all.

      MX Player does seem to have issues with HEVC .TS files though, where there is major lag (no such problem in Kodi)

      Kodi 15.1 RC1/16 Alpha 2/15.1 Wasser works well on the whole. SPDIF passthrough with 5.1/DTS still an issue with only the odd second of sound every few seconds(PCM/AAC all fine though). Frame rate switching, although working, is very slow to change in 15.1 RC1 and 15.1 Wasser which means losing a second or two of the initial video and audio.

      Colour reproduction, although very good is not quite as good as I see on RK3288 and most noticeable in iPlayer where the picture can look very flat and almost cartoonish, so ideally, some contrast, brightness controls would be useful.
      I am agree with u about the colors
      I have tronsmart r28 and r68 and i flashed wasser rom
      And its missing the video advanced settings like brightness contrast.
      In the stock rom these settings are exist
      Pls fix it wasser andtnx for the rom!

      Comment


        What happens if i put Wasser ROM on Tronsmart R68 100M version (the first bulk that came out with 100M Ethernet and not the new Gigabit model) ?

        Comment


          Originally posted by Glouds View Post
          What happens if i put Wasser ROM on Tronsmart R68 100M version (the first bulk that came out with 100M Ethernet and not the new Gigabit model) ?

          It works.

          Before my box fried I was using the ROM on the 100Mb model and it worked rather well and most definitely better than stock.
          R-TV BOX S10, Beebox N3150, Chuwi Hibox, Nvidia Shield, A95X Max

          Comment


            How u fried that box?

            Comment


              Originally posted by bajann View Post
              How u fried that box?

              I was moving things around in my TV cabinet and plugged the wrong ac adapter into the R68 and killed it.
              R-TV BOX S10, Beebox N3150, Chuwi Hibox, Nvidia Shield, A95X Max

              Comment


                Originally posted by bluesmanuk View Post


                I was moving things around in my TV cabinet and plugged the wrong ac adapter into the R68 and killed it.
                Sadly I've done that too.
                Tronsmart R28 PRO with wasser-2.0.7-beelink-r89-rk3288 ROM and MX Player

                Comment


                  Hi

                  Sorry I am new to tronsmart and have an issue after flashing this firmware

                  I bought the box and my video was stuttering so thought I'd try this.

                  All went well but then when I tried it my wifi and Bluetooth stopped working.

                  Went back to stock, same issue

                  The WiFi switches on and back off without actually looking for signals. Same with Bluetooth.

                  I left the box off over night and switched it on and all of a sudden I could see wifi signals available.

                  Once I tried connecting it went back to the same same state as before.

                  Please help

                  Comment


                    Originally posted by notz View Post


                    Wifi & Bluetooth is not working with this rom on Beelink i68. It's working with default Tronsmart Rom and also if build my own rom from sdk.

                    D/CommandListener( 190): Setting iface cfg
                    D/CommandListener( 190): Trying to bring down wlan0
                    D/CommandListener( 190): Clearing all IP addresses on wlan0
                    E/WifiMonitor( 478): killSupplicant p2ptrue init.svc.wpa_supplicant=unknown init.svc.p2p_supplicant=unknown
                    D/RkWifiCtrl( 478): check_wifi_chip_type_string: AP6335
                    D/RkWifiCtrl( 478): Kernel version is 3.10.
                    D/RkWifiCtrl( 478): Kernel version is 3.10.
                    D/WifiHW ( 478): wifi_start_supplicant: p2p_supplicant
                    D/WifiMonitor( 478): startMonitoring(wlan0) with mConnected = false
                    E/WifiHW ( 478): Unable to open connection to supplicant on "@android:wpa_wlan0": No such file or directory
                    I/wpa_supplicant( 2885): Successfully initialized wpa_supplicant: for broadcom wifi
                    I/wpa_supplicant( 2885): rfkill: Cannot open RFKILL control device
                    D/PowerManagerService( 478): screen time out
                    E/wpa_supplicant( 2885): Could not set interface wlan0 flags (UP): Operation not permitted
                    E/wpa_supplicant( 2885): nl80211: Could not set interface 'wlan0' UP
                    E/DrmService( 195): [wlan0] interface is not ready, wait 300000us
                    E/wpa_supplicant( 2885): wlan0: Failed to initialize driver interface
                    E/WifiHW ( 478): Supplicant not running, cannot connect
                    E/WifiHW ( 478): Supplicant not running, cannot connect
                    E/WifiHW ( 478): Supplicant not running, cannot connect
                    I have the same issue

                    Did you manage to fix this as I'm stuck

                    Comment


                      After spending hours trying to figure out the "Wait for Loader Fail" error I upgraded to the latest beta firmware on Tronsmart's website. This finally got around the issue. But it seems like the Factory Tool won't let me go backwards in rom version. I can't install old Tronsmart or older Wasser roms. Does anyone have any suggestions?
                      Tronsmart R28 PRO with wasser-2.0.7-beelink-r89-rk3288 ROM and MX Player

                      Comment


                        Originally posted by amclean123 View Post
                        After spending hours trying to figure out the "Wait for Loader Fail" error I upgraded to the latest beta firmware on Tronsmart's website. This finally got around the issue. But it seems like the Factory Tool won't let me go backwards in rom version. I can't install old Tronsmart or older Wasser roms. Does anyone have any suggestions?

                        I've often found that erasing the nand resolves any issues going to and from ROM's where there are issues.

                        Changes in bootloader version can also cause issues if there is a mismatch.
                        R-TV BOX S10, Beebox N3150, Chuwi Hibox, Nvidia Shield, A95X Max

                        Comment


                          Has anyone else experienced not being able to connect with ethernet after installing the latest Wasser firmware (3.1.2) on the R68 Meta Gigabit model? My wifi works fine, but I get all zeros in my ethernet properties even though the cable is plugged in and it is set to DHCP. Additionally, if I set the IP mode to static, it doesn't allow me to change any of the settings. Any assistance would be greatly appreciated.

                          Comment


                            I had the same but after flashed this everthing working O.K.

                            [ROM] Tronsmart Orion R68G_205L_151110.img ( Nov 28, 2015 )





                            Originally posted by xwingfighter View Post
                            Has anyone else experienced not being able to connect with ethernet after installing the latest Wasser firmware (3.1.2) on the R68 Meta Gigabit model? My wifi works fine, but I get all zeros in my ethernet properties even though the cable is plugged in and it is set to DHCP. Additionally, if I set the IP mode to static, it doesn't allow me to change any of the settings. Any assistance would be greatly appreciated.

                            Comment


                              Originally posted by xwingfighter View Post
                              Has anyone else experienced not being able to connect with ethernet after installing the latest Wasser firmware (3.1.2) on the R68 Meta Gigabit model? My wifi works fine, but I get all zeros in my ethernet properties even though the cable is plugged in and it is set to DHCP. Additionally, if I set the IP mode to static, it doesn't allow me to change any of the settings. Any assistance would be greatly appreciated.
                              I don't think wasser's ROM includes Ethernet drivers for the gigabit models, only the 100mbit models are supported

                              Comment


                                brenas25 and shiznit...thanks for the responses. I am actually quite pleased with the Wasser firmware; would be disappointed if there are no gigabit drivers available, but will continue using it over wifi as it solved the issues I had where the Kodi version couldn't be updated past 15.2rc1 and the ChrisB's Beast wouldn't load properly.

                                Comment

                                Working...
                                X