Unconfigured Ad Widget



No announcement yet.

NAND Chip Mask ROM Mode Short Location

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

    Hi thank for the reply do I do this when power is off or on?
    can you guide me how to go about short pining it thank


      Here's the way I do it:
      • Disconnect everything from the device and open up the case. Expose pins to eMMC.
      • Launch USB Burning Tool and load burn package. Hit the Start button.
      • Connect USB cable to USB OTG port.
      • Start shorting adjacent pins on the eMMC using a test probe or tiny metal screwdriver. Hold each for at least a second.
      When you get the right pins, you'll heard the sound of the WorldCup driver discovering the device and USB Burning Tool will automatically begin to flash the burn package.


        Any suggestions for me and my mx9 pro?


          hi usb burner didn't work driver didn't install. i was able to short pin it using boot card maker but the green light only goes a bit and stop
          so now i'm thinking i don't have the right firmware any idea which firmware will work ?


            hey i retry the usb burning tool i did get driver to install and short pin it i heard the sound but notting happen i did put image first hit start and short pin it sound came but notting happen


              There is a stick MK809-4K. Who knows how to switch to the maskrom mode?
              NAND Flash in BGA formfactor: SAMSUNG KLM8G1GEAS-B001.
              Click image for larger version  Name:	mk809-4k.jpg Views:	1 Size:	112.9 KB ID:	693513


                Originally posted by Magendanz View Post
                For the Alfawise S92 (q201 ref board):
                Seems to be the same for GT1 Ultimate (SN A706D0), It's true?

                Founded another pins (picture 3) but I'm not sure.

                Could anyone help me. Thanks!!!


                  Originally posted by Alpetrus View Post

                  Which pins should I short in this chip?

                  Chip: SanDisk SDINADF4-32G
                  TV Box T95Z Plus, Amlogic S912, 3GB/32GB, Wifi LTM8830

                  I can not boot into recovery mode.
                  USB Burning Tool shows errors:
                  [0x10105002]Romcode/Initialize DDR/Read initialize status/USB Control setup error
                  [0x10302001]Romcode/Switch status/Check connect/Enum device

                  Thanks in advanced for reply.
                  I cannot connect thru USB Burning tool and by using the toothpick method, what else can I do?
                  Where is pins to short on this chip? thanks in advance


                    Hi guys,

                    I have a MXQ 4k with R329Q_V.2.0 board. This one was of a friend of mine who gave it to me bricked, with a non working firmware on it.

                    I've flashed it tons of times, most of the time with wrong firmware, always using the short pin mode to enter in MASKROM mode. Never had a problem.

                    One day I've flashed a firmware (I don't remember which one) and now my box enter in MASKROM mode only by connecting the usb port to the pc (so without shorting any pins) and when I try to flash it, the flashtool gives me the infamous "Prepare IDB FAIL".

                    I suppose I have a faulty NAND now.

                    Anyone can help me with this?



                      Mam Z28 PRO i jest zamurowany. Które szpilki są skrótem dla trybu MASKROM

                      I found how someone would need it Photo 3
                      Last edited by sw224; 12-17-2017, 08:26.


                        Mask ROM mode
                        who knows more about this Mecool bb2 pro I disassembled I will get UART-USB CABLE
                        and I'm connecting to the computer with which program to load on mecool and which software I download.
                        I attach images to the motherboard

                        confirm if I think correctly

                        thank you


                          hi! i have a5x max+ 4g/32g Fn-Link 6222B-SRB wifi bluetooth module and did flash it on USB-4 right next to AV/reset. unfortunately, loader failed and now it is now bricked. tried the suggested short-pins but cannot detect the maskrom device. so m still looking for the correct pins to short to enter the mask mode and re-flash it. anyone knows this?

                          Click image for larger version

Name:	A5X Max+ mBoard_Samsung 32GB eMMC KMV2W00LM-B506.GIF
Views:	7540
Size:	151.2 KB
ID:	698217
                          Attached Files
                          Last edited by gidabytes; 01-01-2018, 13:35.


                            the boot loop issue on A5X Max has still the bootloader which is easily can be detected using male to male USB cable whereas mine has no way to detect its bootloader. tried using the jtag fix to boot on mmc but cannot boot on microsd. will buy the PL2303 TA USB Cable to use other method, sad that i will receive the item after a month. So i still looking for the trick on how to enter the emmc rom in maskmode.


                              Hello. I need to unbrick the MXQ 4k (not pro version) with the chip RK3229. I don't know which pins are to shortcut. NAND is a Essencore 13t-8gq8t2h5tarc

                              Here are the photos:

                              Last edited by Mike1832; 12-21-2017, 14:20.


                                Originally posted by Mike1832 View Post
                                Hello. I need to unbrick the MXQ 4k (not pro version) with the chip RK3229. I don't know which pins are to shortcut. NAND is a Essencore 13t-8gq8t2h5tarc

                                Here are the photos:

                                You should shorts these two pins (7 and 8) while you put the USB cable in the PC with the red circle.

                                After a second, a tool like AndroidTool should recognize your board in MASKROM mode.

                                Attached Files